Can't add PIN, can't reset PIN RRS feed

  • Question

  • I am running PC build 14379. I'd like to change my login method from password to PIN, but I can't. Here's what happens:

    I go to Accounts, Sign In Options. Under PIN, there's an Add button. I click it,

    Next I get a "We need  to verify your identity" screen that prompts me for the PIN I don't have.

    If I click "I forgot my PIN", I get a message saying I can reset my PIN by going to Accounts > Sign-in Options - which is where I am and there's no option to reset a PIN.

    Sometimes this screen says "Use another method". When I do that it prompts me for my password and then I'm back to the PIN prompt.

    On another Win10 system (not Insider build) I set a PIN and that works fine. The PIN I used there isn't recognized here.

    How do I get out of this infinite loop?  The behavior has been consistent for the last several builds. I did report it through Feedback earlier. Thanks.

    Sunday, July 31, 2016 12:05 AM

All replies

  • Open C:\Windows\ServiceProfiles\LocalService\AppData\Local\Microsoft\NGC.
    • In NGC folder delete all the files. To do so you must be logged as Administrator.
    • Open  Settings > Accounts > Sign-in Options.
    • Click Add a PIN and add a new PIN code for your account.

    S.Sengupta, Windows Experience MVP

    • Proposed as answer by Tonofun Wednesday, May 17, 2017 9:39 AM
    Sunday, July 31, 2016 12:38 AM
  • Thank you!  This sorted out my problem, that the 'I forgot my pin' option didn't even exist.
    Wednesday, May 17, 2017 9:40 AM
  • I do not have access to this directory even though I have the administrator access.   How do I get access to his directory?
    Sunday, October 1, 2017 4:33 PM
  • I'm having the same problem, but like the person above me I can't get access to that folder, even with administrator privileges.  I tried to go to the security tab to change permissions but could not figure out how to do so.
    Monday, November 13, 2017 1:43 PM
  • I have the exact same problem. I can't delete the folder. I am an administrator, but I still can't delete it.  Please help? Any ideas?
    Wednesday, January 3, 2018 4:08 AM
  • Hi Josh,

    Please take owner of the folder with the following command line.(make sure you run command with administrator right).

    takeown /f filename /d y
    icacls filename /grant username:F /q


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, January 12, 2018 10:39 AM
  • As usual the suggested fix doesn't work. I really wonder if the people proposing these so-called fixes actually try them first. Just a waste of time.

    Wednesday, March 21, 2018 1:08 PM
  • Thank you - this worked for me.

    Had to step through a few security setups before I could read and then delete the files.

    Monday, April 2, 2018 1:02 AM
  • i have change to admin and such but still cant erase files/folders inside the NGC folder!
    Saturday, April 14, 2018 9:26 AM
  • I dont have an "AppData" folder

    Thursday, May 10, 2018 2:50 PM
  • I had the same issues and could not delete the folder or any subfolders.   Instead, I renamed the first folder inside of NGC with an underscore at the end.   This allowed me to set up a new PIN.
    Tuesday, December 11, 2018 5:10 PM
  • can't delete, but indeed can rename the folder. the folder is named like {1234-abcd-blah-blah}
    after renaming, can create new PIN

    microsoft sucks.

    Sunday, January 5, 2020 4:23 PM