none
Hyper-V Manager on Win10 RRS feed

  • Question

  • I've just finished installing a brand new machine which is loaded with Win10 (I used to have Win7 on the previous Machine).

    I cannot make Hyper-V Manager work.

    I've run WSManConfig: Microsoft.WSMan.Management\WSMan::localhost\Client and I (think) I have successfully added the VM server to the list - I assume the syntax is ComputerName.Domain.Fully Qualified.Name so if my VM machine is called VMHOST and it is in the Domain OFFICE and the fully qualified name is office.co.uk the synatax should be :-

    set-item wsman:\localhost\Client\TrustedHosts -value VMHOST.OFFICE.office.co.uk 

    what I see is:-

    Type            Name                           SourceOfValue   Value
    ----            ----                                    -------------   -----
    System.String   TrustedHosts                                   VMHOST.OFFICE.office.co.uk

    Is it normal to have a blank under SourceOfValue?

    When I try to run up Hyper-V Manager:

    I get the error: "An error occurred while attempting to connect to server...."

    As far as I can tell the Virtual Machine Management Service is running

    In the list of services I see: Hyper-V Virtual Machine Management - Running Automatic

    So where have I gone wrong? Can anyone help please?

    Jean

    Saturday, March 10, 2018 12:19 AM

All replies

  • More research has not got me far: all I need to do is to connect from the Win10 to the 3 VMs on the VM server.

    We have two WORKGROUPS DOMESTIC OFFICE 

    With Win7 The client machine was in the DOMESTIC workgroup and the VM HOST in the OFFICE workgroup

    On the VM server I am an administrator with exactly the same credentials on the Win7 and the VH HOST

    This is what I have done on the new Win10 machine.

    Now the error message is less daunting as it now says "Check Virtual Machine Management service is running" - it is and then it says "You do not have the required permission etc..." 

    Since I am the same person (same creds) on both machines I don't see what else I am supposed to do.  

    Hope someone can come to my rescue.

    Jean

    Saturday, March 10, 2018 11:38 AM
  • what OS is the host?
    as this is not in a domain: did you use "Enable-PSRemoting" and "Enable-WSManCredSSP -Role server" on the VM host?
    I used this: Remotely manage Hyper-V hosts with Hyper-V Manage to get it running with Windows 10 as VM host and Windows 10 as VM manager in a non-domain setup.

    SourceOfValue is empty on my system, too,
    • Edited by EckiS Saturday, March 10, 2018 1:20 PM
    Saturday, March 10, 2018 1:18 PM
  • Windows server 2012 R (no GUI)

    I didn't - unless I had done 3 years ago when I set this up! 

    It was too easy with win7 ...  I will do as you suggest 

    I ran Enable-PSRemoting and:-

    WinRM is already set up to receive requests on this computer.
    WinRM has been updated for remote management.
    Configured LocalAccountTokenFilterPolicy to grant administrative rights remotely to local users.

    So I ran the second command:

    PS C:\Users\citrixmanager> Enable-WSManCredSSP -Role Server

    CredSSP Authentication Configuration for WS-Management
    CredSSP authentication allows the server to accept user credentials from a
    remote computer. If you enable CredSSP authentication on the server, the server
     will have access to the user name and password of the client computer if the
    client computer sends them. For more information, see the Enable-WSManCredSSP
    Help topic.
    Do you want to enable CredSSP authentication?
    [Y] Yes  [N] No  [S] Suspend  [?] Help (default is "Y"): y

    But no change from the client machine (Win10) I still get the same error message when I try to run hyper-V management console.

    Jean

    Saturday, March 10, 2018 7:33 PM
  • First I didn't thank you for your post - What I have now done is to create another profile on the Win10 machine with exactly the same credentials (I thought I'd done it before but this was "just in case") and now I can enter the name of the VMSERVER but get the "access denied. Unable to establish communication between "VMSERVER" and "CLIENT" which is a huge step forward - now all I have to do is try to figure out what needs to be done to establish the communication! Any ideas...  Jean
    Saturday, March 10, 2018 9:16 PM
  • I am sorry, I only got this running once so don't know what might be the problem.
    the link I posted contains some more info in the comments, perhaps you can find something there.
    Sunday, March 11, 2018 8:26 PM