none
Hypervisor not running RRS feed

  • Question

  • Dell Latitude 3150
    CPU XD Support Enabled 
    Intel Virtualization Technology Enabled 
    Intel CPU N3540 2.16GHz
    8 GB RAM 
    Server 2012 R2 installed 

    Hi there all,
    I installed Hyper-V Gen 1 and created a sample VM by all default options but the VM won't start, "because the hypervisor is not running".
    However, I installed VMWARE workstation pro and created a couple VMs and Installed some guest OS into those VM without problem.
    "Hyper-V Virtual Machine Management" is running.
    I suppose the hardware no problem because VMWARE running without issue, what causes this issue? Any suggestions are appreciated!


    • Edited by BrianEhMVP Friday, January 6, 2017 12:11 AM real issue
    • Moved by BrianEhMVP Friday, January 6, 2017 12:11 AM
    Thursday, January 5, 2017 11:41 PM

All replies

  • Hyper-V and Workstation are different types of hypervisors, so its not a totally accurate conclusion that if one works, the hardware is ok.

    The table here: https://ark.intel.com/products/82105/Intel-Pentium-Processor-N3540-2M-Cache-up-to-2_66-GHz

    for your CPU makes no mention of EPT, which is required for Hyper-V.

    Download coreinfo here: https://technet.microsoft.com/en-us/sysinternals/cc835722.aspx?f=255&MSPPError=-2147217396

    run "coreinfo -v" from a cmd prompt

    You should get something like this as a result:  

    Intel(R) Core(TM) i7 CPU       X 980  @ 3.33GHz
    Intel64 Family 6 Model 44 Stepping 2, GenuineIntel
    HYPERVISOR      -       Hypervisor is present
    VMX             *       Supports Intel hardware-assisted virtualization
    EPT             *       Supports Intel extended page tables (SLAT)

    You need to have the * for both VMX and EPT (* means present, - means not present)

    If Hyper-V is installed correctly, you'll see something this:

    Intel(R) Core(TM) i3-4160T CPU @ 3.10GHz
    Intel64 Family 6 Model 60 Stepping 3, GenuineIntel
    HYPERVISOR      *       Hypervisor is present
    VMX             -       Supports Intel hardware-assisted virtualization
    EPT             -       Supports Intel extended page tables (SLAT)

    Friday, January 6, 2017 12:12 AM
  • Thank you for your quick response, run "coreinfo -v" got below:

    Intel(R) Pentium(R) CPU  N3540  @ 2.16GHz
    Intel64 Family 6 Model 55 Stepping 8, GenuineIntel
    Microcode signature: 00000829
    HYPERVISOR - Hypervisor is present
    VMX       * Supports Intel hardware-assisted virtualization
    EPT       * Supports Intel extended page tables (SLAT)

    is this a correct result? otherwise my machine won't support Hyper-V?

    I am beginner of Hyper-V and I need to set up a server to learn Hyper-V, what cheaper laptop or CPU can meet my needs? please advise, thanks. 

    Friday, January 6, 2017 12:56 AM
  •   Did you have Hyper-V and VMWare installed at the same time? You would have had trouble running 64-bit guests in VMWare if the hypervisor was running.

     I cannot think of any reason why this does not work for you. I would remove the Hyper-V role and after a reboot, install it again.

      Before you go any further after that, run bcdedit /enum from a command prompt with admin privilege. Check that the hypervisorlaunchtype parameter is set to Auto.  If it is set to off, the hypervisor will not load.


    Bill

    Friday, January 6, 2017 2:01 AM
  • No, I haven't install VMWARE in this moment, I also did bcdedit:

    Windows Boot Manager
    --------------------
    identifier              {bootmgr}
    device                  partition=C:
    description             Windows Boot Manager
    locale                  en-US
    inherit                 {globalsettings}
    bootshutdowndisabled    Yes
    default                 {current}
    resumeobject            {85c0e939-cf23-11e6-ae67-87733f945d87}
    displayorder            {current}
    toolsdisplayorder       {memdiag}
    timeout                 30

    Windows Boot Loader
    -------------------
    identifier              {current}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Windows Server 2012 R2
    locale                  en-US
    inherit                 {bootloadersettings}
    recoverysequence        {85c0e93f-cf23-11e6-ae67-87733f945d87}
    recoveryenabled         Yes
    allowedinmemorysettings 0x15000075
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {85c0e939-cf23-11e6-ae67-87733f945d87}
    nx                      OptOut
    hypervisorlaunchtype    Auto

    I have two error event ids from Hyper-V-VMMS: 1. 20148, 2. 15130

    any idea?



    Friday, January 6, 2017 2:21 AM
  •   Do you have any idea? You have seen the error events. I have not.


    Bill

    Friday, January 6, 2017 6:27 AM
  • There has been some progress, I installed Server 08 R2 on same machine then Hyper-V then VM, it started!
    I will reinstall Server 12 R2 tonight to see what gonna happen, thank you for your help anyway!
    Friday, January 6, 2017 7:19 AM
  • no lucky, same issue after reinstalled a flesh srv 2012 r2, any help? please?!
    Friday, January 6, 2017 8:10 AM