none
Could not load file or assembly 'Oracle.DataAccess, Version=2.102.2.20, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified RRS feed

  • Question

  • Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Configuration Error 
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

    Parser Error Message: Could not load file or assembly 'Oracle.DataAccess, Version=2.102.2.20, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified.

    Source Error: 


    Line 31: <compilation debug="true">
    Line 32: <assemblies>
    Line 33: <add assembly="Oracle.DataAccess, Version=2.102.2.20, Culture=neutral, PublicKeyToken=89B483F429C47342" />
    Line 34: <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    Line 35: <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
     

    Source File: D:\AverySignatureBinders\httpsdocs\ASBNet\web.config    Line: 33 

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Oracle.DataAccess, Version=2.102.2.20, Culture=neutral, PublicKeyToken=89b483f429c47342' could not be loaded.


    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

     
    Thursday, October 2, 2014 5:57 PM

Answers

  • For Adapter Pack 2013 the following Oracle Client(s) are needed:

    Supported client versions: Oracle Data Access Components for Oracle Client 12.1, Oracle Data Access Components for Oracle Client 11.2.0.1

    And please bear in mind that both the 32- and 64 bit versions are needed.

    Morten la Cour

    • Marked as answer by Angie Xu Thursday, October 9, 2014 1:36 AM
    Saturday, October 4, 2014 6:03 AM

All replies

  • Is the appropriate Oracle Client installed?
    Thursday, October 2, 2014 6:01 PM
  • Like Johns-305 said appers to be a GAC issue. Please check if it is present there, in case you have more than one server check elsewhere as well.

    Regards

    Thursday, October 2, 2014 8:20 PM
  • Hello,

    I recommend you to use the managed Oracle DataAccess http://www.oracle.com/technetwork/topics/dotnet/whatsnew/index.html

    It like 10MB and you only have to run the configure.bat. 

    As Oracle always changes the Version Number, you probably have to change your config file in order to make everything work.

    Best Regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com

    Friday, October 3, 2014 9:36 PM
  • For Adapter Pack 2013 the following Oracle Client(s) are needed:

    Supported client versions: Oracle Data Access Components for Oracle Client 12.1, Oracle Data Access Components for Oracle Client 11.2.0.1

    And please bear in mind that both the 32- and 64 bit versions are needed.

    Morten la Cour

    • Marked as answer by Angie Xu Thursday, October 9, 2014 1:36 AM
    Saturday, October 4, 2014 6:03 AM
  • I ran into this problem while setting up a new development pc, and it took me a few moments to realize why; the error message is not particularly helpful, and the fix isn't in the registry;

    You might have to set the application pool for your site in IIS to allow 32bit applications if you're using a 32-bit Oracle connector (even on a 64-bit system). The application pool is 64-bit by default.

    Right-click on the Application Pool > Advanced Settings > 'Enable 32-bit Applications' set that to true. Fixed it for me.

    Wednesday, June 3, 2015 1:39 PM