none
Outlook 2010 Search Not Working

    Question

  • Hi All,

    After resequencing office a number of times and following the AppV recipie at http://support.microsoft.com/kb/983462 I still can't get Outlook 2010 to play nicely.

    My sequencing and operating environment is Windows 7 32-bit.

    I have configured the proxies according to the AppV recipie and run the client installer but I still cannot get it to work.

     

    msiexec /i C:\offvirt.msi ADDDEFAULT="Click2runOneNoteProxy,Click2runOutlookProxies,Click2runWDSProxy,Click2runOWSSuppProxies" PACKAGEGUID="{782EF558-1977-466C-B5A8-0975B2996E67}" PACKAGEVERSION=14.0.4755.1000 OUTLOOKNAME="Microsoft Outlook 2010" ONENOTENAME="Microsoft OneNote 2010" MAPISERVER="Microsoft Virtual Office Simple Mapi Proxy Server" VIRTUALSEARCHHOST="Search MAPI Protocol Handler Host" MLCFG32CPL="Windows Control Panel" OWSSUPPServer="Microsoft SharePoint Client Support Manager"

     

    Is what I use to install the deployment kit and all the values in the arguments are 100% correct.

    However the actual registry keys do not reflect what I have entered into the Arguments.

    When looking at "HKLM\Software\Microsoft\Office\14.0\CVH\" keys they all have strange values.

    "Click2runOutlookProxies\MapiProxyServer" for example is set to "C:\Program Files\Microsoft Application Virtualization Client\sfttray.exe" "Simple MAPI Proxy Server "

    This is obviously wrong as it's not what I specified. I corrected these manually to:

    "C:\Program Files\Microsoft Application Virtualization Client\sfttray.exe" "Microsoft Virtual Office Simple Mapi Proxy Server 14.0.4755.1000"

    In an attempt to get it to work and the AppV client succeeded in starting the "Search MAPI Protocol Handler".

    Despite this no matter what I search for and where I search for it I get "No matches".

    It does appear to index the items but doesn't appear to be able to contact desktop search to even try to get a response.

     

    Any help would be much appreciated!

    Wednesday, May 26, 2010 4:50 AM

Answers

  • OK.

    Because there are a few other people who have described this problem and not told of the solution I'm going to go ahead and tell you whats up if you have this issue.

     

    It goes back to how MSIEXEC handles the properties.

     

    If you do not run CMD (or the batch file you use to run MSIEXEC) as an administrator MSIEXEC is launched as a user, then it escalates when it is ready to install.

    As part of that escalation it blows away all your custom properties. Thus resetting the defaults and not setting the right keys.

     

    Therefore the solution is that you MUST, MUST, MUST, run the process that calls MSIEXEC as an administrator. So that MSIEXEC is already elevated and keeps your properties.

    I hope this helps someone out there as it certainly helped me!

    • Marked as answer by Stubbers Monday, July 26, 2010 5:28 AM
    Thursday, May 27, 2010 1:23 AM

All replies

  • OK.

    Because there are a few other people who have described this problem and not told of the solution I'm going to go ahead and tell you whats up if you have this issue.

     

    It goes back to how MSIEXEC handles the properties.

     

    If you do not run CMD (or the batch file you use to run MSIEXEC) as an administrator MSIEXEC is launched as a user, then it escalates when it is ready to install.

    As part of that escalation it blows away all your custom properties. Thus resetting the defaults and not setting the right keys.

     

    Therefore the solution is that you MUST, MUST, MUST, run the process that calls MSIEXEC as an administrator. So that MSIEXEC is already elevated and keeps your properties.

    I hope this helps someone out there as it certainly helped me!

    • Marked as answer by Stubbers Monday, July 26, 2010 5:28 AM
    Thursday, May 27, 2010 1:23 AM
  • I am having the same issue with OFFICE 2010 and not being able to search.  In order to fix the issue with the answer above does anyone know if you can update the package or would it be best to start from scratch with a new package?  I am assuming that I need to start from scratch.
    Thursday, May 27, 2010 4:23 PM
  • Hello,

    Active upgrade should work.

    See this post;

    http://social.technet.microsoft.com/Forums/en-US/appvgeneralsequencing/thread/ffbbfb10-a550-4605-9a6a-bf61fe8940f8

    There are very good documentation links - and instructional videos aswell.
    /Znack

    Thursday, May 27, 2010 9:16 PM
  • Try creating a CVH.reg file and populate the keys with your package GUID and versions:

    x86

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\CVH]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\CVH\Click2RunFilterPack]

    @=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\CVH\Click2runOneNoteProxy]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "OneNote"="\"C:\\Program Files\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Microsoft OneNote 2010 092210A\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\CVH\Click2runOutlookProxies]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "MapiProxyServer"="\"C:\\Program Files\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Microsoft Virtual Office Simple Mapi Proxy Server 092210A\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\CVH\Click2runOWSSuppProxies]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "ProxyServer"="\"C:\\Program Files\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Microsoft SharePoint Client Support Manager 092210A\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\CVH\Click2runWDSProxy]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "WDSProxyServer"="\"C:\\Program Files\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Search MAPI Protocol Handler Host 092210A\""

    x64

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\CVH]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\CVH\Click2RunFilterPack]

    @=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\CVH\Click2runOneNoteProxy]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "OneNote"="\"C:\\Program Files (x86)\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Microsoft OneNote 2010 092210A\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\CVH\Click2runOutlookProxies]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "MapiProxyServer"="\"C:\\Program Files (x86)\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Microsoft Virtual Office Simple Mapi Proxy Server 092210A\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\CVH\Click2runOWSSuppProxies]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "ProxyServer"="\"C:\\Program Files (x86)\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Microsoft SharePoint Client Support Manager 092210A\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\CVH\Click2runWDSProxy]

    @="{83287C5A-4D30-4708-8C97-C65CE31FA8D0}"

    "WDSProxyServer"="\"C:\\Program Files (x86)\\Microsoft Application Virtualization Client\\sfttray.exe\" \"Search MAPI Protocol Handler Host 092210A\""

    Tuesday, October 05, 2010 5:54 PM
  • Hi all. 
    I have tried all the possible solutions on tons of different forums and eventually found one thing that works across the board. I followed the steps above being :
    • Control panel -
    •  Programs - 
    • Turn Windows Features on/off - 
    • Turned windows search off and indexing on. then wait for changes to take effect. Do a restart. open outlook and do a search. 
    Then after finding a few things, go to : 
    • Control Panel - 
    • Programs - 
    • Turn Windows Features on/off - 
    • Turn Windows search back on and leave indexing on. 
    Let new settings take effect and then restart again. During restart power down/up you will see 'Windows is Configuring....%' . That means it is (should be) working. After the restart, open outlook and let it index completely. This should do the trick. ( It did it for me) .
     DON'T FORGET to check all the indexing folders are correct before doing this. This can be done in outlook search options - index folders - modify.
    Hope this helps.

    Regards, Paul Bristow Proudly South African
    Tuesday, September 27, 2011 3:51 PM
  • Hi all. 
    I have tried all the possible solutions on tons of different forums and eventually found one thing that works across the board. I followed the steps above being :
    • Control panel -
    •  Programs - 
    • Turn Windows Features on/off - 
    • Turned windows search off and indexing on. then wait for changes to take effect. Do a restart. open outlook and do a search. 
    Then after finding a few things, go to : 
    • Control Panel - 
    • Programs - 
    • Turn Windows Features on/off - 
    • Turn Windows search back on and leave indexing on. 
    Let new settings take effect and then restart again. During restart power down/up you will see 'Windows is Configuring....%' . That means it is (should be) working. After the restart, open outlook and let it index completely. This should do the trick. ( It did it for me) .
     DON'T FORGET to check all the indexing folders are correct before doing this. This can be done in outlook search options - index folders - modify.
    Hope this helps.

    Regards, Paul Bristow Proudly South African

    Sadly, this one did not work for me. I, too, have tried dozens of suggestions, none of which has worked. Does anyone else have a suggestion? Should I uninstall and reinstall Office 2010? I've run repair, rebuild and scanpst multiple times to no avail. I cannot search AT ALL.

    Thanks

    Tuesday, October 18, 2011 6:26 PM
  • My search utility stopped working all of a sudden. After trying all of these suggestions without success, I just reinstalled windows search 4.0 and it fixed it.

    Tuesday, November 29, 2011 1:32 PM
  • DarkAng3LS's process work for me!
    Monday, March 26, 2012 2:47 AM
  • Brilliant, thanks, tried lots of things as others have done, and this worked first time.  Cheers
    Thursday, April 05, 2012 1:02 PM
  • NOw we are talking about the search inside outlook. the one for email addresses and emails them

    selves and NOT the main search down by the Microsoft button??????????????????????

    Saturday, October 20, 2012 12:49 PM
  • IT WORKED

    If you ever get to Louisiana i will buy you a beer.

    THANK YOU- I have been fighting this for several weeks and the sequence you suggested worked for the search inside Outlook 2010.

    Thank You

    Arr

    Saturday, October 20, 2012 2:06 PM
  • From my experience. This answer from DarkAng3LS seems to work for most clients with this problem.
    Thursday, November 08, 2012 4:27 PM