none
IronCAD 11

    General discussion

  • To provide some helpful advice to anybody searching for an answer in the future.  After many failed and botched attempts to get IronCAD 11 to sequence, I finally got it to work.  Since i wasn't able to find any information about it elsewhere I wanted to post something to help those would-be sequencers and at least get a thread started for the experiences.

    My problems/symptoms included: two complete lock ups of the sequencing machine when running the MSI directly, requring a hard reboot of the machine;  Running setup.exe produced a BSOD consistently; dry runs (installs withOUT running the seqeuencer) worked fine. 

    Solution:  I ended up disabling McAfee Enterprise's OnAccess Scanner, blue screens went away, installer finished successfully, and the sequencer seems to be happy with it. 

    Yes, disabling A/V software should probably be standard fare for sequencing, but I'm more apt to trying to keep the sequencing environment as close to the deployment environment as possible.  Anyway, it'll be higher up on my list of things to try when experiencing similar errors in the future, i just wanted to document my experience for anybody else's benefit.
    Tuesday, February 3, 2009 3:02 PM

All replies

  • Hello,

    One heads up:
    I used to have AV on the sequencer, well, because just like you I wish to have a very client-like environment.
    Obviously performance was lost, but then again this was acceptable.

    Now, I made a snap-shot and probably use it for about 6 months until I updated it with any changes applied to the environment.
    So everytime I reset to base-snapshot - the client was 6 months old.
    The antivirus then began updating itself. And reinstalling itself. And what not.

    Like any self-updating software, automatic updates should be disabled (and offline files, and bla bla bla).
    Worst case, you will have some AV-services within the sequence (I actually managed that once, redid that sequence pretty quick).

    /Znack
    Wednesday, February 4, 2009 11:22 AM
  • I have found there are a couple of additional steps to get IronCAD 11 to run successfully in AppV.  Here is what I needed to do to get it to run without a Visual C++ runtime error.

    - Remove Antivirus

    - Obtain vcredist.msi  and copy to local install file directory (I ran vcredist_x86.exe on a different machine and went into %temp% while the screen was open)

    - Install the vcredist locally on the machine (ours was built into the base image)

    - Begin monitoring

    - Run Ironcad11.msi. During install it will ask for the source location for vcredist.msi, saved previously

    - Stop Monitoring (I didn't launch the application while sequencing and I loaded everything into FB1)

    - In the Sequencer tabs

            - Remove User section of the Registry

            - Remove Windows SxS Folders for VC80 from Registry section (since it is installed locally this shouldn’t be in the Virtual Package)

    - Save package

    - Add the Local_Interaction_Allowed = TRUE tag to the OSD file

    Friday, February 27, 2009 7:16 PM