none
0A-0000800C Error

    Question

  • Error message when you try to use SoftGrid Client Management to start an application or to refresh a Desktop Configuration Server: "Error code: xxxxxx-xxxxxx0A-0000800C"

    The SoftGrid Client failed to download MIME information from {server_name}.

    Microsft's Solution-

    This problem occurs when you are refreshing a Desktop Configuration Server. In this scenario, the problem may occur if the SoftGrid Virtual Application Server’s database server is unavailable.

    What I found -

    Check the SFT_SOFTGRIDSERVER environment variable by right clicking my computer, going to properties. Click the advanced tab and go to the “Environment Variables” button at the bottom. Scroll through the list of system variables. If the SFT_SOFTGRIDSERVER variable is not there, click the new button and add the variable, with value equaling your softgrid server.

    If your 800C error is isolated to one client machine, this fix should solve your problem.

    Tuesday, May 20, 2008 1:19 PM

Answers

  •  

    Pierre,

    I didn't try disabling "Enforce Access Permission..." anymore but I fixed my problem over here by going through all published apps in the SFT console and removed all references to old/no longer existing groups. Trust me , there were a lot of old groups assigned to apps also still pointing to a domain, no longer being used.

     

    After this i stopped the Softgrid VAS services, cleared the SFT-SERVER.LOG and restarted the service. Went to my client, logged in and the auto refresh kicked in and my startmenu was populated before i even got to the softgrid client console.

     

    And this client has the original timeout os 20secs

     

    Tested with all my terminal servers with 20secs timeout and it works perfectly again.

     

    So basically, our problem was related to the decommisoning of a domain known to the softgrid system in the past.

     

     I hope this info can help anyone with similar problems.

     

    Alvin

    Friday, June 06, 2008 12:26 PM

All replies

  • From the client, open an cmd.exe and type "telnet [serverhostname] 554" then hit [Enter] three times.

     

    You should get an message saying:

    RTSP/1.0 400 Bad Request
    Server: Softricity SoftGrid Server/4.1.3.16 [Win32; Windows NT 5.2]
    Date: Wed, 04 Jun 2008 10:57:50 GMT

    Otherwise check that the "SoftGrid Virtual Application Server" service is started on the SoftGrid Server.

    Or that no firewall is blocking communikation between client and server.

     

    Please give us the last part of the log file on the client, sftlog.txt in C:\Program Files\Softricity\SoftGrid for Windows Desktops\ after you have tried refreshing your Desktop Configuration Server.

     

    Please also check and submit information about you SoftGrid client configuration.

    Open SoftGrid client MMC, click on "Desktop Configuration Server", right click on your server in the right pane, choose properties.

     

    The SFT_SOFTGRIDSERVER environment variable is only intressting if you have problem with streaming your application.

     

     

    //Pierre

    Wednesday, June 04, 2008 11:07 AM
  •  

    Hello Guys,

     

    I'm having this same problem with all my clients and terminal servers refreshing to the VAS.

    With help from Microsoft we found out that increasing the values of:

     

    ReadTimeout and WriteTimeout to 45secs

     

    Found in HKLM\Software\Softricity\Softgrid Client\CurrentVersion\Network

     

    However, this is not a fix. This only shows that the VAS is still working, but not optimal. So if anyone would have more ideas for troubleshooting this, please share.

     

    Thanks

     

    Alvin

    Thursday, June 05, 2008 8:16 AM
  •  

    Thanks for sharing AlvinLie.

    So the consulsion in your case was that you have latency in your network and not a problem with your SoftGrid client or Server?

     

    BR

     

    Pierre

    Thursday, June 05, 2008 9:17 AM
  • That is one option yes, however we have done some investigating our network today. Checking network components and NIC settings and drivers, but nothing specific so far.

     

    Other options are:

     

    The VAS takes too long to talk to the Domain controllers (this we can mybe validate by temporarily changing authentication method in SFT console)

    or

    The VAS takes too long to talk to the Datastore (SQL)

     

    In our environment we do have a DR VAS server in the U.S., while we are in the Netherlands. Pointing Clients from the netherlands to to US VAS, refreshing works fine with the default timeout setting of 20secs.

     

    Pointing to the VAS in the Netherlands, refreshing fails with default timeout, but works if increased to 45secs.

     

    So what we have ruled out so far, is that the problem is localized to our server in the Netherlands. So network latency is not necessarily the issue.

     

     

    Thursday, June 05, 2008 10:39 AM
  • Yeah, good idea.

     

    Uncheck "Enforce Access Permissions Settings" under Default Provider -> "Provider Pipeline", the start the service and check the result.
    Hmm guessing still though that the SoftGrid server will still use kerberos/NTLM authentication when a client do a refresh and that we can't do anything about.

    The "Enforce Access Permission...." may only have an effect when setting up a session for streaming.

     

    Let us know the progress.

     

    BR

     

    Pierre

    Thursday, June 05, 2008 11:58 AM
  •  

    Pierre,

    I didn't try disabling "Enforce Access Permission..." anymore but I fixed my problem over here by going through all published apps in the SFT console and removed all references to old/no longer existing groups. Trust me , there were a lot of old groups assigned to apps also still pointing to a domain, no longer being used.

     

    After this i stopped the Softgrid VAS services, cleared the SFT-SERVER.LOG and restarted the service. Went to my client, logged in and the auto refresh kicked in and my startmenu was populated before i even got to the softgrid client console.

     

    And this client has the original timeout os 20secs

     

    Tested with all my terminal servers with 20secs timeout and it works perfectly again.

     

    So basically, our problem was related to the decommisoning of a domain known to the softgrid system in the past.

     

     I hope this info can help anyone with similar problems.

     

    Alvin

    Friday, June 06, 2008 12:26 PM
  • Alvin,


    That's interesting thing to know, thank you for sharing it! I'm sure not many of us have thought about non-existing domain groups being a latency incurring problem..

     

    /Kalle

     

    Sunday, June 08, 2008 6:40 PM
    Moderator