Java 1.6 update 17 for Kronos (webapp)


  • Hello,


    I've had success in sequencing java webapps in the past however this one is proving to be difficult. I've tried it on sequencer 4.2 and 4.5, i've tried a few different paths only to end up in the same place, so I'm hoping someone will have some insight.

    • it requires jre 1.6.17
    • runs over https

    i've tried the following:

    • started sequencer, installed jre (either to q or default), ended monitor, conf'ed shortcuts, imported to server
    • started sequencer, browse to the webapp through IE and install it through the prompt

    what i've found is if the sequencer is running and after JRE is installed (or run from the final sequenced application through AppV) I browse to the webapp and it says:

    The Java plug-in failed to load.
    The required version: 1.6.0_17

    this happens as well directly after jre is installed by the IE prompt...

    if i go to the webapp on this or another workstation and no seq running, it will prompt to install java and everything is happy.

    so my question is: what is the sequencer doing that is blocking the recognition that the proper version of java is installed? if i go to - during sequence or using the sequenced app it will tell me it's proper (1.6.17). but Kronos is being painful and not behaving...


    thank you for any help! cheers

    Wednesday, May 12, 2010 11:26 PM



    turns out the application was searching for a particular GUID in a particular location. for some reason the sequencer was nullifying this value. a simple reg import during the sequence makes it work.


    Monday, May 17, 2010 4:34 PM

All replies

  • Hello,

    If you browse to Kronos and download and install Java - is that the exact same installer as you use when sequencing?

    Thursday, May 13, 2010 5:01 AM
  • Thursday, May 13, 2010 6:58 AM
  • i've downloaded the version through the kronos site and used that as my base installer

    i've also tried, during the sequence, to download the version through the kronos site and run it on the fly as well

    Thursday, May 13, 2010 6:12 PM
  • thanks Aaron, that looks really comprehensive. i'll be going through it after lunch. thanks!
    Thursday, May 13, 2010 6:13 PM
  • Hey Aaron,

    I like the doc, and I see what you're doing - using softgrid to surpress any other locally installed versions of java, unfortunately this is not my issue...

    even on a machine that does not have any java installed, the package fails to run the webapp. what's interesting is that i can see in both the advanced internet options and on a java checker website that JRE 1.6.u17 is installed and set as default for running applets...


    what's weird is if i install java while monitoring with the sequencer - the webapp will fail to load.

    if i browse to the site after i close the sequencer (after installation sequencing complete) it will prompt me to install java.

    if i browse to the site during sequencing or running the package after publishing it on the server, it will simply tell me i dont have the right version and will fail to load.


    WEIRD! i wonder what the sequencer is blocking...

    Thursday, May 13, 2010 7:25 PM
  • Hello,

    just checking - if not starting the sequencer (software) - but trying to install to the sequencer (machine) - does it work then?

    Thursday, May 13, 2010 7:27 PM
  • good call but I did check that.. works great as long as the sequencer is not monitoring the install

    i've tried it on my win7 sequencer machine as well with 4.5 but same result: sequencer monitoring during install = doesn't work. install without sequencer = works like a charm.. le arg.

    Thursday, May 13, 2010 8:36 PM
  • Hello,

    UAC enabled? 

    Well - if all else fails.. Use procmon to determine a baseline what happens when doing a native installation. 
    compare this to your capture - perhaps a difference can be spotted..


    Thursday, May 13, 2010 8:45 PM
  • uac disabled on the win7 machine. the other is xpsp2..

    good idea, procmon is the next step. i'm also capturing the install with WISE to see if there are any noticeable differences


    thanks for the help!

    Thursday, May 13, 2010 8:53 PM

    turns out the application was searching for a particular GUID in a particular location. for some reason the sequencer was nullifying this value. a simple reg import during the sequence makes it work.


    Monday, May 17, 2010 4:34 PM
  • SO...............  Any chance you could post where and what you modifed in the registry for this?



    Wednesday, July 21, 2010 9:02 PM
  • Can you provide any information on the reg import? I'm running into this same issue.
    Tuesday, May 03, 2011 1:56 PM
  • I too would love to have more information on how you cracked this. Please tell us!!!!!
    Wednesday, May 04, 2011 4:26 PM
  • Usually this can be isolated by looking at Process Monitor traces to HKLM\Software\Classes\CLSID\..... where a bunch of NOT_FOUNDS are seen prior to the application process shutting down.

    May also be searching HKLM\CURRENT_USER\Software\Classes\CLSID

    Steve Thomas, SSEE, Microsoft
    The App-V Team blog:
    The MED-V Team Blog:
    The SCVMM Team blog:

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”
    Wednesday, May 04, 2011 7:24 PM
  • What registry import?  Where do we get it?



    Monday, April 09, 2012 2:27 PM