none
SharePoint 2010: Not able to access site collection: Page Not Found RRS feed

  • Question

  • Hi,

    I have a web application and multiple site collections in it. each of the site collections reside in separate content databases. Suddenly, I am not able to access one of the site collection. Although I am able to view the content database for that site collection in SQL and also in Central admin. I can also see the site collection in View All Site Collections in CA.

    But if I try to access the site collection(or any sites inside it) it gives Page Not Found Error.

    The only change that was done on sever was that backup agent was configured and a backup was triggered using that agent. Is it because of that? or is there something else that went wrong?


    Regards, Priyanka Makkar

    Friday, June 21, 2013 9:21 AM

Answers

  • Does the site collection use a managed path?  Perhaps you created a list or subsite on the root site collection that interferes.  

    For example, if your site collection has a managed path of /accounting the URL would be http://portal/accounting

    Creating a subsite with url of /accounting on the http://portal root site collection would cause problems.

    I don't have an environment handy to reproduce this but I know I've issues with duplicate URL's in the past.


    Nate

    Saturday, June 22, 2013 1:54 PM

All replies

  • You should check your ULS logfiles and see what it says when accessing the site. It could be that something less obvious is triggering the error message to appear. If you have verified the content database is indeed filled with the required site collection than its strange it doesnt appear. 

    If you are in a restore to another environment than the original, make sure all required solutions and packages are deployed on that one too


    I am a SharePoint Infrastructure Engineer, focussed on Administration and Installation of SharePoint Server environments.MCITP SP2010 Administration

    Friday, June 21, 2013 10:45 AM
  • Does your web application have a root site collection? Can you access the site collection URL via Central Admin by copying the displayed url name from the site collections list and paste it in an internet browser?

    I am a SharePoint Infrastructure Engineer, focussed on Administration and Installation of SharePoint Server environments.MCITP SP2010 Administration

    Friday, June 21, 2013 10:47 AM
  • Yes, I have a root site collection, it is accessible.

    I tried copy-paste url from CA, still the error.


    Regards, Priyanka Makkar

    Friday, June 21, 2013 10:50 AM
  • Go to Central Administration  - Site Collection - Quotas and Locks

    Check that your site collection isn't in a "no access" state.


    This post reflects my opinion on this specific thread. It does not necessarily represent my employer's opinion.

    SharePoint Consultant
    MCSA Windows Server 2008
    MCTS SharePoint 2010, Configuring

    Friday, June 21, 2013 3:57 PM
  • Does the site collection use a managed path?  Perhaps you created a list or subsite on the root site collection that interferes.  

    For example, if your site collection has a managed path of /accounting the URL would be http://portal/accounting

    Creating a subsite with url of /accounting on the http://portal root site collection would cause problems.

    I don't have an environment handy to reproduce this but I know I've issues with duplicate URL's in the past.


    Nate

    Saturday, June 22, 2013 1:54 PM
  • Check yoursite problematic sitecollection url \_layouts\settings.aspx page is opening ?

    In view all site collections, if you see the problematic site collection, does it show the content db name also or is it blank ?

    Try to remove database from manage contentdatabase and mount back the content database which is problematic.

    Saturday, June 29, 2013 6:48 AM