locked
IP address of website generating reports from user reports RRS feed

  • Question

  • Hi ,

    Im getting IP address of website when im generating reports from user reports.

    Please help.

    Regards

    Vikas Sankla


    Vikas Sankla
    Monday, August 23, 2010 9:16 AM

Answers

  • No. When you do this you are configurig the client as SecureNAT. You need to at least configure the client as Web Proxy client.


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Wednesday, September 29, 2010 10:55 AM
    Moderator

All replies

  • Hi,

     

    Thank you for the post.

     

    From the description, I cannot understand what ‘s the problem you have occurred, would you please tell us more detailed? And do you mean ISA reports or TMG reports?

     

    Regards,


    Nick Gu - MSFT
    Tuesday, August 24, 2010 6:47 AM
    Moderator
  • Hi Nick,

    I have generated users report from logs and reports, whereas in reports im not getting sites domain name.

    Find the report below, i have bolded the IP Addresses.

    Eg :- wordpress.com -- 74.200.247.186.

    Any Solution for this.

    User
    Category
    Site
    Total Bytes
    10.0.0.5
    Blogs/Wiki
    74.200.247.186
    1.39 MB
       
    67.228.214.208
    216.16 KB
       
    76.74.254.120
    137.38 KB
       
    120.50.47.136
    45.31 KB
       
    67.192.97.104
    35.71 KB
       
    207.171.191.249
    2.06 KB
       
    72.21.91.19
    1.14 KB
     
    Edge Content Servers/Infrastructure
    125.252.226.80
    64.70 KB


    Vikas Sankla
    Tuesday, August 24, 2010 6:56 AM
  • Hi,

     

    Thank you for the update.

     

    I have tested on the TMG server. But I cannot reproduce this issue. What about the “Top Web Sites” in the report?  Do you receive any error message?

     

    Regards,


    Nick Gu - MSFT
    Friday, August 27, 2010 9:43 AM
    Moderator
  • Hi,

     

    Similar issue when I am generating the Daily Report in Top Websites getting IP Address.

     

    I have not received any error.

     

    Regards

    Vikas Sankla


    Vikas Sankla
    Monday, August 30, 2010 3:20 PM
  • This behavior is documented here:

    Q

    In the daily report I see the IP address of websites visited, and not the resolved name. How can I ensure the name is displayed in the report?

    A

    Only clients that are configured as Web Proxy clients resolve sites through the ISA Server computer. Other clients handle name resolution themselves, and so the ISA Server computer only knows about the IP address. Ensure that the required clients are configured as Web Proxy clients.

     

    From http://technet.microsoft.com/en-us/library/cc302624.aspx

    Same applies to ISA 200x and TMG.

    HTH,

     


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Wednesday, September 8, 2010 5:28 PM
    Moderator
  • Hi Yuri,

    I have not installed Web proxy Client on my client machine.

    Without web proxy client is not possible.

     


    Vikas Sankla
    Monday, September 27, 2010 12:30 PM
  • Correct, if you are using SecureNAT this is expected. Just remember that there is nothing to install on Web Proxy Client, you just need to configure the Web Browser to use TMG as proxy.
    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Monday, September 27, 2010 12:54 PM
    Moderator
  • Hi Yuri,

    I have configured proxy address as internet gateway, is that not sufficient.

     


    Vikas Sankla
    Wednesday, September 29, 2010 10:33 AM
  • No. When you do this you are configurig the client as SecureNAT. You need to at least configure the client as Web Proxy client.


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Wednesday, September 29, 2010 10:55 AM
    Moderator
  • How can there have been a whole thread about this with no one mentioning LogHostname or hostlogger, which fix this problem? ;)
    Saturday, October 2, 2010 12:47 AM