locked
TerminalServices-RemoteConnectionManager Event ID: 1057: The relevant status code was Object already exists. RRS feed

  • Question

  • The computer is Windows 7 Professional 64-bit edition version 6.1 Build 7601 service pack 1. The computer is not in a domain environment. I believe this may be a security issue however I completed an in-place windows 7 upgrade to try and fix the problem but after all of the windows updates, etc the error remains and appears every time the computer is rebooted...

    I could use some help with the following error:

    Log Name:      System
    Source:        Microsoft-Windows-TerminalServices-RemoteConnectionManager
    Event ID:      1057
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Description:
    The Terminal Server has failed to create a new self signed certificate to be used for Terminal Server authentication on SSL connections. The relevant status code was Object already exists.

    Provider Name="Microsoft-Windows-TerminalServices-RemoteConnectionManager"
    Guid="{C76BAA63-AE81-421C-B425-340B4B24157F}"
    EventSourceName="TermService"

    I found {C76BAA63-AE81-421C-B425-340B4B24157F} in my registry in the:

    HKey_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows -> CurrentVersion -> WINEVT -> Channels -> Microsoft-Windows-TerminalServices-RemoteConnectionManager/Admin -> OwningPublisher

    HKey_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows -> CurrentVersion -> WINEVT -> Channels -> Microsoft-Windows-TerminalServices-RemoteConnectionManager/Analytic -> OwningPublisher

    HKey_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows -> CurrentVersion -> WINEVT -> Channels -> Microsoft-Windows-TerminalServices-RemoteConnectionManager/Debug -> OwningPublisher

    HKey_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows -> CurrentVersion -> WINEVT -> Channels -> Microsoft-Windows-TerminalServices-RemoteConnectionManager/Operational -> OwningPublisher

    Microsoft-Windows-TerminalServices-RemoteConnectionManager
    %SystemRoot%\system32\termsrv.dll

    When I open as administrator a command prompt window and enter the follow: regsvr32 termsrv.dll

    I get the following message:

    RegSvr32

    The module termsrv.dll was loaded but the entry-point DllRegisterServer was not found.

    Make sure that termsrv.dll is a valid DLL or OCX file and then try again.

    Not sure if this is a problem or if this behavior is expected...

    I ran sfc /scannow and check disk on the hard drive with both reporting no errors.

    I updated the security profile for:

    [Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security]

    In the right pane, double click "Require use of specific security layer for remote (RDP) connections", in the security layer list, select RDP.

    I modified the policy and there was no change in computer behavior.  The error still appears each time the computer is reboot.

    ===

    I found a semi-related webpage that at least lists the same Microsoft-Windows-TerminalServices-RemoteConnectionManager and 1057. However I'm running Windows 7 64-bit edition and I seriously doubt I have a lack of available memory issue.

    Event ID 1057 — Terminal Services Authentication and Encryption
    http://technet.microsoft.com/en-us/library/cc775192%28v=ws.10%29.aspx

    Physical Memory (MB)
    Total 24567
    Cached 6337
    Avaiable 21821
    Free 15709

    The relevant status code says that the "Object already exists" which I think is far more relevant then some memory issue. Do I have to delete some file or registry entry? Or is it a security issue?

    Google search have come up with nothing. Any suggestions would be very helpful!

    • Edited by Delar303 Wednesday, April 25, 2012 2:54 PM
    Wednesday, April 25, 2012 2:05 PM

Answers

  • I got this error on Windows 10 Professional 1607 Anniversary Update

    I renamed the C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys directory and rebooted the machine. It fixed it.

    What DID NOT fix it was:

    • Adding Network Services account to the local administrators group
    • Changing TermServices logon to LocalSystem account. In fact this caused major errors with other services which were still set to use Network Services account. DO NOT DO THIS!

    regards Rob Goodridge

    • Proposed as answer by o1ramsky Thursday, December 14, 2017 4:54 PM
    • Marked as answer by Delar303 Monday, August 10, 2020 12:37 PM
    Monday, May 29, 2017 7:46 AM

All replies

  • I rebooted the computer with a clean windows boot:

    msconfig

    In the System Configuration Utility dialog box, click Selective Startup on the General tab.
    • Click to clear the Load Startup Items check box.
      Note The Use Original Boot.ini check box is unavailable.
    • Click the Services tab.
    • Click to select the Hide All Microsoft Services check box.
    • Click Disable All, and then click OK.
    • When you are prompted, click Restart.

    Still have the error on computer reboots.
    Thursday, April 26, 2012 8:27 PM
  • Have a solution for you:

    Download makecert.exe and generate new cert for RDP

    makecert -r -pe -n "CN=server FQDN"  -eku 1.3.6.1.5.5.7.3.1 -ss my -sr LocalMachine -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12"

    Change server FQDN with real value.

    Go to computer certificates and under remote desktop delete current certificate. Then from personal store move the newly created cert to Remote Desktop.  Open the cert and copy Thumbprint.

    Open regedit and go to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations

    Update SelfSignedCertificate key with new cert tumbprint.

    Restart Remote Desktop Services service

    Monday, January 26, 2015 1:20 PM
  • I got this error on Windows 10 Professional 1607 Anniversary Update

    I renamed the C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys directory and rebooted the machine. It fixed it.

    What DID NOT fix it was:

    • Adding Network Services account to the local administrators group
    • Changing TermServices logon to LocalSystem account. In fact this caused major errors with other services which were still set to use Network Services account. DO NOT DO THIS!

    regards Rob Goodridge

    • Proposed as answer by o1ramsky Thursday, December 14, 2017 4:54 PM
    • Marked as answer by Delar303 Monday, August 10, 2020 12:37 PM
    Monday, May 29, 2017 7:46 AM
  • Thanks Rob, simple and effective solution, helped me as well
    Thursday, December 14, 2017 4:53 PM
  • Thank you. Can you mark it as an answer please?

    regards Rob Goodridge

    Friday, December 15, 2017 10:02 PM
  • Great Rob, thank you!

    I used it at Windows 10

    Sunday, June 21, 2020 7:45 PM
  • Same error, worked for me also, Thanks Rob.

    Renamed folder to C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys.orig and rebooted, it recreated itself.

    Thursday, August 6, 2020 3:48 PM
  • Thank you. Can you mark it as an answer please?

    regards Rob Goodridge

    Saturday, August 8, 2020 6:36 AM
  • Thank you. Can you mark it as an answer please?

    regards Rob Goodridge

    Saturday, August 8, 2020 6:36 AM