Azure Website deployed, but does not update RRS feed

  • Question

  • Hello,

    I've been activly deploying changes to my Azure Website for a couple of days, has worked great. I've used both Git and WebDeploy.

    However, now all of a sudden it appears as if changes does not get picked up. The correct files are on the server (checked FTP) and I see a valid "Active deployment" on the Azure portal.

    But I can't see the changes (added an "X" to string in the markup of _Layout.chtml to detect it).

    Any ideas here? As I said it has worked fine up til now.

    • Edited by Wecode Wednesday, July 18, 2012 8:29 AM
    Wednesday, July 18, 2012 7:49 AM

All replies

  • Just as suddenly, it appears to be working again. Will update this post if happens again.
    • Marked as answer by Arwind - MSFT Thursday, July 19, 2012 2:31 AM
    • Unmarked as answer by Wecode Thursday, July 19, 2012 10:31 AM
    Wednesday, July 18, 2012 10:30 AM
  • Hi Wecode,

    Do you have some type of page output caching in your WebApp? If so, it could be the cause if this behaviour you described.

    Cheers, Carlos Sardo

    Wednesday, July 18, 2012 1:48 PM
  • It has happend again. Deployment seams to work, has worked numerous times today. Now, all of a sudden, the site wont update. Guessing it will start working again soon just as it did yeaterday. I would really like some kind of error message on my WebDeploy...

    @Carlos, no I do not have any output caching. 

    Thursday, July 19, 2012 10:05 AM
  • It has happend again. Deployment seams to work, has worked numerous times today. Now, all of a sudden, the site wont update. Guessing it will start working again soon just as it did yeaterday. I would really like some kind of error message on my WebDeploy...

    @Carlos, no I do not have any output caching. 

    Hi, I bet on caching too, can you try clean up the browser caching or access the website from a computer that has never accessed the site before?

    If you found this post useful, Please "Mark as Answer" or "Vote as Helpful". Best Regards.

    Thursday, July 19, 2012 10:50 AM
  • Aaaand we're back. It works now, without any new re-deployment.

    However it appears as it is not a caching-issue (at least not on my side), i got the same erroneous page when visiting from my phone (in a never used browser).

    Thursday, July 19, 2012 11:16 AM
  • I have same issue. I am deploying plain HTML and while files are on Azure, site is not updated. I tried to clean browser cache, open site from mobile and different browsers, but without any result. It seems that Azure is caching something. I have deployed some changes 6 hours ago and those are still not visible.
    Tuesday, July 24, 2012 7:28 PM
  • I appear to be having the same problem today. Did you ever figure out how to force Azure to accept the new updates?

    Friday, July 27, 2012 11:13 PM
  • Same issue for me - I couldn't find any way to force it to reload a DLL *or* static content (razor templates). I've had a similar issue before, but then at least templates were refreshed. Any hints?
    Tuesday, August 14, 2012 12:54 PM
  • We are experiencing something similar with a php Azure website. Site has been previously working correctly with GIT deployment.

    Now, updating from GIT after a couple of weeks initial deployment, files confirmed to be updated by FTP.

    Old files still being served from Azure, despite browser cache clearing and testing on a mobile devices browser that used 3g and had never been to the site.

    The previous occasion this occurred, stopping and restarting the website fixed the problem - that's not working this time.

    When the site is stopped, nothing at all is served out, so the caching is turned off with the instance.

    However, when the instance is restarted, the old content is once again displayed.

    It's been twelve hours now, and the old site is still being served up.

    Anyone with any suggestions to resolve this?

    Thursday, August 23, 2012 1:25 AM
  • Same problem here. Web Deploy says it updated the file. I even upload via ftp and check and the file is on the azure server. The site is not being updated. Any solution yet? I find it amazing that this problem still has not been fixed and it is 9/5.
    Wednesday, September 5, 2012 9:52 PM
  • Same problem here.
    Tuesday, November 27, 2012 2:27 PM
  • Same problem here. Explicitly stopping and then re-starting the website fixed the problem. The "Restart" feature from the management portal did not solve the issue for me.
    Thursday, November 29, 2012 2:58 AM
  • Same problem here. Website Uploaded but not updated.
    Thursday, November 29, 2012 7:22 PM
  • I have been experiencing the same problems today - the site just doesn't update. I'm deploying directly from Visual Studio, and this is neither a problem with server nor client caching.

    I managed to get the site to update by adding a new app setting. Restarting from the portal didn't work.

    I assume that changing app settings is pretty similar to a full stop and start, as the site became 503 unavailable for a few seconds. That also indicates that the restart feature is some kind of a soft restart.

    Friday, November 30, 2012 10:35 AM
  • Same problem here. I am publishing an MVC site from Visual Studio. Changes that I have med in the views are not updated online.

    Seems that the files are deployed to another server than the actual web site is placed on.

    Anyone got a solution for this?

    Wednesday, December 5, 2012 10:48 PM
  • Same problem here. Stopping and starting the website fixed the problem. Uploading the Web.config again, hoping to force a restart didn't work.

    I see this bug is reported 17th of July. Why is there no response from Microsoft yet?!

    Wednesday, December 19, 2012 7:50 AM
  • same problem here - so frustrating - no one ever answers these posts?
    Wednesday, January 9, 2013 10:11 PM
  • Same issue here... FTP shows the updated file, browsing to it doesn't show the update. What gives? Replication issues on the cloud nodes or something?
    Friday, June 21, 2013 4:10 PM
  • Same problem for me. Started today. I don't see any issues reported on the Azure service dashboard, though.
    Saturday, July 6, 2013 9:55 PM
  • Update: I restarted the site, with no change visible. I then published again after restarting. That did cause the changes to appear. Still, it sounds like something weird is going on based on the responses I see in this thread.
    Saturday, July 6, 2013 11:14 PM
  • Hello!

    I am developing a Django app with Azure website and suddenly when I deploy, changes

    are not seen when accesing the website, altough they are on the server ( checked via FTP )

    How can I solve this ? I tried all the above methods and it didnt worked. It is really urgent!

    Thank you!

    Tuesday, May 6, 2014 5:33 PM
  • I tried everything in this post to find no working fix.

    Anyway, I did some poking around and the solution that worked for me was changing the "Default Document". This can be found under the "Configure" tab under your site. My landing page is not a index.html or default.html. Removing the default list that Azure provides and adding my own page name to the list of default documents, after saving, updated the front end of the site.

    Hope this helps!

    • Proposed as answer by MattDaines Tuesday, November 4, 2014 11:30 PM
    • Unproposed as answer by MattDaines Tuesday, November 4, 2014 11:30 PM
    • Proposed as answer by MattDaines Tuesday, November 4, 2014 11:31 PM
    Tuesday, November 4, 2014 11:21 PM
  • You may refer to my slides that I share at slideshare


    Wednesday, November 5, 2014 12:46 AM
  • This issue is not resolved by the proposal to edit the default document.  I have only index.php in the list and I regularly find file updates are delayed.  I can FTP in and see the files are clearly updated, but the site doesn't reflect the change.

    I do not have application level caching, nor PHP caching enabled.  Has anyone experienced this?

    Friday, June 9, 2017 8:02 PM
  • I gave up!!

    I deleted the app and published again with other name and worked :\

    Friday, August 4, 2017 2:34 PM
  • Same here - have deployed site several times now - having of course to first stop and then restart (why oh why but that's another issue).  In any case, still not running current code. I've FTP downloaded various .cshtml pages to check and yes the pages are latest. THIS IS A PRODUCTION DEPLOYMENT OF A PUBLIC SERVICE website - it is not acceptable, no .. its unbelievable .. that we have no way of having latest code running.  


    • Proposed as answer by Chester Chin Monday, November 13, 2017 3:03 AM
    • Unproposed as answer by Chester Chin Monday, November 13, 2017 3:03 AM
    Thursday, August 31, 2017 2:02 PM
  • HI, experiencing same issues here. I ended up disconnecting the deployment options and reconnecting it again. 

    I have eliminated the possible of cache as I tested with a brand new machine and hard reloading my browser. The web apps still serves the same old page. 

    The only explanation that I can think of is that there are still some active users (or session) on the site or the webpage it self. (Which somehow is being detected by Azure.) 

    I also notice this issue happens especially during peak hours(Supporting point for the active users statement). Disconnection deployment options works immediately but i think it also terminates all active sessions. 
    Monday, November 13, 2017 3:08 AM
  • Just in case anyone is listening, I wanted to say I'm having the same problem as everyone else, that is...

    Website working fine, I make a simple change to a .cshtml file, and do a Web Publish from VS 2017. No errors reported, everything looks that same as it always has in VS - but when going to the site, my changes are not reflected.

    I then republish my site locally, manually copy everything over to the server via FTP, verify the change is on the server, and check the site again... but it still doesn't reflect the change.

    Nothing being cached on my side, tried multiple PCs, browsers, etc.

    Interestingly, if I make a change to the controller, I can see that update - but still can't see the new .cshtml file.

    The only solution I found was to check the "Remove additional files as destination" setting in the Web Deploy --> File Publish Options dialog. But this could have unintended consequences of removing files that were manually added to the server but not solution. Fortunately, I didn't have that problem, but others might.

    Saturday, December 9, 2017 12:48 AM
  • Same problem i am facing now
    Friday, December 22, 2017 9:57 AM
  • Same issue

    Remove Additional Files at Destination helped

    Monday, April 16, 2018 7:38 PM
  • It might be a CDN issue. The CDN cache is kept for 7 days by default setting. 
    • Proposed as answer by dan9527 Friday, June 22, 2018 8:34 PM
    Friday, June 22, 2018 8:34 PM
  • This still appears to be an ongoing issue 7 years later.

    Using Azure DevOps CI/CD - most of the time our application updates the files correctly. Once in a while a build will "Succeed" with no output indicating anything wrong, but files on the server do not reflect the changes in the repo.

    Queuing a manual build of the same exact repo makes the changes visible both on the server and in the browser - but there should be some indication from the build that something failed. 

    It also seems like some people are reporting a separate issue, or this issue is more complicated - Some report that the updated files appear through FTP but are not visible on the site, while others are reporting that the server never gets the updated files (this is what I am experiencing).

    An official response to this would be nice - at least an acknowledgement that it's either a known problem with Azure/VS/CI/CD/whatever or something that us users are doing incorrectly.

    Some of the responses being proposed as "answers" by MSFT are not actual solutions, they're temporary fixes at best.

    Thursday, May 30, 2019 7:25 PM
  • I'm struggling with this also.  In my case, I can publish direct from VS and it works as expected.  However through a Pipeline deployment, all appears to succeed but there are no changes on the site afterwards.

    Saturday, July 6, 2019 7:34 PM
  • Solved it myself:

    > in the Azure DevOps, Deploy Azure App Service Task:

    > Additional Deployment Options
    > ..Select Deployment Method
    > ....Remove Additional Files at Destination

    Hope it helps. 

    Saturday, July 6, 2019 7:43 PM
  • Searched for this exact issue and caching was indeed my problem. As soon as I opened my web app in an incognito tab it worked as expected.
    Tuesday, July 30, 2019 10:07 PM