none
SCCM 1906 and Application approval request with Email RRS feed

  • Question

  • Hi,

    I have SCCM 1906 and I want to deploy some Application as "Application Request" and it should be approved and send an E-Mail an the ADMIN. But I cannot put any E-Mail on the "Deployment Settings". It should display the following filed for E-Mail address, but

    On my SCCM Server I get the following page without the E-Mail filed

    I have enabled the "Approve application request for users per device" and the E-Mail subcriptions

    Regards

    Nick


    • Edited by mpng2008 Wednesday, October 9, 2019 3:04 PM
    Wednesday, October 9, 2019 2:57 PM

Answers

  • Unfortunately, we cannot modify the request email text.

    If the URL points to HTTPS, you need a valid certificate in the IIS binding, in the IE, try to access to HTTPS://fqdn_site_server.

    • Marked as answer by mpng2008 Thursday, October 10, 2019 9:09 PM
    Thursday, October 10, 2019 3:19 PM

All replies

  • Hi Nick,

    You cannot customize the email approval request, you have just to add the email addresses for the admins in the case marked on your first capture, don't forget that you need to deploy the application to a user device collection.

    You can refer to this guide: 

    https://www.prajwaldesai.com/approve-sccm-application-requests-via-email/

    Regards,

    SAAD Youssef

    ______

    Please remember to mark the replies as answer if they help, thank you!


    • Proposed as answer by SAAD Youssef Wednesday, October 9, 2019 9:46 PM
    • Edited by SAAD Youssef Wednesday, October 9, 2019 9:46 PM
    Wednesday, October 9, 2019 9:02 PM
  • Hi,

    We need to enable this feature first, because it is disabled by default.
    Navigate to Administration > Overview > Updates and Servicing > Features, right click Approve application requests for users per device and click Turn On, then remember to close and relaunch the console. Then the filed for E-Mail address will show up.

    If your "turn on" button grayed out, we need to navigate to Administration > Overview > Site Configuration > Sites > Hierarchy Settings, check Console to use Pre-Release features.

    Regards,
    Allen

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 10, 2019 3:18 AM
  • Hi,

    It is all enabled and it works fine too. But I is not displaying the field for E-Mail. I think the filed can be displayed if you deploy the Application to the user Collection and not to the Device Collection.

    Am I right? If so, is there anyway that the Admin get a e-Mail Notification for device Collection too?

    BR

    Thursday, October 10, 2019 6:41 AM
  • Hi Saad,

    I dont understand what you mean with "to add the email addresses for the admins"?

    I have defined under "Monitoring-->Alerts-->Subscription-->Configure Email Notification.

    I think you cannot put any email address if you deploy Application to the "Device Collection". You have to deploy the App to the "User Collection", 

    Then appears the field for Email address. Am I right?

    Is there anyway to send Email to the Admin if you deploy Application the "Device Collection"?

    Regards

    Nick

    Thursday, October 10, 2019 6:50 AM
  • The Application Approval requests by email is available only for user device collection, you can follow the above step-by-step guide to configure it.

    There is no way for device collection.

    For more details: https://techcommunity.microsoft.com/t5/Configuration-Manager-Blog/Application-approval-improvements-in-ConfigMgr-1810/ba-p/303534#Email%20notifications%20for%20application%20approval%20requests

    • Marked as answer by mpng2008 Thursday, October 10, 2019 8:05 AM
    • Unmarked as answer by mpng2008 Thursday, October 10, 2019 2:04 PM
    Thursday, October 10, 2019 7:34 AM
  • Hi,

    Thank SAAD Youssef very much for the solution provided. Here's a short summary for the problem.

    Problem/Symptom:
    ===================
    Platform: System Center Configuration Manager (Current Branch) 1906
    Deploy some Application as "Application Request" and it should be approved and send an E-Mail to the ADMIN. But cannot put any E-Mail on the "Deployment Settings". It should display the filed for E-Mail address.

    Possible Cause:
    ===================
    Do not enable this feature: pprove application requests for users per device
    Do not deploy the application to a user device collection.

    Solution:
    ===================
    There is no way to send Email to the Admin if you deploy Application to the "Device Collection".

    Reference Links:
    ===================
    https://www.prajwaldesai.com/approve-sccm-application-requests-via-email/
    https://techcommunity.microsoft.com/t5/Configuration-Manager-Blog/Application-approval-improvements-in-ConfigMgr-1810/ba-p/303534#Email%20notifications%20for%20application%20approval%20requests

    Regards,
    Allen

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 10, 2019 8:26 AM
  • Hi Saad,

    again me, can I modify the default request Email text?

    IF click on"Approve" or "Deny" button, I get a error message, the URL cannot be open? Any Idea? Is it IIS with https?

    Regards

    Nick




    • Edited by mpng2008 Thursday, October 10, 2019 2:24 PM
    Thursday, October 10, 2019 2:05 PM
  • Unfortunately, we cannot modify the request email text.

    If the URL points to HTTPS, you need a valid certificate in the IIS binding, in the IE, try to access to HTTPS://fqdn_site_server.

    • Marked as answer by mpng2008 Thursday, October 10, 2019 9:09 PM
    Thursday, October 10, 2019 3:19 PM
  • Hi,

    We're glad the problem is solved now. If you have any questions in future, we warmly welcome you to post in this forum again.
    Have a nice day!

    Regards,
    Allen

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 11, 2019 7:35 AM