locked
Internet Explore Group Policy Settings RRS feed

  • Question

  • As the administrator, I have been trying to prevent access to certain settings on my computer.  There is one other profile that has limited access.  I have gone to the group policy settings control and have disabled InPrivate browsing under the computer and user configuration, but it only affects my (administrator) profile and not the limited user.  I was able to manage disabling the delete browsing history in the limited user's profile, but when I try to do the exact same thing for private browsing, it has no effect on that profile.  I don't know what I am doing wrong. Please help.

    • Moved by Yi Feng Li Friday, November 19, 2010 7:22 AM IE question (From:Internet Explorer Extension Development)
    Wednesday, November 17, 2010 11:54 AM

Answers

  • Hi,

     

    First, please let me know if this is in a domain or home network.

     

    You may try the following steps to modify the registry key to troubleshoot this issue:

     

    Before modify the registry keys, please take a backup of the key. For more information about how to back up and restore the registry, please click the following link to view the article:

     

    Back up the registry

     

    1. Type regedit in RUN or Start menu Search box and press Enter to open the Registry Editor.

     

    2. Now go to following key:

     

    HKLM/Software/Policies/Microsoft/Internet Explorer/Privacy/EnableInPrivateBrowsing

     

    3. In right pane, create a new DWORD value EnableInPrivateBrowsing and set its value to 0 to disable the InPrivate Browsing feature.

     

    4. Log off or restart your system to take effect.

     

    If you are the home user, you also may try the Windows Vista – Parental Controls and Windows XP – Family Safety (this can also be used in Windows Vista or 7).

     

    References:

     

    keep the history or just completely disable InPrivate browsing

     

    Disable IE8 In-Private Feature

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sabrina Shen Friday, November 26, 2010 6:22 AM
    Wednesday, November 24, 2010 9:52 AM

All replies

  • It does not look like you need help in writing software. Try the IE forum on technet instead.

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Wednesday, November 17, 2010 3:50 PM
  • Hi,

     

    First, please let me know if this is in a domain or home network.

     

    You may try the following steps to modify the registry key to troubleshoot this issue:

     

    Before modify the registry keys, please take a backup of the key. For more information about how to back up and restore the registry, please click the following link to view the article:

     

    Back up the registry

     

    1. Type regedit in RUN or Start menu Search box and press Enter to open the Registry Editor.

     

    2. Now go to following key:

     

    HKLM/Software/Policies/Microsoft/Internet Explorer/Privacy/EnableInPrivateBrowsing

     

    3. In right pane, create a new DWORD value EnableInPrivateBrowsing and set its value to 0 to disable the InPrivate Browsing feature.

     

    4. Log off or restart your system to take effect.

     

    If you are the home user, you also may try the Windows Vista – Parental Controls and Windows XP – Family Safety (this can also be used in Windows Vista or 7).

     

    References:

     

    keep the history or just completely disable InPrivate browsing

     

    Disable IE8 In-Private Feature

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sabrina Shen Friday, November 26, 2010 6:22 AM
    Wednesday, November 24, 2010 9:52 AM