none
MSI package say installation failed even after installation is successful. RRS feed

  • Question

  • I got to create application from msi file and all was done perfectly.

    Software installation is fine too, the only problem i am facing is sccm says installation failed while it was installed correctly.

    MSI package is created with all default setting.

    I am facing this problem almost for 3-4 msi package is there anything i am missing on package?

    Here is the error code on client:



    Thursday, April 14, 2016 12:44 PM

Answers

All replies

  • What does AppEnforce.log tell?

    Simon Dettling | msitproblog.com | @SimonDettling

    Thursday, April 14, 2016 12:47 PM
  •     Performing detection of app deployment type Visual C++ 2012 Redistributable (*.exe)(ScopeId_99A63E03-4D6B-4962-A893-30E1EA7A7EF0/DeploymentType_b860c535-8d54-4e8d-b95e-cb4e010440f7, revision 2) for system. AppEnforce 4/7/2016 8:32:44 PM 8260 (0x2044)
    +++ Discovered application [AppDT Id: ScopeId_99A63E03-4D6B-4962-A893-30E1EA7A7EF0/DeploymentType_b860c535-8d54-4e8d-b95e-cb4e010440f7, Revision: 2] AppEnforce 4/7/2016 8:32:44 PM 8260 (0x2044)
    ++++++ App enforcement completed (12 seconds) for App DT "Visual C++ 2012 Redistributable (*.exe)" [ScopeId_99A63E03-4D6B-4962-A893-30E1EA7A7EF0/DeploymentType_b860c535-8d54-4e8d-b95e-cb4e010440f7], Revision: 2, User SID: ] ++++++ AppEnforce 4/7/2016 8:32:44 PM 8260 (0x2044)
    +++ Starting Install enforcement for App DT "Password_Reset_Desktop_Integration - Windows Installer (*.msi file)" ApplicationDeliveryType - ScopeId_99A63E03-4D6B-4962-A893-30E1EA7A7EF0/DeploymentType_a27759fb-93f2-4d76-b446-48702eaeb704, Revision - 3, ContentPath - C:\WINDOWS\ccmcache\8z, Execution Context - System AppEnforce 4/7/2016 8:32:45 PM 8260 (0x2044)
        A user is logged on to the system. AppEnforce 4/7/2016 8:32:45 PM 8260 (0x2044)
        Performing detection of app deployment type Password_Reset_Desktop_Integration - Windows Installer (*.msi file)(ScopeId_99A63E03-4D6B-4962-A893-30E1EA7A7EF0/DeploymentType_a27759fb-93f2-4d76-b446-48702eaeb704, revision 3) for system. AppEnforce 4/7/2016 8:32:45 PM 8260 (0x2044)
    +++ Application not discovered. [AppDT Id: ScopeId_99A63E03-4D6B-4962-A893-30E1EA7A7EF0/DeploymentType_a27759fb-93f2-4d76-b446-48702eaeb704, Revision: 3] AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        App enforcement environment:
     Context: Machine
     Command line: msiexec.exe /i "PasswordResetDesktopIntegration.msi" /quiet WRAPPED_ARGUMENTS="/resetUrl "" XXX"" /verysilent"
     Allow user interaction: No
     UI mode: 0
     User token: null
     Session Id: 4294967295
     Content path: C:\WINDOWS\ccmcache\8z
     Working directory:  AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Prepared working directory: C:\WINDOWS\ccmcache\8z AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Prepared command line: "C:\WINDOWS\ccmcache\8z\msiexec.exe" /i "PasswordResetDesktopIntegration.msi" /quiet WRAPPED_ARGUMENTS="/resetUrl "" XXX"" /verysilent" AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Executing Command line: "C:\WINDOWS\ccmcache\8z\msiexec.exe" /i "PasswordResetDesktopIntegration.msi" /quiet WRAPPED_ARGUMENTS="/resetUrl "" XXX"" /verysilent" with system context AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Working directory C:\WINDOWS\ccmcache\8z AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Post install behavior is BasedOnExitCode AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Waiting for process 8200 to finish.  Timeout = 120 minutes. AppEnforce 4/7/2016 8:32:46 PM 8260 (0x2044)
        Process 8200 terminated with exitcode: 1603 AppEnforce 4/7/2016 8:32:55 PM 8260 (0x2044)
        Looking for exit code 1603 in exit codes table... AppEnforce 4/7/2016 8:32:55 PM 8260 (0x2044)
    Unmatched exit code (1603) is considered an execution failure. AppEnforce 4/7/2016 8:32:55 PM 8260 (0x2044)


    ____________________________________________

    While my software is working fine, its just small popups say installation failed.

       
    Thursday, April 14, 2016 12:50 PM
  •    Process 8200 terminated with exitcode: 1603 AppEnforce 4/7/2016 8:32:55 PM 8260 (0x2044)
        Looking for exit code 1603 in exit codes table... AppEnforce 4/7/2016 8:32:55 PM 8260 (0x2044)
        Unmatched exit code (1603) is considered an execution failure. AppEnforce 4/7/2016 8:32:55 PM 8260 (0x2044)

    The Installation of the MSI terminates with an Exit Code 1603, which the ConfigMgr Client considers as an Execution Failure.

    Does the Installation succeed, when you execute the Installation manually?

    Check here to enable installation logging: https://blogs.msdn.microsoft.com/astebner/2005/08/01/how-to-locate-the-cause-of-error-code-1603-in-a-verbose-msi-log-file/


    Simon Dettling | msitproblog.com | @SimonDettling

    Thursday, April 14, 2016 12:54 PM
  • Yes no issue when i do the things manually.
    Thursday, April 14, 2016 1:02 PM
  • Then try to enable Verbose Logging

    msiexec /i "C:\MyPackage\Example.msi" /L*V "C:\log\example.log"


    Simon Dettling | msitproblog.com | @SimonDettling




    Thursday, April 14, 2016 1:03 PM
  • Hi,

    0x80244018 -2145107944 SUS_E_PT_HTTP_STATUS_FORBIDDEN Http status 403 - request forbidden

    Please also examine the IIS log.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 15, 2016 2:58 AM
    Moderator
  • For me it was the detection method. 

    Get-WmiObject -Class win32_product | where {$_.name -like 'Appname*' | select name, identifyingnumber

    In my case, after an update SnagIT 2019 got an additional ProductGUID. Fixed the detection method and it working now.

    Cheers

    Raghu


    Raghu Sharma

    Tuesday, October 8, 2019 12:47 AM
  • I wouldn't use Win32_Product as Detection Method or in general.

    See: https://gregramsey.net/2012/02/20/win32_product-is-evil/


    Simon Dettling | msitproblog.com | @SimonDettling

    Please remember to mark the post(s), which answered your question.

    Thursday, October 10, 2019 2:42 PM