none
SCToastNotification.exe - The toast failed RRS feed

  • Question

  • Hi there,

    In our Windows 10 environment currently 1709 (Build 16299.726) we have the problem, that after an Windows update is installed, no Toast-Notification (Lower right corner) is shown for the pending system restart.

    The problem here is, that if we do not suppress the reboot, the windows 10 computer restarts automatically after defined time. If there is no Toast-Notification showing to the user, they will be very unsatisfied.

    Some windows 10 clients are working. Some not.

    Current problem investigation:

    - Builds are the same

    - .Net-Framework are the same

    - My computer with my AD-user(no admin rights) user receives notification with the command 'C:\Windows\CCM\SCToastNotification.exe "Title" "Message"'

    - Friends computer and his AD-user(no admin rights) doesn not receive notification with the command 'C:\Windows\CCM\SCToastNotification.exe "Title" "Message"'

    - On friends computer, with my AD-account(no admin rights, and never logged on @this machine) my user receives the message with the command 'C:\Windows\CCM\SCToastNotification.exe "Title" "Message"'

    So therefore, this has to be related to the user account.
    Does anybody also had problems like this, or knows more about this behaviour?

    The logfile 'c:\Windows\CCM\Logs\SCToastNotification_Domain@user.log' on a non functioning userprofile shows the following results:

    <![LOG[Starting up...   (Microsoft.SoftwareCenter.Client.ToastNotification.App at Main)]LOG]!><time="08:52:49.7843970" date="10-18-2018" component="SCToastNotification" context="" type="1" thread="1" file="">
    <![LOG[Client is running .Net Version4.0.30319.42000   (Microsoft.SoftwareCenter.Client.ToastNotification.App at Main)]LOG]!><time="08:52:49.7913991" date="10-18-2018" component="SCToastNotification" context="" type="0" thread="1" file="">
    <![LOG[Toast notification process started with command line Hi Hi    (Microsoft.SoftwareCenter.Client.ToastNotification.App at Main)]LOG]!><time="08:52:49.7913991" date="10-18-2018" component="SCToastNotification" context="" type="1" thread="1" file="">
    <![LOG[The command line has 2 arguments   (Microsoft.SoftwareCenter.Client.ToastNotification.App at Main)]LOG]!><time="08:52:49.7913991" date="10-18-2018" component="SCToastNotification" context="" type="1" thread="1" file="">
    <![LOG[The toast failed   (Microsoft.SoftwareCenter.Client.ToastNotification.App at ToastFailed)]LOG]!><time="08:52:49.8684014" date="10-18-2018" component="SCToastNotification" context="" type="1" thread="3" file="">

    Thank you in advance for your valuable feedback.

    Kind Regards.

    Joel

    Thursday, October 18, 2018 2:08 PM

Answers

  • In fact, I was able to turn off the notification for SofwareCenter by the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Notifications\Settings\Microsoft.SoftwareCenter.DesktopToasts
    Enabled DWORD
    0: Off

    Doing the same with (1: On) set the switch to "on" in "Notifications & actions" settings applet, but the "SCToastNofitication.exe" was not able to send any toasts.

    Solution:
    As a logged in user, turn the notification to "Off" and "On" again in the "Notifications & actions" settings applet for the SystemCenter notification.

    Afterwards "SCToastNotification.exe" was able to send toast notifications again.

    • Marked as answer by JoelKalt Wednesday, December 5, 2018 9:21 AM
    Wednesday, December 5, 2018 9:21 AM

All replies

  • Has your friend attempted to log onto another computer and does it work?

    Is it possible that the users who are not working have accidentally disabled the notifications from the "Notifications & actions" settings applet?


    Nathan Ziehnert
    Senior Lead Consultant | Catapult Systems

    Blog | @theznerd | LinkedIn

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Thursday, October 18, 2018 3:39 PM
  • Thank you for the Input.

    Unfortunately I'm setting this as default to true by GPO to ensure, every user has this enabled, so the user cannot disable this by mistake.

    I checked this settings in notification-settings 100 times. Disabled it, enabled it... nothing...

    We also checked the behaviour at a not working user, if we delete the userprofile. After the user logged in and received the set of GPOs the notification is working. So i think it has to be a setting in the userprofile or user registry.

    Thursday, October 18, 2018 7:55 PM
  • I'm fairly certain that individual apps not possible to configure via GPO - turning notifications on or off yes, but I believe the user can still override. Please correct me if I'm wrong!

    However, since you've verified in notification settings that it's fine you can check the following registry key for toast notifications:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PushNotifications
    ToastEnabled DWORD
    1
    : On | 0: Off

    EDIT: A logoff/logon may be required for this setting to be applied. This registry key reflects the toggle on the settings page named "Get notifications from apps and other senders"


    Nathan Ziehnert
    Senior Lead Consultant | Catapult Systems

    Blog | @theznerd | LinkedIn

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.


    • Edited by The Z-Nerd Thursday, October 18, 2018 8:58 PM Clarification for logoff/logon
    Thursday, October 18, 2018 8:35 PM
  • In fact, I was able to turn off the notification for SofwareCenter by the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Notifications\Settings\Microsoft.SoftwareCenter.DesktopToasts
    Enabled DWORD
    0: Off

    Doing the same with (1: On) set the switch to "on" in "Notifications & actions" settings applet, but the "SCToastNofitication.exe" was not able to send any toasts.

    Solution:
    As a logged in user, turn the notification to "Off" and "On" again in the "Notifications & actions" settings applet for the SystemCenter notification.

    Afterwards "SCToastNotification.exe" was able to send toast notifications again.

    • Marked as answer by JoelKalt Wednesday, December 5, 2018 9:21 AM
    Wednesday, December 5, 2018 9:21 AM
  • Hi,

    ich habe das selbe Problem. Bie mir erscheint die Software Center gar nicht in "Notifications & actions" settings applet?. Hast du eine Idee?

    VG

    Friday, October 18, 2019 8:35 AM