Configuration error faced in BizTalk parties RRS feed

  • Question

  • We are facing issue while configuring send port in BizTalk parties in production server. The below error gets popped up



    The type initializer for 'ExtentPlaceholderCreator' threw an exception. (System.Data.Entity)




    Exception has been thrown by the target of an invocation. (mscorlib)




    Unable to load DLL 'SqlServerSpatial110.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E) (Microsoft.SqlServer.Types)



    Program Location:


       at Microsoft.SqlServer.Types.GLNativeMethods.SetClrFeatureSwitchMap(Int32 clrFeatureSwitchMap)

       at Microsoft.SqlServer.Types.SqlGeometry.IsValidExpensive()

       at Microsoft.SqlServer.Types.SqlGeometry.Construct(GeoData g, Int32 srid)

       at Microsoft.SqlServer.Types.SqlGeometry.GeometryFromText(OpenGisType type, SqlChars text, Int32 srid)

       at Microsoft.SqlServer.Types.SqlGeometry.STGeomFromText(SqlChars geometryTaggedText, Int32 srid)

       at Microsoft.SqlServer.Types.SqlGeometry.Parse(SqlString s)

    Have tried resolving this issue by following all the online steps provided ; assembly redirection , installing CLR Types MSI for SQL Server 2014, tried modifying registry but didnt help.

    If any of you have faced this issue. Request your help in letting me know the steps to follow to resolve the same.  

    Thanks in advance !



    Monday, July 8, 2019 12:24 PM

All replies

  • Hello Supriya,

    Unfortunately, we are running into the same issue.  Were you ever able to resolve this?

    Cathy Dopp,  Grand Rapids, Michigan, USA

    Monday, August 19, 2019 5:19 PM
  • What version of BizTalk?  Which Feature Pack / CU?

    Is it the WCF-SQL adapter?

    Have you installed both the 64 bit as well as 32 bit of the Adapter Pack?

    Monday, August 19, 2019 8:40 PM