none
Office365 Adapter Pack - BizTalk 2016 RRS feed

  • Question

  • I have BizTalk 2016 server, while installing BizTalk have all the adapter pack installed.
    But I dont see Office365 Email adapter. I have installed Development version of biztalk server 2016 x64.
    I dont see it any of the BizTalk Accelerators folder, neither in Adapter pack.
    Where can i find it and install . 

    Please advise

    RH

    Thursday, August 8, 2019 6:59 PM

All replies

  • That is part of Feature Pack 3.  Have you installed that?

    P.S. Make sure that it is Feature Pack 3 CU 6 rather than CU 5 that they still point to on the Configure the feature pack page.

    Thursday, August 8, 2019 9:22 PM
  • How can I see what Feature pack is on my Prod server ? Because I want to make sure and alert admin this change will be coming. 

    1) How to check which version Feature pack and CU is installed on server ?

    2) Is there any major difference using POP3 Adapter and Office365 email adapter ?


    RH

    Thursday, August 8, 2019 9:33 PM
  • 1) Check which BizTalk Server 2016 Feature Packs installed with PowerShell & How to check what BizTalk Server 2016 Cumulative Updates are installed in your Servers with PowerShell or just check in Add/Remove programs.

    2) Yes. They are quite different.  The POP3 is only for receiving from Exchange or other POP3 mail server.  The Office365 is for both Receiving and Sending to Office 365 Outlook Email




    Friday, August 9, 2019 12:02 AM
  • I have BizTalk 2016 Developer version installed, then as suggested above downloaded and installed Feature Pack 3 with CU6. 
    Not I ran the BTS2016-KB4294900-ENU it failed and now when I open my BizTalk admin console receiving following error.

    Please advise


    TITLE: BizTalk Server Administration
    ------------------------------

    Failed to load Group [ABCD\A1:BizTalkMgmtDb] data providers. (Microsoft.BizTalk.Administration.SnapIn)

    For help, click: http://go.microsoft.com/fwlink/?LinkId=47400&ProdName=Microsoft+BizTalk+Server+2016&ProdVer=3.12.774.0&EvtSrc=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors&EvtID=FailedLoadingGroupProviders&EvtChain=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors+%2cFailedLoadingGroupProviders

    ------------------------------
    ADDITIONAL INFORMATION:

    Failed to load Group [ABCD\A1:BizTalkMgmtDb] data providers. (Microsoft.BizTalk.Administration.SnapIn)

    For help, click: http://go.microsoft.com/fwlink/?LinkId=47400&ProdName=Microsoft+BizTalk+Server+2016&ProdVer=3.12.774.0&EvtSrc=Microsoft.BizTalk.Administration.SnapIn.Properties.Errors&EvtID=FailedLoadingGroupProviders

    ------------------------------

    Could not load file or assembly 'Microsoft.BizTalk.Analytics.Common, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. (Microsoft.BizTalk.ExplorerOM)

    ------------------------------
    BUTTONS:

    OK
    ------------------------------



    RH

    Tuesday, August 13, 2019 2:33 PM
  • What was the error message in the install of FP3 that caused it to fail?

    You need to resolve then and re-run FP3.

    Tuesday, August 13, 2019 9:07 PM
  • I posted the error message above.

    Installing Feature pack 3 with CU6 broke my 2016 Dev env. Cannot open admin console now :(.

    I tried to do repai, but that doesnt fix this.


    RH

    Tuesday, August 13, 2019 9:17 PM
  • You posted the error that your BizTalk Admin console now throws, which is a consequence of the FP3 failing to install the Application Insights (which was part of FP1). 

    You need to look at the logs created during the install of FP3 to see what that error was.

    Tuesday, August 13, 2019 9:20 PM
  • this is completely weird, I tried installing this morning and it failed installtion.

    Now, I retried installing it was success.

    I see Office365 is added. Thanks


    RH

    Tuesday, August 13, 2019 9:26 PM
  • Did you follow the steps in Office 365 Outlook adapters in BizTalk and run the BizTalkTMS.msi etc.?
    Tuesday, August 13, 2019 9:51 PM
  • I followed the steps and was able to sign in, but the Filter is greyed out. Cannot select the drop down. Please advise what is missing here ?


    RH

    Wednesday, August 14, 2019 9:50 PM
  • do I need to open a ticket with Microsoft about this ?

    The Folder option is greyed out


    RH

    Thursday, August 15, 2019 4:15 PM
  • Did you manage to resolve this?

    If not, then yes, you may need to raise a ticket with them.

    Tuesday, August 20, 2019 10:51 PM