locked
IE - activeX problems with files on own PC RRS feed

  • Question

  • I have a simple web site stored with my ISP and keep a copy on my own PC for editing and amendment. All the pages have a tiny piece of Javascript.

     

    When I want to check a page stored on my own PC with IE, the page comes up with a warning "IE has restricted this web page from running ActiveX controls etc. etc. ". However if I access the page on the web, it loads normally as expected, with no warning.

     

    So how can I load the local pages without the warning? I have tried to follow the directions in the help for setting the security, without success. I have another similar machine (Dell with Vista) where the problem doesn't occur. However I cannot discern any differences between the security settings.

     

    Can you help please?

     

     

     

     

     

    Monday, August 18, 2008 3:52 PM

Answers

  • Hi, Please understand that C:\users\peter\Documents\Home\www-pmb\index.htm is not a valid URL address and the Trust Sites settings could not work with the htm files on your local drive. For your current situation, please perform the following steps to solve the problem.

     

    1. Start Internet Explorer, click the Tools -> Internet Options.

    2. Point to the Advanced tab.

    3. Scroll down to security and put a check in 'Allow Active content to run in files on My Computer'

    4. Click Apply and OK.

    5. Restart Internet Explorer 7 and test the issue.

     

    On the other hand, to prevent the ActiveX warning from popping up in Internet Explorer, you might directly to add MOW(mark of the Web!) while encoding your local pages.

     

    All the information you need to know in order to add (mark of the Web!) to your local web pages can be found at this site: Mark of the Web

     

    Hope it works!

     

    Wednesday, August 20, 2008 9:41 AM

All replies

  • Hello,

     

    The Active X popup message is IE specific. IE blocks all Active X controls unless you allow them. You can change that on your computer by changing your security settings to Medium or by clicking the Allow Active X control under the options.

     

    1. Start Internet Explorer, click the Tools -> Internet Options.

    2. Click the Security tab, and set Medium as the Security level for both Internet and Local intranet zones.

    3. Click Custom Level button and ensure that the following are set to Enabled:

    Run ActiveX controls and plug-ins

    Script ActiveX controls marked safe for scripting

    4. Click OK after these settings are enabled.

    5. Click the Trusted sites icon and click Sites button.

    6. Clear the checkbox before Require server verification (https: ) for all sites in this zone option.

    7. Fill your local pages (for example, http://localhost) in the Add this website to the zone field and click Add.

    8. Click Close.

    9. Click OK again to save your changes.

    10. Restart Internet Explorer 7 and test the issue.

     

    Cheers!

    Tuesday, August 19, 2008 8:00 AM
  • Dear Colleague,

     

    Thanks for the prompt response and the advice. Unfortunately it has not worked!

     

    I set the security levels for internet and intranet to medium (one of them was on medium-low) and checked that both

    Run ActiveX controls and plug-ins

    Script ActiveX controls marked safe for scripting

    were enabled in both zones.

     

    On Trusted sites/sites I removed the https verification check, and added my own files with http://C (this is all it would accept from the complete path (C:\users\peter\Documents\Home\www-pmb\index.htm)

     

    I re-started IE with the files but I still got the warning message. The trusted sites zone is also on medium and has the two controls mentioned as enabled.

     

    If you have further suggestions Iwould be most grateful

     

    Best wishes

    Tuesday, August 19, 2008 9:30 AM
  • Hi, Please understand that C:\users\peter\Documents\Home\www-pmb\index.htm is not a valid URL address and the Trust Sites settings could not work with the htm files on your local drive. For your current situation, please perform the following steps to solve the problem.

     

    1. Start Internet Explorer, click the Tools -> Internet Options.

    2. Point to the Advanced tab.

    3. Scroll down to security and put a check in 'Allow Active content to run in files on My Computer'

    4. Click Apply and OK.

    5. Restart Internet Explorer 7 and test the issue.

     

    On the other hand, to prevent the ActiveX warning from popping up in Internet Explorer, you might directly to add MOW(mark of the Web!) while encoding your local pages.

     

    All the information you need to know in order to add (mark of the Web!) to your local web pages can be found at this site: Mark of the Web

     

    Hope it works!

     

    Wednesday, August 20, 2008 9:41 AM
  • Dear Colleague,

     

    Perfect! The change to the "advanced" option you indicated worked and now I can look at local pages without warnings.

     

    I didn't need MOW.

     

    With best wishes

     

    Peter

     

    Wednesday, August 20, 2008 12:03 PM
  • Actually this problem bothered me quite a long time too, but recently I find functional software which can fix all these problems just with one click: tuneup360, maybe you guys could have a try.

     

    Tuesday, November 23, 2010 7:08 AM