locked
TMG 2010 Reports Empty after changing server IP's RRS feed

  • Question

  • Hello. I changed all IP's on TMG 2010 Standard SP1 (Windows 2008 R2). After this Daily reports are empty. TMG working fine, no errors except next one.

    In Event log I have error:

     The daily summary for day "08/06/2010" was not created. This may cause the report for this period to be inaccurate. Verify that no prior reporting configuration alerts exist, and that the reporting services on the designated Forefront TMG report server are running and accessible from all the array members. Use the source location 1001.100.7.0.8108.200 to report the failure.
     
     Summary Definition Extended error information:
     Name: 'UserSummary'.
     Method: 'EXEC ISA_spUserSummary'.
     SQL Error description: Arithmetic overflow error converting expression to data type bigint.
    The statement has been terminated.

    Please advise how to restore reporting. Unfortunately I have no skills in SQL server area.

    Tuesday, August 10, 2010 2:23 PM

Answers

  • Hi Volijka,

    Reviewing your initial post on this thread, which is:

    The daily summary for day "08/06/2010" was not created. This may cause the report for this period to be inaccurate. Verify that no prior reporting configuration alerts exist, and that the reporting services on the designated Forefront TMG report server are running and accessible from all the array members. Use the source location 1001.100.7.0.8108.200 to report the failure.
     
     Summary Definition Extended error information:
     Name: 'UserSummary'.
     Method: 'EXEC ISA_spUserSummary'.
     SQL Error description: Arithmetic overflow error converting expression to data type bigint.
    The statement has been terminated.

    .. and comparing to a recent case that we worked with the same behavior, I would like to ask you to run the script fixsqlserverlogin.vbs from the article below:

    http://technet.microsoft.com/en-us/library/ff717843.aspx

    Note in case you have multiple TMG Servers in an array: run the script in one node, wait for each node to get in sync with CSS and then run it on second node.

    Let us know the result.

     


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    • Marked as answer by Voljka Thursday, September 23, 2010 6:56 PM
    Thursday, September 16, 2010 12:55 AM
    Moderator

All replies

  • Hi,

    try to start the SQL Server Report Server Wizard, to see if everything is fine with the configuration. You should also have a look at the SQL Server 2008 configuration utility to have a look if the services and configuration has the new IP address configuration.
    HTH


    regards Marc Grote aka Jens Baier - www.nt-faq.de - www.it-training-grote.de - www.forefront-tmg.de
    Tuesday, August 10, 2010 4:21 PM
  • I've checked SQL Server Config Manager - TCP/IP not used or all IP not enabled.

    Reporting Services use loopback address, so I'm unable to find a problem with IP addresses.

    Wednesday, August 11, 2010 8:24 AM
  • Hi Volijka,

    Do you have any server publishing rule that uses a custom protocol on your TMG deployment?

     


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Tuesday, August 17, 2010 9:38 PM
    Moderator
  • I think your problem is related with the SP1 installation !!!
    Wednesday, August 18, 2010 3:27 AM
  • I have the exact same problem, exact same error, fresh install of TMG 2010 SP1, no custom protocol rule (just web and RDP)
    • Edited by SCrozier Thursday, August 19, 2010 5:52 PM redoing it
    Thursday, August 19, 2010 5:51 PM
  • I have no such rules. Just standard SMTP/SMTPS publishing.
    Friday, August 20, 2010 1:25 PM
  • I did full install - install TMG 2010 and immideately apply SP1 before opening TMG console even.

    And Reporting works fine just until IP was changed.

    Friday, August 20, 2010 1:27 PM
  • Thanks for the feedback Voljka. I will try to repro this behavior in our lab and will let you know the result.
    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Friday, August 20, 2010 2:01 PM
    Moderator
  • If you change your IP and then reports did not work , can you check the IP address of the server in the TMG MMC -- > System node --> Server Tab --> Server property --> communication tab

     

    If you have  the Use the fQDN option - make it sure it resolves to new IP

    or

    If you have Use this IP address option make sure it is the new IP 


    Bala Natarajan [MSFT]| Sr. Support Escalation Engineer | CSS Security
    Monday, August 23, 2010 7:41 PM
    Answerer
  • TMG box use IPv6 address in ping command. I think this is not good. Will try to find correction on Google.

    =========

    Update:

    Unchecked IPv6 for all network adapters, add key to register to disable IPv6. Got Blue screen every time when TMG Firewall starts.

    Revert all changes back - Unable to start TMG Firewall service. Uninstall TMG. Uninstall failed. Manually uninstalled SQL services, all added Roles and Features. When start to add NAP role - error. So in the end I start again from clean install.

    Now, just before to start TMG installation I see what server answer with IPv6 address on ping <server name> command. I hope what this does not a problem....

    Tuesday, August 24, 2010 7:53 AM
  • Hi Volijka,   
         
    Try install this hotfix: http://support.microsoft.com/kb/980311
    Friday, August 27, 2010 5:02 PM
  • Any updates here?


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Friday, September 10, 2010 12:14 PM
    Moderator
  • I reinstall whole system. Unfortunately, this new installation has reporting problem from the start.

    May be i was a bad boy in previous life?

    Friday, September 10, 2010 4:55 PM
  • Not sure if this have to do with Karma :) but since this is happening in a pristine installation I suggest you to open a case with Microsoft CSS to further investigate this. To open a support case, use this link http://support.microsoft.com/select/Default.aspx?target=assistance , select Forefront Threat Management Gateway (under security) and follow the wizard.

    Regards,

     


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Friday, September 10, 2010 5:30 PM
    Moderator
  • Hi Volijka,

    Reviewing your initial post on this thread, which is:

    The daily summary for day "08/06/2010" was not created. This may cause the report for this period to be inaccurate. Verify that no prior reporting configuration alerts exist, and that the reporting services on the designated Forefront TMG report server are running and accessible from all the array members. Use the source location 1001.100.7.0.8108.200 to report the failure.
     
     Summary Definition Extended error information:
     Name: 'UserSummary'.
     Method: 'EXEC ISA_spUserSummary'.
     SQL Error description: Arithmetic overflow error converting expression to data type bigint.
    The statement has been terminated.

    .. and comparing to a recent case that we worked with the same behavior, I would like to ask you to run the script fixsqlserverlogin.vbs from the article below:

    http://technet.microsoft.com/en-us/library/ff717843.aspx

    Note in case you have multiple TMG Servers in an array: run the script in one node, wait for each node to get in sync with CSS and then run it on second node.

    Let us know the result.

     


    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    • Marked as answer by Voljka Thursday, September 23, 2010 6:56 PM
    Thursday, September 16, 2010 12:55 AM
    Moderator
  • Any updates on the test?
    Yuri Diogenes [MSFT] - http://blogs.technet.com/yuridiogenes
    Tuesday, September 21, 2010 12:53 PM
    Moderator
  • Yep! Thank you very much! When I run this script, manually running reports (one-time) start working. Web pages now contains information.

    But! Scheduled reports (automatic daily) still goes empty. I delete all defined reports and restart TMG scheduler, then recreate scheduled reports, and this solve problem.

    Now I have running schduled daily reports, and two days reported OK!

    I think you solve this case. THANKS! :o)

    Thursday, September 23, 2010 6:22 PM