none
Migration of Clients RRS feed

  • Question

  • Hi Guys,

    We are undergoing a migration from one domain to another. The migration itself is going ok but we are encountering problems with SCCM not changing the site code from source to target domain.

    For example we migrated 5 machines last week and they all have the source legacy Site code and not the Target site code. We have to change the code manually.

    Does anyone know how we can avoid doing this manually. Anyone been through this experience before?

    Regards.

    Thursday, April 25, 2019 1:01 PM

Answers

  • You can easily just use client push (with the force option selected) to reinstall the client agent on the systems. This will force them to change site codes as well.

    Alternatively, you can create a script that forces the client to change its site code and push that from the old site to the systems. A quick search of the web will get you lots of example scripts for this.

    The simply and easy path, assuming you've never used a group policy to set the site code before, is to just use client push though.


    Jason | https://home.configmgrftw.com | @jasonsandys

    • Proposed as answer by Garth JonesMVP Thursday, April 25, 2019 2:36 PM
    • Marked as answer by czql5v Thursday, April 25, 2019 3:29 PM
    Thursday, April 25, 2019 1:51 PM

All replies

  • Hello
    The sccm site code is not changed automatically

    | Please Mark This As Answer if it solved your issue |
    | Please Vote This As Helpful if it helps to solve your issue |
    | Disclaimer:
     This posting is provided with no warranties and confers no rights. |
    | N 48° 8' 39.8419" E 11° 36' 1.3359" |


    Klaus

    • Proposed as answer by Garth JonesMVP Thursday, April 25, 2019 2:37 PM
    Thursday, April 25, 2019 1:26 PM
  • Hi Klaus,

    Yes I thought that was also the case, however, what I am after is how we can address the problem given that we are going to migrate a few hundred machines from source to target and I don't want to manually change all the site codes.

    is there a solution for this?

    Regards.

    Thursday, April 25, 2019 1:45 PM
  • You can easily just use client push (with the force option selected) to reinstall the client agent on the systems. This will force them to change site codes as well.

    Alternatively, you can create a script that forces the client to change its site code and push that from the old site to the systems. A quick search of the web will get you lots of example scripts for this.

    The simply and easy path, assuming you've never used a group policy to set the site code before, is to just use client push though.


    Jason | https://home.configmgrftw.com | @jasonsandys

    • Proposed as answer by Garth JonesMVP Thursday, April 25, 2019 2:36 PM
    • Marked as answer by czql5v Thursday, April 25, 2019 3:29 PM
    Thursday, April 25, 2019 1:51 PM
  • Hi Jason,

    this is what I suspect and was hoping I could do. I will indeed do this when I have completed the migration.

    Thanks for taking the time out to post its appreciated.

    Regards.

    Thursday, April 25, 2019 3:30 PM