none
Setup Windows and Configuration Manager not completing RRS feed

  • Question

  • Recently setup a new SCCM 2012 environment, fully patched. I cannot seem to get the Configuration Manager client to run when using a distribute image task sequence. Basically here is what I've tried.  Setup a reference PC with Windows 7 SP1 x64 like I've been doing for years, i.e. NOT joined to a domain, very little added software installed, using a local admin user to setup some basic profile preferences.  From there I have tried 2 different methods to capture/create the image, both which seem to work fine. The first method is using MDT 2013 toolkit package job ultimately using ZTIBackup.wsf script. When I use this method I manually run sysprep myself, pointing to an answer file, and shut the machine down.

    The 2nd method is using standard Capture Media (Cd-rom) created from the SCCM 2012 environment.  Once captured I then use an 'Install existing image package' task sequence.  Nothing fancy here, the usual steps, ending with the Setup Windows and Configuration Manager step.  Everything runs fine, I see that last step happen in WinPE, I even see the config manager client package get downloaded, and once done it finally says the computer will restart.

    Once it restarts the pc kicks into mini setup, does it regular installing devices, etc, reboots one last time, checks video performance, and ultimately boots to Windows.  The image seems fine, it joined the domain as specified in the TS, but it never runs the config mgr client part.  The smsts.log file does not appear to show me any glaring errors, except one line that says 'SMS client is not installed.'  But it also says 'Successfully completed the action (Setup Windows and Configuration Manager).  I'm also left with the _SMSTaskSequence folder on the root of the C drive since the TS never knows it's finished and thus never deletes it.  I have googled for days and can't seem to find a solution.  I will add a copy of the SMSts.log file shortly.  Any help would be greatly appreciated, thanks!


    Brian Stein

    Monday, August 8, 2016 5:36 PM

All replies

  • Can you please share the complete SMSTS log file?

    Monday, August 8, 2016 10:26 PM
  • Probably a silly question but what's the recommended way to share it?  If I try and copy/paste the contents of the file it doesn't let me saying it's too big and I don't see anyway to upload a file, only pictures

    Brian Stein

    Monday, August 8, 2016 11:25 PM
  • OneDrive?

    Tuesday, August 9, 2016 1:44 AM
  • ok thanks!  Try this:

    https://1drv.ms/u/s!AkvxAUOYFjr4kFyP2Naos8Cisfae


    Brian Stein

    Tuesday, August 9, 2016 1:56 AM
  • So just curious if anyone has a had a chance to look at the smsts.log file I shared above from OneDrive?  No matter how many different ways I try to build and capture an image, or how many different things I try in a task sequence, it's the same result every time and the smsts.log file looks basically identical.  While I don't see any specific errors, it even says the action Setup Windows and ConfigMgr completed successfully, there is an entry that also says 'the action Setup Windows and ConfigMgr requested a retry', but no reason as to why.  It's like ccmsetup just cannot start and I have no idea why.

    Note however that I am able to manually install the client as well as right clicking the computer object in the SCCM console and choosing Install Client.  Both methods work fine.  It's simply in an OSD task sequence where it NEVER kicks off.  In all seriousness does anyone recommend me opening a case with Microsoft?  My boss is willing to do it, however I haven't had much luck with them in the past.  Thoughts?  Thank you!


    Brian Stein

    Wednesday, August 17, 2016 3:22 PM
  • Can you please try the following? These are meant to troubleshoot what the problem is.

    While in the WinPE phase, open a command-prompt (F8) then wait for the OS WIM to be applied and for the TS exit. At this point, it is ready to reboot to the new OS.

    For the task sequence to be able to continue running in the new OS, it installs a binary named OSDSETUPHOOK.EXE and modifies the setup registry key to point to this file.

    1. Check if the file OSDSETUPHOOK.EXE exists in the Windows folder of the new OS.

    2. Use REGEDT32 to load the registry hive of the new OS. Check that the registry HKLM\System\Setup\CmdLine has the value which is the path of the OSDSETUPHOOK.EXE.

    Both (1) and (2) must be correct. Otherwise, the task sequence will not be able to continue running in the new OS. If (1) and/or (2) is not correct, then that would be a serious bug that you need to contact support for.

    If (1) and (2) are correct, then exit the WinPE command-prompt and allow the machine to reboot to the new OS.

    In the new OS, check again that the OSDSETUPHOOK.EXE is in the Windows folder and that the HKLM\System\Setup\CmdLine points to it.


    Wednesday, August 17, 2016 6:20 PM
  • Just a complete shot in the dark (without having had a look at the logs): have you tried to remove the product key from the task sequence for testing purposes?

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, August 18, 2016 6:14 AM
  • I will look into the OSDsetuphook.exe stuff today.  As for the product key, I don't specify one in the TS since we're a KMS environment.  So while I'm at it quick question - how do you guys setup your reference computers and ultimately capture an image?  Being a school district we try to customize the default profile a bit.  What I've done in the past is I will install Windows, patch with all the latest windows updates, then load some basic software like adobe flash, java, etc, setup internet explorer and the desktop how I like it, and then sysprep using a custom answer file and capture the image.

    I find if I use build and capture, whether via SCCM directly or MDT 2013 and let it run the sysprep for me, even when I specify my answer file in the deployment task sequence, it doesn't seem to copy all the profile settings like it does when I manually run sysprep.  For example stupid things like IE won't open maximized like it should, stuff like that.

    Lastly and what I can't make sense of is what happened last night.  So first I created a reference image using MDT build and capture on a vm.  Very basic image as described above, captured the image and then deployed it to a new Dell Latitude 5470 laptop.  Config mgr piece did not work as usual.  Then I used the same MDT build and capture TS and created a similar image directly on the 5470, captured it and deployed it back to the 5470 laptop, for the first time the config mgr client piece worked.  So what in the he*l am I doing wrong??? So frustrated


    Brian Stein

    Thursday, August 18, 2016 1:15 PM
  • Did you manage to resolve this issue. I am also having the same problem?
    Friday, April 5, 2019 1:37 PM
  • In my instance is was due to Secureboot being enabled. Disabling this resolves the issue in my estate.
    Monday, August 12, 2019 2:34 PM