none
Error installing Service Provider Foundation- pre-requisite for configuring Windows Azure Pack RRS feed

  • Question

  • We are trying to setup lab at our premises to get hands on with WAP and explore.

    We are able to install all the pre-requisite software’s except the "Service Provider Foundation (SPF)" component. Using SPF we are trying to configure the WAP that is installed successfully.

    Software installed on Target machine-

    • Win Server 2012 OS.
    • Server roles enabled on host-Hyper-V,IIS, WSUS, File and storage services.
    • SQl Server W2k12-sp1-Standard edition in mixed authentication mode.
    • SCVMM.
    • WAP.

    Issue description:-

    We try to run the 'Orchestatorsetup.exe' with both Local admin/domain admin account. Pre-requisite check during the installation of SPF is successful.

    When we select "Install” button, Setup.exe is getting terminated halfway through abruptly.

    We tried to analyze the attached error log file extract.

    [061C:0F60][2014-12-02T12:30:03.146+05:30]: Applying package: Id.Setup.msi, action: Install, path: C:\ProgramData\Package Cache\{69344E86-7183-4384-A230-499E9914BE14}v7.2.1902.0\Microsoft.SystemCenter.Foundation.Setup.msi, arguments: ' INSTALLLOCATION="C:\inetpub" SCVMMCHECKED="1" SCDPMCHECKED="0" SCOMCHECKED="0" SCSMCHECKED="0" WEBSITE_NAME="SPF" PORT_NUMBER="8090" SPECIFY_CERTIFICATE="0" CERTIFICATE_STORE="My" CERTIFICATE_SERIAL="1714309174975BA5442B9ADF17FB6657" USE_SSL="1" SCVMM_APPPOOL_NAME="VMM" SCVMM_DIRECTORY_NAME="VMM" SCVMM_USERNAME_VALUE="NETWORK SERVICE" SCVMM_DOMAIN_VALUE="NT AUTHORITY" SCVMM_PASSWORD_VALUE="" SCADMIN_APPPOOL_NAME="Admin" SCADMIN_DIRECTORY_NAME="Admin" SCADMIN_USERNAME_VALUE="NETWORK SERVICE" SCADMIN_DOMAIN_VALUE="NT AUTHORITY" SCADMIN_PASSWORD_VALUE="" SCPROVIDER_APPPOOL_NAME="Provider" SCPROVIDER_DIRECTORY_NAME="Provider" SCPROVIDER_USERNAME_VALUE="NETWORK SERVICE" SCPROVIDER_DOMAIN_VALUE="NT AUTHORITY" SCPROVIDER_PASSWORD_VALUE="" SCUSAGE_APPPOOL_NAME="Usage" SCUSAGE_DIRECTORY_NAME="Usage" SCUSAGE_USERNAME_VALUE="NETWORK SERVICE" SCUSAGE_DOMAIN_VALUE="NT AUTHORITY" SCUSAGE_PASSWORD_VALUE="" SCDPM_APPPOOL_NAME="DPM" SCDPM_DIRECTORY_NAME="DPM" SCDPM_USERNAME_VALUE="NETWORK SERVICE" SCDPM_DOMAIN_VALUE="NT AUTHORITY" SCDPM_PASSWORD_VALUE="" DATABASE_SERVER="localhost" DATABASE_PORT="1433" DATABASE_EXISTS="False" DATABASE_NAME="SCSPFDB" DPM_SECURITYGROUPUSERS="WAPLABS\vmmadmin" VMM_SECURITYGROUPUSERS="WAPLABS\vmmadmin" ADMIN_SECURITYGROUPUSERS="WAPLABS\vmmadmin" PROVIDER_SECURITYGROUPUSERS="WAPLABS\vmmadmin" USAGE_SECURITYGROUPUSERS="WAPLABS\vmmadmin" ARPSYSTEMCOMPONENT ="1"'
    [061C:0F60][2014-12-02T12:30:24.948+05:30]: Error 0x80070643: Failed to install MSI package.
    [061C:0F60][2014-12-02T12:30:24.949+05:30]: Error 0x80070643: Failed to execute MSI package.
    [18C0:17D4][2014-12-02T12:30:24.950+05:30]: Error 0x80070643: Failed to configure per-machine MSI package.
    [18C0:17D4][2014-12-02T12:30:24.952+05:30]: Error 0x80070643: Failed to execute MSI package.
    [061C:0F60][2014-12-02T12:30:24.952+05:30]: Removing cached package: {69344E86-7183-4384-A230-499E9914BE14}v7.2.1902.0, from path: C:\ProgramData\Package Cache\{69344E86-7183-4384-A230-499E9914BE14}v7.2.1902.0\
    [18C0:17D4][2014-12-02T12:30:24.957+05:30]: EverestBootstrapperApplication_ExecuteComplete
    [18C0:17D4][2014-12-02T12:30:24.958+05:30]: MSI execution completed
    [18C0:17D4][2014-12-02T12:30:24.963+05:30]: Installation finished

    Workaround tried:-

    1. As per the TechNet MS site changing the time zone to Pacific/London time zone. Tried it but issue persists.

    2. Tried to run the setup.exe using domain account and local admin account.

    Any help appreciated much..

    Friday, December 5, 2014 9:43 AM

Answers

  • UAC was turned off and installation was tried using local admin account. The error log suggested it was failing to create a firewall exception rule for 8090/UDP port. Windows Firewall service was enabled. SPF got installed successfully. 

    Thanks Darryl for helping us break the deadlock :)

    • Marked as answer by SreejaSJ Monday, December 8, 2014 6:08 AM
    Monday, December 8, 2014 6:08 AM

All replies

  • - Disable user account control (UAC)

    - Disable all firewalls and anti virus.

    - Try adding "Network service" to the administrators group.

    Friday, December 5, 2014 9:48 AM
  • Thanks for the suggestion. We had tried the options partially, previously. Will try all suggested and see.
    Monday, December 8, 2014 5:33 AM
  • UAC was turned off and installation was tried using local admin account. The error log suggested it was failing to create a firewall exception rule for 8090/UDP port. Windows Firewall service was enabled. SPF got installed successfully. 

    Thanks Darryl for helping us break the deadlock :)

    • Marked as answer by SreejaSJ Monday, December 8, 2014 6:08 AM
    Monday, December 8, 2014 6:08 AM