none
Can't connect SQLAzure Database to my Mobile App service? RRS feed

  • Question

  • Hello,

    I am trying to connect my SQLAzure Database to my mobile app for EasyTables. I follow the given page in EasyTables section for details on how to make the connection string but still i have no connection at all. How to fix this?


    • Edited by abdo400 Thursday, September 12, 2019 10:14 PM
    Thursday, September 12, 2019 10:11 PM

Answers

  • I tried this today and got it working.

    The only caveat here is that the Connection sting name should be exactly MS_TableConnectionString

    Then you should be able to initialize and create tables without any issues

    Do let me know if it still doesn't work for you.

    Monday, September 16, 2019 11:34 AM
    Moderator

All replies

  • Welcome to the MSDN Forums!

    Could you post the error message you are getting so that we can troubleshoot better.

    The tutorial here has step by step instructions to work with EasyTables

    Please try and let us know if you face any issues.

    Friday, September 13, 2019 6:35 AM
    Moderator
  • The tutorial talks about the old way to connect a database to easytables (the automatic one). Now you removed it and it has to be done manual. I am not getting any errors. I add the connection string then get back to see if i have already a database connection, but I don't have any. Checked with chat support if I am doing something wrong, apparently no.
    • Edited by abdo400 Saturday, September 14, 2019 11:17 AM
    Saturday, September 14, 2019 11:17 AM
  • Hi Abdo

    If you are still facing the issue, Could you post the error message to look into further.

    Thank you!!


    If this post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Saturday, September 14, 2019 1:29 PM
  • I do make an SQLAzure Database, and add the connection string, then go to easy tables and it is still showing me (Connect a databse). After pressing the second option and clicking ok, i get this error

    Initializing App Service app creation error!

    There was an error while initializing App Service app for 'todolistappTA'. 'Error connecting to SQL server (SQL error code 87)'

    I think this error because I doesn't read I have a database connection?

    Saturday, September 14, 2019 11:35 PM
  • I tried this today and got it working.

    The only caveat here is that the Connection sting name should be exactly MS_TableConnectionString

    Then you should be able to initialize and create tables without any issues

    Do let me know if it still doesn't work for you.

    Monday, September 16, 2019 11:34 AM
    Moderator
  • Just checking in to see if the above answer(s) helped.

     

    If this answers your query, do click “Mark as Answer” and Up-Vote for the same which might be beneficial to other community members reading this thread .

    And, if you have any further query do let us know. 

    Tuesday, September 17, 2019 2:09 PM
    Moderator
  • Sure will check it out! Just had a bad internet yesterday sorry!

    abdo400

    Wednesday, September 18, 2019 1:04 AM
  • Thank you a lot for your patience :)

    abdo400

    Wednesday, September 18, 2019 1:10 AM