locked
SCOM 1801 linux agent install bug RRS feed

  • Question

  • I am getting the following error when I try to install the Linux agent. I have imported the latest Linux MP and also deleted and reimported the MP. I have redone the runas accounts and profiles but all I get is the message below.  Has anyone else come across this?

    "Unexpected DiscoveryResult.ErrorData type.  Please file bug report.
    ErrorData: Microsoft.SystemCenter.CrossPlatform.ClientLibrary.MPAbstractions.WSManUnknownErrorException
    The user name or password is incorrect.
       at System.Activities.WorkflowApplication.Invoke(Activity activity, IDictionary`2 inputs, WorkflowInstanceExtensionManager extensions, TimeSpan timeout)
       at System.Activities.WorkflowInvoker.Invoke(Activity workflow, IDictionary`2 inputs, TimeSpan timeout, WorkflowInstanceExtensionManager extensions)
       at Microsoft.SystemCenter.CrossPlatform.ClientActions.DefaultDiscovery.InvokeWorkflow(IManagedObject managementActionPoint, DiscoveryTargetEndpoint criteria, IInstallableAgents installableAgents)"

    Thanks,

    Rene

    Monday, June 25, 2018 3:05 PM

All replies

  • Did you ever figure out what the problem was?  I'm having the same issue now.
    Tuesday, June 30, 2020 4:54 PM
  • That was two years ago. If my memory is correct I ended up removing and re-adding the runas accounts on the Linux servers and perhaps even switching SELINUX to permissive during the discovery and agent install process.

    Rene

    Tuesday, June 30, 2020 5:19 PM
  • Thanks for the reply.. this is unfortunately only happening on new server 2016 management servers that we are adding.  The existing 2012R2 OS management server works fine.  


    Tuesday, June 30, 2020 5:26 PM
  • In the event someone else comes across this issue it was due to Kerberos being enable on the new Windows 2016 OS servers and we are currently using basic authentication for the other management server.  Deleting the registry key HKLM:\Software\Microsoft\Microsoft Operations Manager\3.0\Setup\Linux Auth to Kerberos. fixed the issue.
    Tuesday, June 30, 2020 6:31 PM