none
No Data Detected under Azure SQL Analytics for managed instance RRS feed

  • Question

  • Hi Folks,

    I have configured "Azure SQL Analytics" for managed instance though It is not showing any data under summary as well as in dashboard. 

    Not sure If it takes longer time to show this data, but I have already waited more 3-4 hours now..! but don't see any result.

    In order to configure this, I have followed below steps.

    1. Created Log Analytics Workspace

    2. Configured "Diagnostics Setting" for "Managed Database" and "Managed Instance"

    Referred article : https://docs.microsoft.com/en-us/azure/sql-database/sql-database-metrics-diag-logging and https://docs.microsoft.com/en-us/azure/azure-monitor/insights/azure-sql

    In the Analytics Summary It shows blank, once I clicked on "View Summary", it shows no data detected.

    Your inputs will be helpful.

    NOTE: I have followed same steps for Azure SQL Standard instance, and for Azure SQL Standard Instance it is showing all the dashboard.

    Thank you

    Regards,

    Mahesh Arban.



    Saturday, July 20, 2019 6:28 PM

All replies

  • Guys Bingo...!

    It's working as expected, not sure what magic happen within 24 hours, but when I have checked dashboard after 24 hours everything was populated...not sure how much time required in order to fetch all the data post enabling diagnostics setting database. Anyone experience similar behavior? 

    I have also observed behavior while increasing managed instance storage quota, it took one hour to reflect actual increased sized, and based on below article, I could see  while instance storage scaling up/down 90% of operations finish in 2.5 hours. seems to be a expected behavior.

    https://docs.microsoft.com/en-us/azure/sql-database/sql-database-managed-instance

    • Marked as answer by Mahesh Arban Monday, July 22, 2019 5:24 AM
    • Unmarked as answer by Mahesh Arban Monday, July 22, 2019 5:24 AM
    Monday, July 22, 2019 5:24 AM