locked
Smartcard redirection broken for Gemalto SafeNet eToken 5110 CC since RDP for MacOS ver. 10.3.8 up to lates beta (10.4.0 1807) RRS feed

  • Question

  • Dear all,

    most probably since MSRDP for MacOS ver. 10.3.8 the smartcard redirection in MacOS client is broken, at least for above mentioned token (but other users with different HW are also reporting problems). I have tested this bug on MacOS Mojave and Catalina (both updated to latest versions) with MSRDP ver. 10.3.12 (1801) and few previous versions too and also with latest beta build 10.4.0 (1807). The behavior is always the same: smartcard is redirected and visible at the destination RDP host but at the moment private key should be used when the dialog for entering private key passsphrase should appear the card disconnects and can not be used anymore. The session has to be disconnected, token removed from Mac USB port, MacOS restarted and token inserted again.

    The same process works well from Windows RDP session.

    Please let me know if I could supply some logs or diagnostic data. So far I couldnt find any relevant error messages in syslog in MacOS.

    Thank you for your support and wish you nice day

    Regards

    Frantisek Vesely

    +420 776016041 frantisek@mujitguru.cz


    Monday, July 6, 2020 8:41 AM

All replies

  • One more finding:

    when the card is redirected to Windows and unsuccessfuly used it disappears from MacOS and the system has to be restarted or at least user has to be logged off and logged on again or the card is not visible in Gemalto SAC for MacOS at all. It looks like it is actually crashing the smartcard service in MacOS.

    Can somebody provide minor version then 10.3.8 of MS RDP for Mac for testing purposes please?

    Many thanks and wish you nice day

    Regards

    Frantisek

    Monday, July 6, 2020 11:17 AM
  • Dear all,

    the smartcard redirection got broken with the bugfix release Beta Version 10.3.8 (1738). This and following releases are not working (at least for Gemalto/Aladin tokens). Beta repo is here: install.appcenter.ms/orgs/rdmacios-k2vy/apps/microsoft-remote-desktop-for-mac/distribution_groups/all-users-of-microsoft-remote-desktop-for-mac

    It means the latest working version is Beta Version 10.3.8 (1737)

    Please check your code changes and fix your product.

    Thank you

    Sincerely

    Frantisek


    Monday, July 6, 2020 1:54 PM
  •  Hi Frantisek,

          Thank you for your sharing and we will pass your feedback to our product team. 

          You can raise questions about Mac on Mac Forum via link below:

     

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Yvonne Yang様 Wednesday, July 29, 2020 9:23 AM
    Tuesday, July 7, 2020 8:26 AM
  • Hi Yvonne,

    thank you for passing it for further investigation.

    Have a nice day

    Frantisek

    Tuesday, July 7, 2020 8:32 AM
  • You are always welcome if you have any questions about Microsoft products in the future. Your suggestions help our products improve please feel free to come back Forum to ask questions. 

    Best Regards,

    Yvonne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 8, 2020 7:25 AM
  • You are always welcome if you have any questions about Microsoft products in the future. Your suggestions help our products improve please feel free to come back Forum to ask questions. 

    Best Regards,

    Yvonne

    This "Remote Desktop Client" Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details. 


    "Remote Desktop Client" forum will be migrating to a new home on Microsoft Q&A!

    We invite you to post new questions in the "Remote Desktop Client"  forum's new home on Microsoft Q&A!

    For more information, please refer to the sticky post.
    Thursday, July 16, 2020 9:29 AM