none
FTPS using TLS 1.2 using Microsoft Integration Pack RRS feed

  • Question

  • Hi

    I'm having problems getting Orchestrator to connect to an FTPS server using the IP in orchestrator.  It doesn't matter which activity I try they all fail.  I've followd all the instructions listed in Microsoft document 4051111 - TLS 1.2 Protocol Support Deployment Guide for System Center 2016

    and I can connect to the server with ftps using filezilla.

    Looking at a wireshark trace from both servers it never tries to initiate the TLS connection.  It performs the initial handshake and that's it.  It makes no difference if I specify the certificate or not. 

    The orchestrator error is

    List Folder failure: List Folder failure, Log: Connected to [IPADDRESS]:990 on 31/05/2019 @ 10:26:35


    Exception: FtpServiceException
    Target site: FtpService.ListFolder

    Stack trace:
       at SystemCenter.IntegrationPack.Ftp.Protocol.Core.FtpService.ListFolder(String folderPath, Boolean recursive, Filter[] filters)
       at SystemCenter.IntegrationPack.Ftp.Domain.ListFoldersFilesCommand.Execute(IFtpService ftpService)
       at SystemCenter.IntegrationPack.Ftp.Domain.ExecuteContext.Execute(FtpCommand command)
       at SystemCenter.IntegrationPack.Ftp.Activities.ListFoldersFilesActivity.DoExecute(ExecuteContext context)
       at SystemCenter.IntegrationPack.Ftp.Activities.FtpActivity.Execute(IActivityRequest request, IActivityResponse response)

    In the event log the schannel does also record

    A fatal error occurred while creating a TLS client credential. The internal error state is 10013.  

    Can anyone offer advice please?  I'm wondering if it is the credential path being wrong (The error happens whatever is in there)

    Thanks

    Monday, June 3, 2019 4:05 PM

All replies