none
Failed to take snapshot of one or more contents in package RRS feed

  • Question

  • We have two main SCCM site system servers, and all of a sudden (everything was working before, no change) the applications would not distribute to the DPs.

    distmgr.log:

    Snapshot processing content with ID 16781461 ...

    The source directory \\sccm02\Packages\ doesn't exist or the SMS service cannot access it, Win32 last error = 5

    Failed to take snapshot of one or more contents in package 00239

    I tried granting Everyone full control for both Share and NTFS, and granting the site server computer account full control, still the same issue.  I could access it manually w/ the UNC path and read/write/delete all of its contents.

    If I copy the folder to another server and point it there in the Application, it distributes the content to DPs just fine.

    Monday, December 8, 2014 4:18 PM

Answers

All replies

  • If the "Packages" share is local to the site server, then you need to grant the local System account at least read permissions to the folder shared as "Packages".

    *You* accessing the share proves the share is working but not much more since ConfigMgr uses the site server's local System account (assuming the SMS Provider is on the site server).


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Monday, December 8, 2014 6:05 PM
  • The SYSTEM account has full control for the Share and NTFS

    On top of that, EVERYONE has f/c as well. 

    I verified and compared the permission for ntfs/share on a working (different server) and a non-working share (same server), they're identical.

    As much as Win32 last error = 5 is telling us this was an access issue, it might be something else?

    Monday, December 8, 2014 6:38 PM
  • Unlikely something else 

    Access is denied.
    Source: Windows

    as it's not working is it worth replacing the perms on the containers?

    Monday, December 8, 2014 6:51 PM
  • I tried replacing ntfs permissions on all the folders, still getting Win32 last error = 5

    I was seeing some errors in event log

    The shadow copies of volume \\?...ac2-11e4-9f6d-005056a7533c} were aborted because of an IO failure on volume \\?...ac2-11e4-9f6d-005056a7533c}.

    The system failed to flush data to the transaction log. Corruption may occur.

    Reset to device, \Device\RaidPort0, was issued.

    Tuesday, December 9, 2014 4:31 PM
  • Sounds if there are hardware problems. Make sure that you have a working backup. That error is unrelated to ConfigMgr then.


    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, December 9, 2014 4:42 PM
    Moderator
  • solution on vmware

    This was my fix...

    • Marked as answer by katiedonut Tuesday, December 9, 2014 5:43 PM
    Tuesday, December 9, 2014 5:43 PM
  • Thanks for sharing the fix
    Tuesday, December 9, 2014 7:01 PM
  • looks like the site does not work anymore

    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2063346


    OSLM ENGINEER - SCCM 2007 & 2012

    Monday, October 7, 2019 5:25 PM
  • That site worked for me just fine just now. Ultimately though, if it's not working for you, you need to contact VMWare as there's nothing that anyone here can do about it.

    Jason | https://home.configmgrftw.com | @jasonsandys

    Monday, October 7, 2019 6:15 PM