Windows 10 Apps Failing to Launch/Crashing RRS feed

  • Question

  • One of our domain users was having an issue with an unrelated program and, since we had very little information to go on, we removed her local profile from the PC and had her start over from scratch.  Since then, her calculator app fails to launch and crashes, as well as her photo viewer.  The calculator will open a blue window and then immediately close and I believe the photo viewer does something similar.  They still work for other users logged into the same PC though.  We have tried the following steps in this order trying to resolve this issue for her:

    • Terminated the app
    • Reset the app
    • Performed a Windows update to 1903 (I think it was 1809 previously)
    • Uninstalled then re-installed the app (uninstalling wasn't an option prior to the update)
    • We've tried re-registering the apps using this powershell script:
      • Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)AppXManifest.xml”}
    • Ended the Runtime Broker background process
    • Ran the built in Windows App troubleshooter and rebooted afterwards
    • Ran WSReset.exe
    • Attempted to uninstall using Powershell with the script Get-AppxPackage *windowscalculator* | Remove-AppxPackage 

    These were most of the solutions I could find by searching.  Is there any other possible solution?  I don't want to remove and recreate her profile again since that would be a pain for her to do for the second time in two days and it's not guaranteed to work since that's what sparked this issue in the first place.

    Thanks for any help or suggestions you have.

    Friday, October 18, 2019 9:53 PM

All replies

  • Open Command Prompt and run the following command:

     sfc /scannow and press Enter.

    If SFC can’t fix the problem or if you’re unable to run SFC scan, you need to use DISM instead.

    To do that, start Command Prompt as administrator. Now paste DISM /Online /Cleanup-Image /RestoreHealth command and run it.

    Create new user account and recheck.

    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Friday, October 18, 2019 11:27 PM
  • Store app is based on account, so your troubleshoot thread is correct, if create the new profile still has issue, you need to consider image health.

    Since you have tested many solutions, there are three methods can still be checked:

    1.DISM /Online /Cleanup-Image /RestoreHealth, upgrade by a native iso from Microsoft website

    3.Reset this PC keep my files


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, October 21, 2019 7:28 AM
  • I have exact the same issue. Were you be able to fix it?
    Wednesday, November 20, 2019 4:12 AM
  • Unfortunately not, and the troubleshooting I was given here did not fix it either.  I just ended up swapping out the user's PC and re-purposing the original for someone else since it was specific to that user's profile.
    Wednesday, November 20, 2019 5:53 PM
  • That is exactly what I did. Delete the user profile through User Profiles doesn't work. The affected user doesn't have roaming profile.
    Thursday, November 21, 2019 3:21 PM