locked
2012 R2 Hyper-V Automatic Stop Action doesn't work RRS feed

  • Question

  • I got a fresh build of 2012 R2 Hyper-V host with 2012 R2 VM's installed on it. I seutp my automatic Stop Action to Shut Down, however when I reboot the host, the VM's don't shut down but they are Turned Off, as well my automatic Start Action is to power up all the VM's and they don't get powered on upon restart. I found the following in the event viewer:

    at: 12:12:33 PM Hyper-V Config:

    The Virtual Machine configuration at H: is no longer accessible: the system cannot find the path specified. (0x80070003)

    at: 12:14:32 PM Hyper-V Config

    The Virtual Machine configuration at H: is now accessible

    It looks like the drive initialization process is loaded after the Hyper-V.

    Any suggestions?

    Thursday, October 10, 2013 9:24 AM

All replies

  • I managed to resolved this, by changing the Hyper-V service to have delayed start. However the Automatic stop action of shut down isn't working it turn off the machines instead of Shutting down.

    In the event viewer under Hyper-V VMMS there is 
    Warning: Shut down physical computer. Stopping/saving all virtual machines...

    2 seconds after that there is:
    Information: The WMI provider 'VmmsWmiEventProvider' has shut down
    Information: The WMI provider 'VmmsWmiInstanceAndMethodProvider' has shut down

    no other errors or events recorded
    • Edited by Thomas Radosh Thursday, October 10, 2013 12:55 PM more info
    Thursday, October 10, 2013 9:45 AM
  • It is a bug others have discovered and reported. I have not seen an official ETA on a workaround or fix yet. Other options still work (pause, etc)...just shut-down is broken.
    Thursday, October 10, 2013 9:41 PM
  • Hi,

    I have create the same system environment for test the issue, but I never found the issue you described. Please check your following conditions on your server configuration:

    1. Update all the update packs.

    2. Check your Automatic stop action setting as “Save the virtual machine state”

    3. Confirm the “Integration Service” has already selected the “Operating system shutdown”

    4. Confirm the following Integration service is running in your child vms”

    1. Hyper-V Guest Shutdown Service
    2. Hyper-V Guest Service INeerface

    Thanks.


    Alex Lv

    Friday, October 18, 2013 5:47 AM
    Moderator
  • Hi, yes it works fine if your Stop Action is set to: Save, however when you change it to Shut Down it will just turn off the machines. I was hoping that yesterday official release might have addressed that and fixed it however the issue is still present.
    Friday, October 18, 2013 8:06 AM
  • Weird, what kind of OS was your VM?

    I tried it on a virtual windows 7 x64: Neither save nor shutdown worked, booth made the VM beeing turned of on Host Shutdown.


    Friday, October 18, 2013 2:09 PM
  • I'm having the exact same problem. the Hyper-V Shutdown” guest service is also running in the windows virtual machines, but yet the vms turn off instead of shutting down!
    Monday, October 21, 2013 2:50 AM
  • I have been having the same problem but have a workaround. The Powershell stop-vm cmdlet does successfully shut down the VMs in an orderly fashion, so instead of using the host shutdown from e.g. the gui, I use Powershell to shut the VMs down first e.g. having a batch file containing e.g.

          Powershell.exe  c:\scripts\shutdown.ps1

          shutdown.exe /m hostmachinename /s /d u:6:12

    with the c:\scripts\shutdown.ps1 file containing the Powershell commands

        stop-vm -name VMname1

       stop-vm -name VMname2

    This can also be called from a scheduled task or the individual commands embedded as separate actions

    Tuesday, October 22, 2013 9:54 AM
  • I have been having the same problem but have a workaround. The Powershell stop-vm cmdlet does successfully shut down the VMs in an orderly fashion, so instead of using the host shutdown from e.g. the gui, I use Powershell to shut the VMs down first e.g. having a batch file containing e.g.

          Powershell.exe  c:\scripts\shutdown.ps1

          shutdown.exe /m hostmachinename /s /d u:6:12

    with the c:\scripts\shutdown.ps1 file containing the Powershell commands

        stop-vm -name VMname1

       stop-vm -name VMname2

    This can also be called from a scheduled task or the individual commands embedded as separate actions


    Thanks for that, however the point here is that if it's a headless server, and you want to just press the power button on it to initiate the system shutdown, you don't want to have to use a scripts. To be honest that should be part of the OS shutdown procedure. It used to work nicely before so I'm wondering what have caused that in the R2 and why MS haven't yet fixed it :(
    Tuesday, October 22, 2013 10:20 AM