none
SCCM 2012 installation using SQL custom port RRS feed

  • Question

  • Hello team,

    We are trying to install SCCM 1602  at one of our customer place using local SQL 2016 database.

    But per customer security policies they have changed the SQL default port (1433) to custom port ( 14444) for an instance..

    While installing SCCM server, the installation wizard does not allowing us to specify the SQL server (FQDN) with custom port. Showing error on "Sql Server name" field.

    Appreciate any quick help how to address this. 

    Thanks in advance,

    Abul 

     



    Monday, May 8, 2017 11:42 AM

All replies

  • According to this link custom Site Server-to-Site SQL Server ports are not supported;

    https://technet.microsoft.com/en-us/library/bb632618.aspx

    Jack



    • Edited by JFetter Monday, May 8, 2017 11:49 AM
    Monday, May 8, 2017 11:48 AM
  • Hi JFetter, 

    This article is referred to SCCM 2007, but I am not sure the same will apply to SCCM 2012/2016.

    But, as per this article under supported Configuration for SCCM - it is clearly mentioned that we can use SQL server with default port or custom port.

    https://technet.microsoft.com/en-us/library/gg682077.aspx

    I want be sure before getting back to customer that SCCM does not support SQL server with custom port.

    Pls help to get some MS articles explaining the same.


    • Edited by ABUL FAZAL Monday, May 8, 2017 12:16 PM
    Monday, May 8, 2017 12:01 PM
  • "SCCM 2016" does not exist at all. It's either ConfigMgr 2012. Or ConfigMgr Current Branch.
    And custom ports are supported.

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, May 8, 2017 12:07 PM
  • Hi Torsten,

    It is SCCM 1602.

    Can you pls share some more details how to specify the SQLserver name with custom port during SCCM installation as it is not accepting for us.

    Monday, May 8, 2017 12:17 PM
  • Do you have the SQL Browser enabled on the system hosting the SQL instance?

    Also note that 1602 is no longer supported -- there's no way for you to directly install 1602 anyway though so I doubt that's the version that you are using.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Monday, May 8, 2017 1:32 PM
  • I know this is an older post, but I ran into this issue yesterday when I installed 1802 and wanted to share my solution.  During installation, when you provide the name of your SQL Server, simply add a comma to the end of the SQL Server name, followed by the number of the custom port.

    Ex:  mysqlservername.domain.com,14444

    I did this and CM installed just fine.

    Friday, November 9, 2018 6:54 PM
  • Wow, thanks MassiveHeadwoundHarry. Finally I can continue to setup my SCCM.
    Friday, December 6, 2019 1:53 AM