none
EDI Validation SNIP Levels RRS feed

  • Question

  • The EDI Validations (both regular and Extended) which is present in BizTalk 2016 doesn't conforms to SNIP Level 2 

    I have used XEngine from EDIFECS and I received error with an EDI File (837P) SNIP2 but Biztalk never returned the similar error for the same file

    THis is from XENGINE

    <Error Severity="Normal" Category="Rejecting" SNIP="2" Index="1" ID="0x81004a">
                                    <Brief>A composite data element with 'Must Use' status is missing.</Brief>
                                    <Description>Composite SV107 (Composite Diagnosis Code Pointer) is missing. This Composite's user option is 'Must Use'. Segment SV1 is defined in the guideline at position 3700.{br}{br}This Composite was expected in:{br}{tab}Segment Count: 168{br}{tab}Composite Count: 7{br}{tab}Character: 5178</Description>
                                    <DetailGuidelineInfo>
                                      <IID>70396</IID>
                                      <ID>C004</ID>
                                      <Name>Composite Diagnosis Code Pointer</Name>
                                      <Sequence>07</Sequence>
                                      <Requirement>Optional</Requirement>
                                      <UsrRequirement>Must Use</UsrRequirement>
                                      <Excluded>0</Excluded>
                                      <MaxUse>1</MaxUse>
                                    </DetailGuidelineInfo>
                                    <ErrorObjectInfo></ErrorObjectInfo>
                                    <ErrorDataInfo>
                                      <Part1>SV1*HC:T4541*51*UN*100</Part1>
                                      <DataXPointer>
                                        <StartPos>5178</StartPos>
                                        <Size>0</Size>
                                      </DataXPointer>
                                    </ErrorDataInfo>
                                  </Error>

    No similar errors received from BIZTALK 2016

    Please advice


    SV

    Tuesday, June 25, 2019 5:26 PM

Answers

  • The Schema used by BizTalk EDI provides Level 1 & 2 SNIP.

    SV107 is required so you should have gotten a similar error from BizTalk EDI.

    Unless someone modified the Schema to remove the requirement, making it non-compliant.

    • Marked as answer by vai2000 Wednesday, June 26, 2019 3:18 PM
    Tuesday, June 25, 2019 7:48 PM

All replies

  • The Schema used by BizTalk EDI provides Level 1 & 2 SNIP.

    SV107 is required so you should have gotten a similar error from BizTalk EDI.

    Unless someone modified the Schema to remove the requirement, making it non-compliant.

    • Marked as answer by vai2000 Wednesday, June 26, 2019 3:18 PM
    Tuesday, June 25, 2019 7:48 PM
  • You are the best!

    SV

    Wednesday, June 26, 2019 3:18 PM