none
Exchange Monitor Item Filters Not Working RRS feed

  • Question

  • Hello,

    I have a runbook that begins with a Monitor Item activity from the Exchange User IP. It's monitoring a mailbox for any new emails that come in. In the Filters tab, I set up a couple filters to only pull in messages from a specific email and with a specific subject line.

    However, when I let the runbook run, it will continue no matter what. Even if there wasn't a new email that comes in. Is it because the messages in the inbox are left unread? Is it considering those unread emails as "New"?

    Also, it creates a new instance about every 3 seconds or so. I'm guessing the monitor interval is in milliseconds so I increased it to 3000, but it still runs every 3 seconds.

    Here are my settings for the activity:

    Is there a better way to handle monitoring inboxes? Should I be having the runbook mark the email as read? How do I stop the monitor from checking so often?

    Any help would be appreciated. Thanks!

    Monday, October 14, 2019 8:57 PM

All replies

  • Hi,

    there should be only new Instances and Instances in "Log History" while the Runbook is executing if the filter condition are met.

    I guess "Monitor Item" is running in an error.

    Anny hints on the Runbook Server(s) in C:\ProgramData\Microsoft System Center 2012\Orchestrator\RunbookService.exe\Logs or C:\ProgramData\Microsoft System Center 2012\Orchestrator\PolicyModule.exe\Logs ?

    Does "Get Item" work?

    Which versions of System Center and the Exchange User IP you are running?

    Regards,

    Stefan


    More and news about System Center at stillcool.de and sc-orchestartor.eu .

    Tuesday, October 15, 2019 7:52 AM
    Answerer