none
Upgrade Sharepoint 2013 Service Bus 1.0 to 1.1 RRS feed

  • Question

  • Hello:

    I'm trying to follow the instruction on the following link: https://msdn.microsoft.com/en-us/library/dn441403.aspx

    but in step 5 when I try to execute Invoke-SBFarmUpgrade as follows:

    Invoke-SBFarmUpgrade -SBFarmDBConnectionString 'Data Source=<MyServerName>;Initial Catalog=SBManagementDB;Integrated Security=True;Encrypt=False' -CertificateAutoGenerationKey $mycert

    I receive the following error:

    Invoke-SBFarmUpgrade : The specified network password is not correct.
    At line:1 char:1
    + Invoke-SBFarmUpgrade -SBFarmDBConnectionString 'Data
    Source=EMXDFEM0204;Initial  ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : OperationStopped: (:) [Invoke-SBFarmUpgrade], Cr
       yptographicException
        + FullyQualifiedErrorId : InstallCertFailed,Microsoft.ServiceBus.Commands.
       InvokeSBFarmUpgrade

    Anyone has any idea what can be the error and how to fix it?

    Thursday, February 25, 2016 8:41 PM

All replies

  • is there any update?
    Tuesday, March 1, 2016 1:50 AM
  • Hi,

    A suggestion is that you can check the Event Viewer to get more details about this issue which should be helpful to troubleshoot this issue:

    https://msdn.microsoft.com/en-us/library/jj193001.aspx

    As this issue is more relate to Windows Server, I would suggest you post it to the corresponding forum, you will get more confirmed answers there:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?category=Windowsserver

    Best Regards,

    Dean Wang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, March 1, 2016 7:27 AM
    Moderator
  • Not sure if Neo would have gotten very far going through the Windows Server support channels. The document he references has the following note: "Service Bus for Windows Server 1.1 does not support upgrading farms used for Workflow Manager 1.0." Workflow Manager 1.0 is installed for SharePoint. Thus, it is likely present on his farm (since he's posting in the SharePoint channel). Aside from completely rebuilding Workflow Manager, I'm not finding any way to upgrade Service Bus 1.0 to Service Bus 1.1, either, and can understand--from the note--why Invoke-SBFarmUpgrade would have thrown an error for him.
    • Proposed as answer by SharePoint169 Monday, March 30, 2020 7:12 PM
    Monday, September 23, 2019 4:12 PM