none
PXE v síti s VLAN

    Dotaz

  • Řeším teď jednu záhadu s WDS, respektive s PXE bootem. Jedná se o síť s více VLAN, kde je řízení přístupu mezi VLAN řízeno z ISA serveru 2006. Nad VLANkami sedí DHCP server, který korektně přiděluje IP adresy podle toho, do kterého portu na switchi je PC připojeno. Problém je v tom, že nedojde ke spuštění instalace přes PXE. WDS sedí na serveru, kde sedí DHCP server, proto je v DHCP záznam 060-PXEClient. Na switchi jsou u každé VLAN nastaveny IP Helper adresy.

    WDS je ověřena u DHCP serveru. Přesto každý pokus o spuštění z jiné, než default VLAN skončí chybou PXE-055. Zkoušel jsem už lecos, ale trochu mi docházejí nápady. V default VLAN vše funguje zcela bez problémů.

     

    Servery včetně domain controlleru jsou v default VLAN.

     

    Připadá mi to jako chyba routování, ale když jsem si tutéž konfiguraci nastavil v testovacím prostředí, tak vše fungovalo i over VLAN. routovací tabulky na ISA, i na serverech jsou v testovacím i ostrém provozu shodné.

    13. prosince 2008 13:05

Odpovědi

  • Tak po dlouhém, ale úspěšném boji mohu prohlásit Astala Vista, teda Astala XP. Už to funguje. Příčina? Odhadnul jsem ji správně. Routing. I když mi celá VLAN topologie routuje přes ISA server, tak zrovna jak na potvoru tyhle DHCP packety musí routovat L3 switch. Protože tím, že jsem mu přes switch sdělil adresu IP helpera, on to vzal jako druhou gateway.

    Přišel jsem na to čirou náhodou a to tak, že jsem rozdělil od sebe ty dvě role. Takže DHCP seděl na jiném serveru ve stejné VLAN jako WDS/PXE a přes 066 a 067 jsem mu nadiktoval, kde má ty image hledat a on mi ukázal, že si IP adresu konečně schroustal včetně souvisejících parametrů a jal se hledat TFTP server, což skočilo timeoutem. Jenže proč, protože měl v konfiguraci IP dvě gateways, jednu, která ukazovala správně na tu ISU a druhou, která ukazovala na IP adresu VLANy, tedy na IP adresu switche (a ta byla primární). Stačilo tedy na switchi zapnout routing a už to svištělo. Proč tedy neroutuju přes ten switch místo ISA serveru? Protože switch neumí Access listy a nedá se tak říct, do které VLAN má který počítač přístup a do které ne.

    Takže doufám, že budu mít co nejdéle od PXE/TFTP/WDS pokoj, neb tyhle průsery se hledají opravdu velmi, velmi těžko. Díky za tipy. BTW: to mazání PXEClient záznamu jsem dělal jako asi druhý pokus.

    14. prosince 2008 14:17

Všechny reakce

  • Z jake vlany odpovida tftp server?

     

    MP

     

    13. prosince 2008 20:09
    Moderátor
  • No právě, že vše podstatné je v té default, tj jak DHCP, tak DNS, tak AD, tak WDS s PXE serverem, ty další VLAN jsou jen pro stanice, ne pro servery.

     

    13. prosince 2008 20:15
  • Zkusil bych opravdu nejakeho klienta nabootovat do OS a pres

     

    tftp -i ipadresaserveru get pxeimage

     

    overil

     

    MP

     

    13. prosince 2008 20:23
    Moderátor
  • Zrovna se v tom vrtám, tak to zkusím. Je divné, že z té default to normálně funguje, čili konfigurace WDS je správná. Díky za tip. Já jsem zatím pátral spíš síťovým směrem, takže přes Network monitor.

     

    13. prosince 2008 20:27
  • NetworkMonitor bych samozrejme poradil jako 2. moznost Smile Idealne soupnout mezi switch a stanici HUB a do nej promiskuitniho cichace

     

    MP

     

    13. prosince 2008 20:32
    Moderátor
  • Na tyto účely tam mám dost slušné vybavení, port ze switche si přesměruju na monitorovací port, kde mi čmuchá ProcurveManager. Leč se bojím, že tohle bude zas nějaká chuťová jobovka. Teď se snažím kompletně přeupgradovat firmwary na serverech, switchích. Pak zkusím to stažení image přes tftp a pak zkusím tu proradnou ISU přestavět, jestli v tom nemá prsty a už se těším jak přijdu na to, že to způsobuje nějaká zastaralá knihovna bůhví čeho. Díky moc za reakce. Jdu dále bojovat.

     

    13. prosince 2008 20:37
  •  

    Takže tftp přenos proběhl ze všech VLAN, čili TFTP, WDS fungují OK. Takže na 100% to bude něco s DHCP. Ale co?

    Ten boot probíhá tak, že se snaží jakože číst z DHCP serveru, vezme si adresu, ale když to asi po pěti minutách skončí, tak to hodí chybu PXE-055 a IP adresa, která by měla udávat IP serveru s DHCP je 0.0.0.0

     

    Ve switchích jsou nakonfigurovány IP helpery pro každou VLAN zvlášť ukazující právě na ten DHCP/WDS server. A ty helpery fungují, protože ten počítač si skutečně leasne správnou IP adresu ze správné VLAN. No to jsem zvědavý, co z toho vyleze za blbost.

    13. prosince 2008 22:44
  • tohle je BFM ale SMAZ zaznam PXEClient z DHCP, testni, pridej zaznam z5.

     

    Kdysi jsem podobne laboroval kdyz jsem si na RIS/WDS moci mermo chctel nacpat images svych bootovacek

     

    MP

     

    14. prosince 2008 13:58
    Moderátor
  • Tak po dlouhém, ale úspěšném boji mohu prohlásit Astala Vista, teda Astala XP. Už to funguje. Příčina? Odhadnul jsem ji správně. Routing. I když mi celá VLAN topologie routuje přes ISA server, tak zrovna jak na potvoru tyhle DHCP packety musí routovat L3 switch. Protože tím, že jsem mu přes switch sdělil adresu IP helpera, on to vzal jako druhou gateway.

    Přišel jsem na to čirou náhodou a to tak, že jsem rozdělil od sebe ty dvě role. Takže DHCP seděl na jiném serveru ve stejné VLAN jako WDS/PXE a přes 066 a 067 jsem mu nadiktoval, kde má ty image hledat a on mi ukázal, že si IP adresu konečně schroustal včetně souvisejících parametrů a jal se hledat TFTP server, což skočilo timeoutem. Jenže proč, protože měl v konfiguraci IP dvě gateways, jednu, která ukazovala správně na tu ISU a druhou, která ukazovala na IP adresu VLANy, tedy na IP adresu switche (a ta byla primární). Stačilo tedy na switchi zapnout routing a už to svištělo. Proč tedy neroutuju přes ten switch místo ISA serveru? Protože switch neumí Access listy a nedá se tak říct, do které VLAN má který počítač přístup a do které ne.

    Takže doufám, že budu mít co nejdéle od PXE/TFTP/WDS pokoj, neb tyhle průsery se hledají opravdu velmi, velmi těžko. Díky za tipy. BTW: to mazání PXEClient záznamu jsem dělal jako asi druhý pokus.

    14. prosince 2008 14:17