locked
Problém s instalací PHP na vistu

    Dotaz

  • Chci si udělat Apache/PHP/MYSQL pro svoje soukromý weby, ale při instalaci PHP se mi napíše chyba php error 2738. Na internetu sem našel že to je vistou. a že se musí něco upravit. Neví někdo co a jak ?
    úterý 4. srpna 2009 9:28

Odpovědi

Všechny reakce

  • Co místo Apache použít IIS? Součástí Windows Vista IISko je a není problém tam php dotlačit. Zde mám lepší zkušenosti s tzv. ruční instalací.
    http://e-jirka.spaces.live.com/blog/cns!759A2E0FD3BD689F!270.entry?sa=990941503

    Co se týká automatické instalace PHP, zkoušel jsem tento postup: http://blogs.msdn.com/heaths/archive/2007/05/31/windows-installer-errors-2738-and-2739-with-script-custom-actions.aspx?
    úterý 4. srpna 2009 12:16
  • Co místo Apache použít IIS? Součástí Windows Vista IISko je a není problém tam php dotlačit. Zde mám lepší zkušenosti s tzv. ruční instalací.
    http://e-jirka.spaces.live.com/blog/cns!759A2E0FD3BD689F!270.entry?sa=990941503

    Co se týká automatické instalace PHP, zkoušel jsem tento postup: http://blogs.msdn.com/heaths/archive/2007/05/31/windows-installer-errors-2738-and-2739-with-script-custom-actions.aspx ?

    IIS vubec ve Vistě není, ale já bych radši Apache. A co se týče toho druhýho odkazu trošku jsem to nepochopil
    úterý 4. srpna 2009 15:13
  • Použil bych prográmek Microsoft Web Platform Installer nainstaluje se IIS a PHP.

    Po naistalování ISS a PHP stačí ze stránek MySQL stáhnout DB. Nebo nainstalovat pomoci Microsoft Web Platform Installer MS SQL 2008

    úterý 4. srpna 2009 15:56
  • Použil bych prográmek Microsoft Web Platform Installer nainstaluje se IIS a PHP.

    Po naistalování ISS a PHP stačí ze stránek MySQL stáhnout DB. Nebo nainstalovat pomoci Microsoft Web Platform Installer MS SQL 2008

    IIS nepodporuje .htaccess, a další věci co Apache jo. Potřeboval bych přesnej návod jak vyřešit přímo tu chybu u instalace. IIS nainstaluju, pokud tu Apache chybu nevyřešim.
    úterý 4. srpna 2009 16:25
  • Máte pravdu, IIS nepodporuje klasický .htaccess, má vlastní řešení. Každopádně předpokládám, že Vy nainstalujete Apache v pořádku a následně instalujete PHP pomocí instalátoru, který selže.
    Zkusil jste stáhnout PHP jen jako zip a nainstalovat ho ručně, bez instalátoru? Návodů jsou na internetu kvanta (např. http://myego.cz/item/instalace-apache-mysql-a-php-na-windows). Myslím, že by tohle projít mohlo.
    úterý 4. srpna 2009 21:32
  • IIS vubec ve Vistě není, ale já bych radši Apache.
    Ovládací panely - Programy - Zapnout nebo vypnout funkce systému Windows - Internetová Informací SLužba :-)
    úterý 4. srpna 2009 21:35
  • .htaccess implicitně ne, lze doplnit pomocí doplňků nebo použít některé vlastnosti a nastavení pomocí konzole pro správu IIS popsané například v KB324064 ... většinu vlastností, které obsahuje Apache (v rámci ini konfigurace) lze svým způsobem naklikat i ve správě IIS nebo dodat pomocí pluginu.

    Jinak IIS bývá schované (defaultně neinstalované) v menu Ovládací panely > Programy > Zapnout nebo vypnout funkce systému Windows pod Internetová informační služba.

    Pokud máš nejnovější verzi instaleru PHP (instaluješ Apache, MySQL, PHP zvlášť či v rámci nějakého Web Server Packu jako například XAMPP - to bývá leckdy nejjednoduší cesta pro začátečníky - vše v jednom a vše již nastaveno funkční i s nápovědou) měla by být chyba již opravena.

    Jinak můžeš zkusit znovu zaregistrovat DLL knihovnu příkazem (spustit příkazový řádek pod právy administrátora [pravé myšítko, Spustit jako Administrátor]) "regsvr32 vbscript.dll" (nejlépe v adresáři system32 nebo syswow64, dle verze systému), pokud nepomůže, podívat se do registru zda neobsahuje klíč "HKEY_CURRENT_USER (HKCU)\SOFTWARE\Classes\CLSID\{ B54F3741-5B07-11CF-A4B0-00AA004A55E8}", ten smazat, vypnout UAC, předchozím příkazem reregistrovat knihovnu a zkusit znovu instalaci.

    EDIT: Sákryš, škoda, že to není AJAXově refreshované to fórum, člověk než sesmolí odpověď, jsou tu dvě stejné. Chválihodné e-Jirko :-)
    úterý 4. srpna 2009 21:53
    Vlastník
  • Děkuju vám za rady, ale opravdu nechci IIS, takže se pustim do řešení PHP Chyby. co se týče Packů, tak to použiju v krajní mezi, já bych radši čistější instalaci, tedy všechny 3 si nainstalovat sám a zvlášť.  
    E-Jirko prosím tykej mi eště mi není ani 18 :-D. 
    středa 5. srpna 2009 8:29