locked
Win 7, problém s automatickou IP adresou RRS feed

  • Dotaz

  • Zdravim pritomne, obracim se na vas se zadosti o radu.
    V notebooku ve windows 7 mi nefunguje nacteni kompletni automaticke IP adresy. (ani pres wifi, ani pres kabel).
    Kdyz necham automatiku, tak se mi  brana, dhcp a dns nastavi na 192.168.1.1
    IP jako jedina se nacte spravne (192.168.1.109).
    viz obrazek na http://www.bxclub.com/_moje/ip.jpg
    když nastavim manualne vsechny hodnoty, tak vse jede jak ma , vcetne okolnich pc na siti... proste vse.
    Pouze ta automatika je nejaka mimo provoz, coz mne trochu mrzi, nebot az se budu potrebovat pripojit jinde kde nebudu znat co prideluje router, tak pohorim prave na te aiutomatice :-(
    Predem vam dekuji za rady.
    ahojte
    marty
    pondělí 12. října 2009 8:32

Odpovědi

  • DObrý den,

    takže si to shrňme - co vám vlastně nefunguje? Já jen, že to co jste popsal je naprosto v pořádku. Na síťi máte zařízení, které vzdáleně nastavuje IP konfiguraci. To je tzv. DHCP. Vaše Windows 7 poslali DHCP požadavek a "to zařízení" vrátilo tuto konfiguraci:

    jedinečná IP klienta: 192.168.1.109
    Maska sítě: 255.255.255.0
    Výchozí brána: 192.168.1.1
    Server DNS: 192.168.1.1

    A teď nastává ten kritický moment - o co vlastně jde? Jestli se vám špatně nastavují tyto hodnoty, tedy brána má být třeba 192.168.1.2

    Ale to si musíte upravit v nastavení DHCP služby na tom konkrétním zařízení, které tuto službu ve vaší síťi poskytuje.
    • Navržen jako odpověď KazzanMVP pondělí 12. října 2009 10:14
    • Označen jako odpověď marty.j pondělí 12. října 2009 13:32
    pondělí 12. října 2009 9:44
  • Onen NB v síti tedy již figuroval a v rámci XP vše fungovalo jak má, jestli tomu dobře rozumím.

    Například: Nezapomeňte na fakt, že v síti může DHCP serverů běžet klidně více. Jeden špatně nakonfigurovaný a jeden dobře, ostatní klienti mají zapůjčenou adresu od toho, který je nastaven dobře a vždy se zeptají toho samého o prodloužení a hodnoty. Ale Váš NB se zeptal na síti a první, kdo mu odpověděl byl ten špatně nakonfigurovaný...

    Prověřte nastěvní DHCP serveru, potažmo tedy AP. Můžete též aktualizovat ovladač pro Vaší síťovou kartu. Nejsou AP značky Netgear? Windows 7 RTM?
    • Označen jako odpověď marty.j pondělí 12. října 2009 13:33
    pondělí 12. října 2009 10:22

Všechny reakce

  • Jak vypadá ona síť? Co je 192.168.1.1? Co Vám přiděluje přes DHCP ony adresy? A jak mají být ony správné hodnoty? Pripojujete se onou domácí wifi k nějaké další (provider) nebo například máte ADSL od O2 s tou malou krabičkou od Huawei?
    pondělí 12. října 2009 8:52
  • omlouvam se zapomel jsem napsat co tam spravne ma byt kdyby se to automaticky nacetlo,
    ip : 192.168.1.109
    maska: 255.255.255.0
    brana: 192.168.1.100
    dns: 62.240.190.4
    dhcp: (tu by melo byt asi ANO), to ja ted nepoznam ted mam rucni ip adresy a tak ted tu mam NE.
    pripojujeme se pres naseho mistniho poskytovatele wifi, a od nej nasimy routery to sirime po firme, a ja se nepripojim ani na jednu ze tri moznych firemnich wifi siti..
    pondělí 12. října 2009 9:40
  • DObrý den,

    takže si to shrňme - co vám vlastně nefunguje? Já jen, že to co jste popsal je naprosto v pořádku. Na síťi máte zařízení, které vzdáleně nastavuje IP konfiguraci. To je tzv. DHCP. Vaše Windows 7 poslali DHCP požadavek a "to zařízení" vrátilo tuto konfiguraci:

    jedinečná IP klienta: 192.168.1.109
    Maska sítě: 255.255.255.0
    Výchozí brána: 192.168.1.1
    Server DNS: 192.168.1.1

    A teď nastává ten kritický moment - o co vlastně jde? Jestli se vám špatně nastavují tyto hodnoty, tedy brána má být třeba 192.168.1.2

    Ale to si musíte upravit v nastavení DHCP služby na tom konkrétním zařízení, které tuto službu ve vaší síťi poskytuje.
    • Navržen jako odpověď KazzanMVP pondělí 12. října 2009 10:14
    • Označen jako odpověď marty.j pondělí 12. října 2009 13:32
    pondělí 12. října 2009 9:44
  • kriticky  moment je ten, ze dostanu spatnou branu a dns.
    shrnu to tedy take i ja:
    Výchozí brána: 192.168.1.1 ma se nacist: 192.168.1.100
    Server DNS: 192.168.1.1 ma se nacist: 62.240.190.4
     a jeste DHCP: 192.168.1.1 a to netusim co ma byt
    dokud jsem mel XP, vse fungovalo bezvadne, jine notebooky a pda zadny problem s automatikou nemaji, pouze tento s win 7
    Myslite tedy ze je zapotrebi neco donastavit na routrech? Nebot jak jsem vyse napsal nepripoji mne to v poradku na zadny ze tri  routeru.
    pondělí 12. října 2009 10:15
  • Onen NB v síti tedy již figuroval a v rámci XP vše fungovalo jak má, jestli tomu dobře rozumím.

    Například: Nezapomeňte na fakt, že v síti může DHCP serverů běžet klidně více. Jeden špatně nakonfigurovaný a jeden dobře, ostatní klienti mají zapůjčenou adresu od toho, který je nastaven dobře a vždy se zeptají toho samého o prodloužení a hodnoty. Ale Váš NB se zeptal na síti a první, kdo mu odpověděl byl ten špatně nakonfigurovaný...

    Prověřte nastěvní DHCP serveru, potažmo tedy AP. Můžete též aktualizovat ovladač pro Vaší síťovou kartu. Nejsou AP značky Netgear? Windows 7 RTM?
    • Označen jako odpověď marty.j pondělí 12. října 2009 13:33
    pondělí 12. října 2009 10:22
  • Jediný mě známý problém se vyskytoval v kombinaci Windows 7 Beta a AP značek Netgear a některých no name zařízení (upgrade ovladače síťové karty případně firmwaru zařízení problém vyřešil).

    Existuje ve Vaší sítí zařízeni s adresou 192.168.1.1? Najít, vypátrat (ping, tracert)...
    pondělí 12. října 2009 10:26
  • ano , onen NB pod XP bezel jak ma.
    Pote format a ted win 7 (omlouvam se ale nevim co je RTM).
    Od noveho win  automatika nejela.
    Nejede vlastne ani doma na automatiku (na wifi a ani na kabel), kde mam pripojemi sitovym kabelem od jineho mistniho poskytovatele, AP  mam doma od edimaxu...  Pod XP, samozrejme sem take fungoval bez potizi.
    Jake dostanu doma hodnoty to ted netusim, mozna to bude zapotrebi vedet pro dalsi hledani priciny.
    Ovladac zkusim pohledat novejsi, mam
     pro wifi: Broadcom 802.11g verzi 4.176.75.23  a pro kabel: Marvell Yukon 88E8072 PCI-E Gigabit Ethernet Controller verze 11.0.5.3.

    edit:
    dodatek: reaguji sam na sebe... premyslim o tom slove DOSTANU. Co kdyz dostavam z roteru spravnou branu a dns, ale win7 to nejak neumi prebrat?
    pondělí 12. října 2009 10:39
  • RTM = Release To Manufacture, aneb prostě finální verze, která půjde do prodeje. Předpokládám, že jelikož byly na NB XP a byl přeinstalován, že pokud nemáte TechNet předplatné bude se nejspíše jednat o RC verzi.

    Pokud router (AP) doma nastavoval naprosto jiný rozsah síťových adres (například oblíbené 10.0.0.138 u ADSL) a Vám by stále z DHCP naskakovalo 192.168.1.1, pak by byl asi někde háček.

    Zkuste ony aktualizované ovladače (důležité bude, jestli výrobce Vašeho NB s ovladači pro Windows 7 počítá), vyhledat ono 192.168.1.1 v síti, juknout se HP Wireless Assistant (některé verze obstarávaly konfigraci nezávislou na Windows / je určen pro Windows 7).

    Pokud všechny ostatní počítače ve Vaší síti běží na Windows XP a ani jeden na Windows Vista, pak by se poprvé mohl projevit i problém KB928233, ale vzhledem k tomu, že dostanete adresu .109 toto vylučuji.

    Ostatně mě napadá jaké změny byly v konfiguraci sítě provedeny neboť implicitně je povoleno IPv6, tedy nejspíše opět záležitost ovladače síťové karty (typ NB HP?).

    Případně se na to můžeme podívat u Vás v reálu jako placený servisní výjezd ;-)
    pondělí 12. října 2009 11:12
  • Nesmysl, o chybné "interpretaci" to nebude.

    Spíš jste v jiné síti, než je ten zbytek, nebo se vám tam něco s něčím pere. Jak psal Kazzan - např DHCP.

    Na té adrese 192.168.1.1 si vlezte do admin rozhranní a pak upravte nastavení DHCP na správné hodnoty.

    Varianta, že by XP interpretovala jiná nastavení IP než 7 je podle mě vedle.
    pondělí 12. října 2009 11:15
  • "automatika" vám funguje - dostáváte hodnoty. Dostáváte špatné hodnoty, ale to bude problém spíš v nastavení DHCP než Windows 7.

    • Navržen jako odpověď KazzanMVP pondělí 12. října 2009 13:22
    pondělí 12. října 2009 11:18
  • Panove klobouk dolu...
    bylo to v halvnim routeru, ten pry "nepoznal" muj NB a proto mi udajne priradil  ty  divne IP adresy 192.168.1.1 :-)
    Ted musim doma prolezt sve AP a hledat ... i kdyz nevim co presne hledat.
    Domaci AP by ale melo byt OK, bo manzelka se svym NB je bez problemu na automaticke IP.
    Jinak kazdopadne jeste jednou diky.

    pondělí 12. října 2009 13:19
  • ah tak ano, RC.
    Doma IP rozsah mam stejny jako na firme, tj 192.168.1.100 az 200
    Ovladace jsem nastesti nepotreboval, viz muj prispevek dole...
    Ten problem co jste naznacoval http://support.microsoft.com/kb/928233 jsem uz studoval vcera a rovnez jsem usoudil ze to neni muj pripad.
    Jo, a IP6 mam odznaceny.. jinymy slovy: nemam je povoleny.
     Placeny vyjezd? Hmm pokud byste si nechali platit cca 700 km z Prahy ke mne a zpet, tak bych se nejspise radne financne prohnul.Nebo mate sve servisni strediska i v ruznych krajich? A jakou mate cenu?
    PS: omlouvam se za OT, kam jsem ted odbehl
    pondělí 12. října 2009 13:28
  • Dnes jen popis co doma.
    Prijdu domu, zapnu NB, a..... , a on si vesele najel na automatiku. ackoliv se mu na ni nikdy nechtelo jet :-).
    Takze timto je muj problem uplne vyreseny.
    Jeste jednou vam diky.
    úterý 13. října 2009 3:28