none
Podmínka v buňce definované jako číslo RRS feed

  • Dotaz

  • Dobrý den. Mám aktualizované Windows10, implicitní antivirovou ochranu a Microsoft365. Při zadání podmínky v buňce formátované jako číslo s testováním buňky definované jako číslo se mi někdy objevuje 0 a někdy je buňka prázdná. Příklad podmínky: =KDYŽ(D25<>0;D$25/1;" "). Potřebuji, aby v případě kdy je testovaná buňka prázdná, aby i buňka s podmínkou byla také prázdná a neobjevovala se v buňce 0. Předem děkuji za odpověď.
    pátek 12. března 2021 11:19

Všechny reakce

  • Dobrý deň,

    robí to takto aj novom prázdnom xlsx súbore kde si to nasimulujete?
    Skúšali ste dočasne vymazať všetky formáty čo to bude potom robiť?
    Viete identifikovať pri akej situácii je tam nula a kedy zase prázdna? Myslím tým v súvislosti s inými hodnotami, bunkami, ktoré by to mohli ovplyvniť?

    Peter B.

    čtvrtek 18. března 2021 21:48
  • Dobrý den,

    vytvořil jsem nový soubor a na čistém listě jsem do buňky vložil podmínku =KDYŽ(D26<>0;D$25/10;" "). Nic jsem neformátoval a když jsem vložil do buňky D25 1 vrátilo mi to na D26 0,1. Jak jinak, že :-). pak jsem naformátoval buňky D25:D30 jako číslo s dvěma desetinnými místy a mezerou před desetitisícovkami a stále byly buňky prázdné. Když jsem vložil do D25 1 vrátilo mi to na D26 opět 0,1. Pak jsem vložil pod sebe do buněk D27:D30 podmínku =KDYŽ(D26<>0;D$25/10;" ").... a pak jsem přišel na to, kde jsem udělal začátečnickou chybu a to tím, že jsem v podmínce za D nevložil $ a překopíroval jsem buňky ve sloupci potažením levého dolního křížku... omlouvám se a děkuji.

    pátek 19. března 2021 10:18