locked
Požadavek na heslo u Outlooku 2013 a vyššího při vytváření nového profilu RRS feed

  • Dotaz

  • Mám Exchange 2016 on-premise, proběhla migrace z Exchange 2010.

    Při vytváření nového profilu v Outlooku 2013 a vyšším se to chová tak, že po zadání e-mailové adresy a výběru typu serveru (Exchange), Outlook zobrazí výzvu k zadání hesla pro aktuálního uživatele. Toto heslo následně uloží do uložených pověření jako MicrosoftOffice16_Data:SSPI:username@domain.local. Poté se dokončí konfigurace Outlooku a ten se spustí. Po vypnutí Outlooku jeho opětovném spuštění se uložené pověření automaticky odstraní a Outlook už se na heslo neptá.

    Metoda ověřování virtuálních adresářů je nastavena defaultně (kontrolováno dle https://docs.microsoft.com/en-us/exchange/clients/default-virtual-directory-settings?view=exchserver-2016 ).

    Věděl by někdo, proč Outlook požaduje heslo při vytvoření profilu? Je možné nějak nastavit, aby se na heslo neptal?

    Díky


    BB

    čtvrtek 16. května 2019 14:27

Všechny reakce

  • Get-ClientAccessServer

    jak je nastaveno AutoDiscoverServiceInternalUri ?

    čtvrtek 16. května 2019 14:44
  • AutoDiscoverServiceInternalUri je nastaveno na hodnotu https://mail.firma.cz/autodiscover/autodiscover.xml.

    Je použito split DNS, tedy v lokálním DNS je A záznam pro mail.firma.cz s lokální IP adresou Exchange serveru (192.168.xxx.yyy).


    BB

    pátek 17. května 2019 6:32
  • A chce to heslo, kdyz uvnitr browserem jdu na https://mail.firma.cz/autodiscover/autodiscover.xml ?

    Pokud ano, je mail.firma.cz v zone intranet na danem stroji?

    IMHO nejde pro zjisteni nastaveni pres Autodiscover windows auth, proto to skonci na basic auth = zadat heslo.

    pátek 17. května 2019 9:39
  • Mail.firma.cz v zóně intranet nebyl a heslo při přístupu na https://mail.firma.cz/autodiscover/autodsicover.xml to chtělo.

    Přidal jsem toto URL do zóny Intranet a v prohlížeči to při přístupu na Autodsicover web heslo už nechce.

    Nicméně Outlook se chová pořád stejně.

    Autentizace Autodiscover na Exchange serveru je nastavena takto (v IIS): Anounymous authentication, Basic authentication a Windows authentication je povoleno.

    U Windows authentication jsou povoleni tito poskytovatelé: NTLM a Negotiate (v tomto pořadí).

    V jedné diskuzi jsem se dočetl, že požadavek na heslo Outlook vyhodí, když e-mailová adresa v konfiguračním průvodci Outlooku je odlišná od UPN uživatele. Což v tomto případě je. E-mail je test@firma.cz a UPN je test@firma.local. Ale jestli to je pravda nebo ne nevím, našel jsem to jen v jednom zdroji.


    BB

    pátek 17. května 2019 10:47
  • muzes overit :)

    Si do AD pridej mail domenu a test uzivateli UPN zmen. Takto se to dela pri integraci AD s O365.

    pátek 17. května 2019 12:16
  • Hmm, tak přece jen by to mohlo být tou odlišností mailové adresy a UPN. Našel jsem další zmínku: https://www.stephenwagner.com/2018/10/16/how-to-add-an-alternative-upn-suffix-to-an-active-directory-domain/

    V pondělí testnu alternativní sufix a dám vědět.


    BB

    pátek 17. května 2019 17:02
  • Tak bohužel bez výsledku. Přidal jsem alternativní doménu, uživateli změnil UPN na test@firma.cz, tedy shodné s e-mailovou adresou a heslo to chce pořád . . .

    BB

    pondělí 20. května 2019 13:30
  • Ještě mám jeden poznatek: Když požadované heslo zadám, tak se po dokončení průvodce přidání účtu Outlook spustí.

    Když požadavek na heslo vystornuji, tak po dokončení průvodce Outlook zahlásí, že nemohl otevřít sadu složek etc.  a nespustí se. Nicméně další spusštění Outlooku už proběhne OK a na heslo se neptá.


    BB

    pondělí 20. května 2019 15:47
  • Tak jsem na to pustil Fiddler a vypadá to, že požadavek na heslo vyskočí při přístupu na URL https://mail.firma.cz/api.

    BB

    pondělí 20. května 2019 15:54