none
Windows 2003 server - odpojeni sitovych slozek po restartu

    Dotaz

  • Zdravim, mam problem s w 2003 (SP2). Po restartu win 2003 (SP2) se odpoji sdilene slozky a je potreba je rucne pripojit. Sdilene slozky jsou na diskovem poli EMC AX150i pripojeny pres SCSI.
    Mockrat dekuji za pomoc

    26. srpna 2008 9:40

Odpovědi

Všechny reakce

  • Ahoj,

    jedine co me napada je ze ti sluzba lanmanserver nabehne drive nez radic pole.

     

    Ale radsi se zeptam: co znamena "odpoji sdilene slozky"? Myslis ze ti zmizi shares na serveru a je treba je znovu nasdilet nebo naopak ti zmizi mapovane jednotky a je nutne je znovu namapovat (zde pomuze net use /persistent:yes)

     

    Prosim tedy malicko upresni!

     

    MP

     

    26. srpna 2008 10:03
    Moderátor
  • Ahoj, diky za reakci Smile

    Kolega prave vcera migroval server na vmware. Ja od nej dostal jen mejl, ze mam hledat pricinu problemu a uvedl :

    "Po restartu w2003 serveru (SP2) se odpoji sdilene slozky, musim je rucne nahazovat. Kdyby si nic nenasel tak upresni dotaz o to, ze sdilene slozky jsou na disku který je pripojen přes SCSI z datového pole EMC AX150i"



    Predpokladam, nebo pochopil jsem z toho, ze se jedna o "shares na serveru" nikoliv o mapovani disku z diskoveho pole.

    Dnes tu kolegu bohuzel nemam, ale pokusim se zjistit podrobnosti. Prikaz na mountovani disku zna kolega velice dobre, takze predpokladam, ze tam problem nebude. V logu take nic

    Moc diky za pomoc

    BK



    26. srpna 2008 11:52
  • Pokud si vsichni 3 rozumime a server nemuze z nejakeho duvodu nasdilet pri startu slozky musi o tom byt zaznam v event logu (od sluzby lanmanserver). Je tam?

     

    MP

    26. srpna 2008 13:26
    Moderátor
  • Ahoj,
    bohuzel v event logu zadny zaznam.
    27. srpna 2008 7:27
  • A uz mas aspon jednoznacny popis problemu?

     

    MP

     

    27. srpna 2008 8:00
    Moderátor
  • Ano,
    zmizi sdileni na serveru a je treba je znovu nasdilet rucne.

    diky
    27. srpna 2008 8:27
  • ze zmizi znamena presne co?

     

    prikaz net share je nevypise?  v HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\Shares nejsou?

     

    MP

    27. srpna 2008 9:31
    Moderátor
  • Nenactou se pri spusteni.

    Problem je momentalne v tom, ze nemuzeme restartovat server. dle prikazu se sdilene slozky vypisou a v registrech jsou take zobrazeny (museli se nasdilet rucne). Zkusime opozdit sluzbu lanmanserver, posleze az pujde restart to restartnem a pak se uvidi.
    Nejprve bych vyzkousel toto a pak bych problem resil dal pokud se spozdenim sluzby nevyresi.

    Dekuji mockrat za pomoc.
    27. srpna 2008 10:15
  • prosim ptal jsem se te jeste na 2 veci - odpovez!

    //aha promin. takze opozdeny start zabral?

     

    MP

    27. srpna 2008 11:45
    Moderátor
  • Pardon, ted nevim co presne myslis.

    sdilene slozky na serveru se ztrati po restartu nebo po vypnuti a opetovnem zapnuti systemu /asi to neumim moc dobre vysvetlit jedna se presneji jak jsi psal u prvniho prispevku " zmizi shares na serveru a je treba je znovu nasdilet"

    prikaz net share mi vypise sdilene slozky a v registrech sdilene slozky take vidim, jelikoz je tam kolega rucne nasdilel. Takze v tuto chvili na nic neprijdu ,,Nastavime delsi prodlevu pri startu sluzby viz. treba toto: http://support.microsoft.com/kb/193888/cs

    a kdyz toto nepomuze resil bych to dale.

    diky
    27. srpna 2008 12:46
  • Jasne. Podivej se jaka sluzba (device) obsluhuje disk a dej ji do zavislosti sluzby lanmanserver (tzn. sluzba server bude zaviset napr. na ABCSCSIMiniport

     

    MP

    27. srpna 2008 12:54
    Moderátor
  •  

    Mam jiny trochu jiny problem... Sit server Windows 2003, stanice Win XP, ucetni system Money S3

     

    ucetni system vyzaduje namapovanou jednotku na server pro pristup k datovym souborum

     

    mam namapovanou jednotku (Z:\)... vse fungovalo do instalace SP2 na windows server 2003

    Ted to z win xp po startu ukaze pripojenou jednotku, ale jak kdyby nebyla "inicializovana" protoze kdyz spustim ucetni system tak mi rekne ze cesta k Z:/ atd... neexistuje... Otevru tento pocitac, tam je normalne jednotka videt, a pri prvnim otevreni akorat o neco delsi nacitani (z 0,1s na 1s Smile ) a otevrou se normalne slozky s daty na serveru... potom uz ucetni system funguje normalne...

     

    technicka podpora microsoftu mi rekla ze nektere programy vyzaduji jen SP1 jinak nemusi korektne fungovat a odkazali na vyrobce softwaru... ten zas ze to neni chyba softwaru, ale systemu... atd.

     

    Zustat na SP1 je blby, ztratim dalsi podporu.

     

    Nemate nejake zkusenosti nebo reseni?

    9. září 2008 7:08
  • Prosim vytvarej nove dotazy, "prilepovanim" ke (stavajicim vyresenym) se stavaji vlakna neprehlednymi!

     

    zacal bych odmapovanim (net use * /delete /yes) a novym primapovanim (net use z: \\server\share /persistent:yes)

     

    Nejake hlasky v eventlogu stanice / serveru? Nemas problemy s resolvingem (DNS, NetBT) a z toho plynoucimi timeouty?

     

    MP

    9. září 2008 7:45
    Moderátor