none
excel 2007 zoradiť text podľa podmienok RRS feed

  • Dotaz

  • zdravím mám problém

     

     

    Každodenne mi chodí rozpis excel. 10 stĺpcov x cca 300 riadkov. V riadkoch sú v abecednom poradí mená a ďalšie informácie. Čo ja potrebujem, je zoradiť tieto mená podľa toho ako sú ubytovaný na izbách. Ubytovaný sú random, čiže si to predstavujem asi tak, že by som mal druhú tabuľku v ktorej by bolo číslo izby a meno a podľa tejto tabuľky s menom by mi zoradilo aj túto moju prvú a ak by sa meno nenachádzalo v tabuľke tak by ho hodilo nakoniec. Samozrejme potrebujem aby riadky boli zviazané (nielen, že poprehadzuje mená ale aj celé riadky nakoľko k menám sú uvedené ďalšie informácie, ktoré musia sedieť.) Ak to takto nieje možné poraďte nejaký najjednoduchší spôsob ako by sa to dalo triediť.

     

     

    Ďakujem

     

     

    Ak tu je už podobný problém tak sa ospravedlňujem a poprosím link ale nenašiel som nič čo by sa zhodovalo.

    neděle 26. prosince 2010 16:44

Odpovědi

  • Ahoj,
    popis neni prilis jasny. Mas tedy pokud chapu dobre 2 tabulky:

    1. jmeno a dalsi informace
    2. jmeno a cislo pokoje; predpokladam ze jmeno je v 1. sloupci a tabulka je podle nej serazena vzestupne

    Pak si do 1. tabulky proste pridej pomoci funkce SVyhledat (VLookup) cislo pokoje z 2. tabulky, zhruba takto:

    =SVYHLEDAT(A1;Jmeno_a_Pokoj!A:B;2;NEPRAVDA)

    Pote serad 1. tabulku dle takto doplneneho cisla pokoje.

    MP

    • Označen jako odpověď hrban666 neděle 26. prosince 2010 19:26
    neděle 26. prosince 2010 18:56
    Moderátor

Všechny reakce

  • Ahoj,
    popis neni prilis jasny. Mas tedy pokud chapu dobre 2 tabulky:

    1. jmeno a dalsi informace
    2. jmeno a cislo pokoje; predpokladam ze jmeno je v 1. sloupci a tabulka je podle nej serazena vzestupne

    Pak si do 1. tabulky proste pridej pomoci funkce SVyhledat (VLookup) cislo pokoje z 2. tabulky, zhruba takto:

    =SVYHLEDAT(A1;Jmeno_a_Pokoj!A:B;2;NEPRAVDA)

    Pote serad 1. tabulku dle takto doplneneho cisla pokoje.

    MP

    • Označen jako odpověď hrban666 neděle 26. prosince 2010 19:26
    neděle 26. prosince 2010 18:56
    Moderátor
  • Tak takto ma to riešiť nenapadlo... Ja som sa to snažil zoraďovať ale takto to bude oveľa jednoduchšie teda hlavne keď to budem vysvetľovať kolegyni čo bude pracovať budúci týždeň. Ďakujem.
    neděle 26. prosince 2010 19:29
  • jj, svyhledat usetri spoustu prace

    MP

    neděle 26. prosince 2010 20:16
    Moderátor