none
doména a vypnutý netbios, sdílení souborů(port 445)

    Dotaz

  •  

    Zdravím,

     měl bych dvě otázky:

    1) V rámci přípravy na MCSA jsem si chtěl odchytit pakety při přidávání PC do domény v případě vypnutého a zapnutého NetBIOSu. Problém je, že když NetBIOS vypnu(jak na DC, tak na budoucím member serveru), tak join neproběhne a chyba je hned na začátku - budoucí member server nemůže najít domain controller- problém je, že server ani neodešle paket s dotazem, přitom nslookup funguje(resp. je server je dotazy schopen posílat).

     Znamená toto, že server není schopen se přidat do domény bez zapnutého NetBIOSu?

     

    2) Kdesi na netu jsem se dočetl, že winxp dávají přednost portu 445 při sdílení souborů, neboli se snaží vynechat NetBIOS, pokud je to možné. Zajímalo by mě, jestli je to skutečně pravda, protože na čistě nainstalovaných severech 2003(R2, SP2) jsem nezaznamenal ani pokus o komunikaci na portu 445, vše probíhá přes 137-139...

     

     

    Předem děkuji mnohokrát za jakýkoli pokus o odpověď. :-)

     

    Bohdan

    21. července 2008 9:27

Odpovědi

  •  Tak nevím, na nic jsem nepřišel, nastavení ok, chyby v logu žádné. Reinstaloval jsem klienta, nastavil ho stejně jako před tím a nejdnou to jede. Tak bud jsem blbej já nebo nevím. :-)

     možná se nějak nekorektně odhlásil z té domény, když byl zapnutý netbios...

     

    22. července 2008 8:12

Všechny reakce

  • Ahoj,

    pri pridavani do domeny jsi pouzil plne DNS jmeno domeny? Take doporucuji nastavit pred joinem domeny primary DNS suffic prave na DLOUHE jmeno domeny (tedy napr. mojedomena.local)

     

    MP

    21. července 2008 11:35
    Moderátor
  • jj, zkoušel jsem "contoso.local" a stejně nic, "CONTOSO" by fungovat nemělo, to je jasné. Suffix jsem, pravda nenastavoval - dneska vyzkouším. Ale přijde mi divné, že to nejde bez přednastaveného suffixu - resp. že počítač se ani nepokouší to jméno resolvovat - z rozhraní neodešel ani jeden paket - zkoumáno Etherealem.

    21. července 2008 13:29
  • predpokladam ze nslookup <nazevpdc>.contoso.local projde. Kontroloval jsi lmhosts? Nemas nejaky dalsi problem s TCP/IP (spatna maska/default GW; spatne nastavene IPV6)? Zkousel jsi pridat PDC do lmhosts (s direktivou #dom)? Bezi ti sluzby server a workstation? Nemas problem s RPC? Mas na adapateru navazane serverove i klientske sluzby?

     

    MP

    21. července 2008 13:41
    Moderátor
  •  

    nslookup projde. používání LMHOSTS mám zakázané - cílem je požívat pouze DNS/DNS cache. pochybuji, ze je problem v TCP/IP stacku nebo konfiguraci(gateway tam ani neni, jedná se o virtualni stroje - kazdy ma 2 sitovky, 1 local a 1 navazanou na fyziky adapter -tato sitovka je ovsem na obou zakazana). všechno, krom joinu funguje.

     Co se týká dalšího, tak dnes overim, ale predbezne odpovidam ano :-), jelikoz se jedná o naprosto stejný stroj, který se do té domény dostal lze normálne namapovat slozku z toho DC.

    21. července 2008 15:11
  •  Tak nevím, na nic jsem nepřišel, nastavení ok, chyby v logu žádné. Reinstaloval jsem klienta, nastavil ho stejně jako před tím a nejdnou to jede. Tak bud jsem blbej já nebo nevím. :-)

     možná se nějak nekorektně odhlásil z té domény, když byl zapnutý netbios...

     

    22. července 2008 8:12
  • Gratuluji Smile

     

    Oznac si sam svuj prispevek za reseni (byt jsme na pricinu neprisli a asi uz neprijdeme) at thread nevisi v nezodpovezenych.

     

    MP

     

    22. července 2008 8:48
    Moderátor
  • btw, pak se, jako zázrakem, rozchodila i komunikace na portu 445 :-)
    22. července 2008 15:27