none
Sharepoint 2010 - check out documents problem v IE

    Dotaz

  • Ahoj,

    mám tento problém při check out dokumentů IE

    vždy napíše toto

    "This document could not be checked out. You may not have permission to check out the document or it is already checked out or locked for editing by another user

    Zajímavé je, že ve FireFoxu mi to chodí

     

    S pozdravem

    Tomáš

    pondělí 17. října 2011 12:09

Odpovědi

  • No to uz se nam tu nakupilo docela problemu :)

    Jak jste ten SharePoint instaloval? Zakladni (Basic) instalace nebo Pokročilá (Advanced)? Aby fungovaly mySites, profiles atd musí být správně zkonfigurována služba User Profile Service. Máte na Vašem SharePoint Service Pack 1? I nějaké další následné cummulative updates? Ale zpět k Vašemu problému.

    K AAM, pokud přistupujete k SharePoint přes HTTPS, měl byste mít toto zohledněno v AAM.
    V rámci addins v IE , někdy by mohlo zabrat spuštění

    regsvr32.exe OWSSUPP.DLL

    v adresáři C:\Program Files\Microsoft Office\Office14

    K Search .. co Vám search píše v eventlogu? Proč nehledá, resp. co nehledá? Je zkonfigurován a běží?


    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    pondělí 17. října 2011 19:11

Všechny reakce

  • Jakou máš verzi IE? Máš všechny updaty? Zkoušel jsi režim kompatibility v IE?
    pondělí 17. října 2011 12:25
  • Zkoušel jsem IE 8, IE 9, IE 10 beta mám všechny updaty. V kompatibilním režimu jsem také zkoušel 

    pondělí 17. října 2011 12:38
  • Document Library Settings  -> Versioning Settings -> Require Check Out mám zapnutý 
    pondělí 17. října 2011 12:41
  • Ahoj,

    k tomu může vést více věcí. Mrkni na moduly v IE, na AAM na SharePointu, je ta stránka v local intranet? Není v cestě "špatně" nastavený kerberos? Tohle všechno může IE rozhodit, nezávisle na tom, že v ostatních to funguje .. Něco podobného se může stát, když nemáte root site-collection ..

    Marek


    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    pondělí 17. října 2011 14:44
  • Dobrý večer pane Chmel,

    děkuji za rychlou odpověď

    Stránka je vypublikovaná do internetu a přistupuje se do ní z internetové domény, která je uvedena v alternativních URL adresách jako výchozí, také je uvedena i v IIS na portu 80 jako hostname. Na 80 portu je udělaný http redirect na https přes URL rewrite, takže v internetu se vždy přistupuje přes https, https není uveden v alternativních URL, jsou tam pouze záznamy pro http.

    v IE modulech jsou pod Microsoft pouze Sharepoint opendocuments class a Sharepoint Stssync Handler a něco dalšího, o AMM ani zmínka.

    Přístup je nakonfigurován přes IIS - je zapnutý anonymous auth, Basic auth (kde je nastavena také doména, pro snadný přístup) a ASP.NET Impersonation.

    Ve správně je nastaven přístup přes NTLM v integrated Windows auth a client integration je také zapnutý

     

    V root site colection mám určitě něco špatně, protože mi nejde my site, my profile a ani search

    mám tam

    /

    /my

     

    Děkuji za radu

     

    S pozdravem

    Tomáš

     

    pondělí 17. října 2011 16:50
  • v AMM je ta stránka jako default na veřejnou adresu domena.cz
    pondělí 17. října 2011 19:01
  • No to uz se nam tu nakupilo docela problemu :)

    Jak jste ten SharePoint instaloval? Zakladni (Basic) instalace nebo Pokročilá (Advanced)? Aby fungovaly mySites, profiles atd musí být správně zkonfigurována služba User Profile Service. Máte na Vašem SharePoint Service Pack 1? I nějaké další následné cummulative updates? Ale zpět k Vašemu problému.

    K AAM, pokud přistupujete k SharePoint přes HTTPS, měl byste mít toto zohledněno v AAM.
    V rámci addins v IE , někdy by mohlo zabrat spuštění

    regsvr32.exe OWSSUPP.DLL

    v adresáři C:\Program Files\Microsoft Office\Office14

    K Search .. co Vám search píše v eventlogu? Proč nehledá, resp. co nehledá? Je zkonfigurován a běží?


    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    pondělí 17. října 2011 19:11
  • Tak je to skutečně tak, problém byl v tom, že jsem měl uvedemé AMM jak pro http://domena.cz jako default, tak pro https://domena.cz jako internet.

    Stačilo tam mít jen https://domena.cz jako default a bylo pro problémech. Dokonec i log mě na to upozornoval, což je má demence, že mi to nedošlo

     

    user profile service mám nakonfigurovanou, je mi nešla vytvořit my site, psalo mi to nějakou chybu, ovšem to mohlo souviset s tímto problémem, zkusím to teď a napíšu.


    Děkuji mnohokrát

    pondělí 17. října 2011 19:27
  • My Site a My Profile už také běží :-)
    pondělí 17. října 2011 19:37
  • Výborně !! :)
    Marek Chmel, WBI Systems (MCTS, MCITP, MCT, CCNA)
    pondělí 17. října 2011 19:38
  • search vypadá to, že také běží, nicméně nic nenajde :-)
    pondělí 17. října 2011 19:45
  • v content sources mám nastaveno adresy veřejné na https://domena.cz, schedule, prioritu pro zdroj na high a spuštěný full crawl

    status crawling full a pořád nic

     

    "Nebyly nalezeny žádné výsledky pro"

     

    pondělí 17. října 2011 20:21