none
Pomalé připojování do sdílené složky

    Dotaz

  • Zdravím,

    mám tu dva servery 2008 R2 - řadiče domény. K nim mám jěště připojený jeden server pro sdílené složky.

    Mám tu klienty XP i 7. Problém je v tom, že první připojení z klienta na jakoukoliv sdílenou složku na jakýkoliv server v doméně, trvá hodně dlouho. Přenos souborů ale potom probíhá normálně. Na klientovi s WinXP to trvá minutu dvacet, na Win7 trvá 20 vteřin, než se mi nasdílená složka poprvé zobrazí. Napadlo mě, jestli něco není špatně v nastavení DNS, ale dcdiag spuštěný na řadiči domény nehlásí žádný problém. EventLog na klientech taky nedává žádnou relevantní informaci. Můžete mi prosím poradit, kde začít hledat chybu? 20 vteřin je hodně a 80 vteřin je opravdu příliš.

    čtvrtek 19. července 2012 14:46

Odpovědi

Všechny reakce

  • 1. Problem muze byt v nastaveni DNS na klientech. Nemela by tam byt verejna (externi) adresa DNS.

    2. Uvedte vystup z ipconfig /all

    3. To je novy nebo uz pretrvavajici problem?

    4. Jsou nejake chyby a varovani v protokolu udalosti?

    5. Jake dalsi jmenne rozliseni pouzivate (#WINS,...)

    6. Pracujete v ramci jednoho subnetu?

    M.

    čtvrtek 19. července 2012 15:47
    Vlastník
  • Dobrý den,

    Naše DNS adresa je skutečně uváděná ve formátu veřejné adresy. Nepoužíváme připonu ".local". Používáme model ADdomena.firma.poskytovatel.cz, kde domena "firma" je nezávislá obyčejná DNS tvořená na linuxu a "ADdomena" je prvni Active Directory domena v nasi siti. Naši klienti opravdu dostávají přes DHCP plnou příponu ve formátu ADdomena.firma.poskytovatel.cz. Na předělávání řadičů domény do tvaru .local už je dnes pozdě. Navíc tato doména i když má veřejný tvar tak veřejná není. Veřejná je jenom ta část "firma.poskytovatel.cz", tu ale spravuje zase jiný DNS server, který není v naší vnitřní síti - opět bez Active Directory (linux).

    Problém s pomalým připojováním na sdílenou složku možná máme už od začátku nasazení Active directory domény, ale nejsem si tím jistý, protože jsme doposud nepoužívali souborové služby uvnitř AD. Teprve nedávno jsem nainstaloval první souborový server založený na 2008 R2 platformě.

    V protokolu událostí na klientu nejsou žádné chyby. Objevuje se jenom varování od služby napagent, které vzniká během přihlašování do naší 802.1x NAP infrastruktury. Ve výsledku je ale přihlášení dokonáno a plně funkční. V protokolu událostí na souborovém serveru je jenom toto:

    Volume Shadow Copy Service warning: VSS was denied access to the root of volume \\?\Volume{d6c82c29-86b2-4ed0-9775-c7754fd0aaf1}\. Denying administrators from accessing volume roots can cause many unexpected failures, and will prevent VSS from functioning properly.  Check security on the volume, and try the operation again.

    Operation:
       Removing auto-release shadow copies
       Loading provider

    Context:
       Execution Context: System Provider

    Na obou řadičích domény nejsou žádné chyby ani varování v posledních dvou dnech.

    Co se týče dalších jmenných rozlišení, tak jsem žádné nekonfiguroval ani na klientech, ani na řadičích domény. Všechno je ve výchozím nastavení (nevím jakém) - primárně používáme jenom DNS.

    Ano, všechno máme v rámci jednoho jediného subnetu s maskou /16.

    V rámci zachování soukromí jsem nechtěl být příliš konkrétní, můžu ale cokoliv poslat přímo Vám (například i ten výstup z ipconfig, pokud to bude potřeba). Děkuji za Váš zájem a podporu.

    pátek 20. července 2012 12:42
  • Tak jsem přišel na zajímavou věc: zkusmo jsem odinstaloval klienta pro Novell. Po restartu veškeré průtahy vůči sdílené Windows složce zmizely. To je docela nepříjemné zjištění, protože klienta pro Novell mají všechny naše počítače a je to náš hlavní souborový server. Navíc je to nepříjemné i proto, že na tomhle fóru už mi s nastavením Novell klienta nikdo nejspíš nepomůže. Nebo máte nějakou zkušenost v tomto směru?
    pátek 20. července 2012 12:55
  • A. Kde se vzal NOVELL? V originalnim dotazu nevidim ani zminku.

    Ja jsem mel stejny problem s klientem Novellu, kdy odezvy byly pul minuty. Nastesti jsme se Novellu zbavili a takove problemy se uz neobjevily.

    Pokud trvate na Novellu, budete muset dat na stanice posledni variantu Novellu a pokud to nepomuze, obratte se s duverou na forum Novellu.

    B. Ja jsem neupozornoval na formu adresy, ale zda je v nastaveni klienta uvedena EXTERNI adresa DNS. Pokud ano, tak se nedivte.

    C. Nevidim vypis z ipconfig /all

    M.



    pátek 20. července 2012 13:11
    Vlastník
  • Děkuji Vám za tipy. Udělal jsem několik desítek pokusů, a zjistil jsem toto:

    úprava položky BadServer v registru funguje dobře, bohužel je ale použitelná jenom pro Windows XP. Navíc na cca třetině našich počítačů je funkce BadServerCache vypnutá (kvůli NAP), takže se tam použít nedá. Řešením pro oba případy je změnit pořadí zprostředkovatelů služeb (advanced settings / provider order) tak, aby služba novell klient byla až po microsoft klientu. Tohle řešení funguje všude, ale nevím jak ho elegantně zpropagovat do našich počítačů v doméně. GPO politiky na to neexistují, a nevím, jestli bude úplně vhodné používat na tohle nějaký vbi skript. Budu hledat dál.

    pátek 20. července 2012 16:20
  • Nasledujici odkaz sice neni pro W 7, ale muze fungovat jako motivace:

    http://support.microsoft.com/kb/894564#appliesto

    Muzete jit take vlastni cestou: Zjistite, jak se projevi nastaveni registru pri otoceni poradi a tuto zmenu ve forme reg souboru muzete roprostrit po siti treba pomoci psexec.

    M.

    pátek 20. července 2012 18:13
    Vlastník
  • V nastaveni ncpa.cpl - advanced - advaced se presvedc, ze preferovane protokoly a klienti jsou opravdu nastavene v odpovidajicim poradi!

    MP


    pondělí 23. července 2012 13:44
    Vlastník