none
Spuštění WWW

    Dotaz

  • Zdravím mám problém.

    Jedu na MS server 2012 foundation. Mám na něm nahozené weby při lokálním připojení na web 192.168.1.5:8080 jede všechno jak má(přihlášení atd). Potřebuju ted lokálně spustit eshop př 192.168.1.5/eshop. Při připojení přes localhost/eshop je vše funkční. Při připojení přes kterýkoli PC v lokální síti chyba 500 nemám vůbec potění kde by mohl být problém.

    Děkuji

     
    středa 4. února 2015 12:42

Odpovědi

Všechny reakce

  • 1. Máš otevřené příslušné porty na firewallu?

    2. Co říkají logy webserveru?

    3. Ty opravdu chceš k webu přistupovat přes IP adresu nebo to je jenom v rámci testování?


    BB

    středa 4. února 2015 13:17
  • Porty jsou otevřené. V Logu nenajdu žádný dotaz z pc z lokální sítě pouze jen localhost. Dotazy na další weby které mám puštěné fungují dobře. 

    Ta IP je jen na testovaní.

    středa 4. února 2015 14:13
  • Z Tvého popisu to chápu tak, že máš site s nabindovanou IP 192.168.1.5 a v ní virtuální adresář ESHOP. A v logu webserveru pro danou site není zaznamenán žádný přístup z jiného PC než ze samotného webserveru? Pak hledej chybu na síti (firewalls, routing etc.).

    BB

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:14
    středa 4. února 2015 14:20
  • A opravdu to máš na standartním portu 80?

    Nemáš to také na portu 8080?

    Co se stane pokud otevřeš: http://192.168.1.5:8080/eshop

    .

    Chyba 500 by ale spíše ukazovala na to, že se dostaneš až na server jen ta máš někde špatnou konfiguraci.

    Jak máš nastavený ten vnitřní web eshop? Nejsou tam natvrdo odkazy pouze na localhost?


    JCH

    středa 4. února 2015 16:49
  • porty jsem otevřel jak 80 tak i 8080(kdyby náhodou) na obou dvou stejná chyba. prošel jsem i kdyby náhodou síťove omezení, nyní teda už mi PC z lokání sítě volá adresu s eshopem ale z nějákého důvodu nemuže najít proceduru(webMenuGetFree). Na těch dvou zmiňovaných portech mám funkční objednávkový web pro naše pracovníky jede bez problému mám tam pdf tiskový server taky všechno ok, ale ten eshop z lokálních pc prostě ne. Mám strach že nemám asi správně dokonfigurovaný server. Když to vemu mám bránu pouze jako přístup k internetu DNS a DHCP provádí zmíněný server. Tvůrce eshopu se mnou nekomunikuje.

    • Upravený PolipCZ čtvrtek 5. února 2015 12:21
    čtvrtek 5. února 2015 12:12
  • 1. Je to interni chyba. Je nutne uvest vic informaci (bud cislo za 500. popripade pisemny popis)

    2. Volani webu pres IP nebo FQDN by nemel hrat roli.

    3. Na netu jsou mraky clanku na toto tema, tenhle by mohl pochopit problem

    http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm

    M.

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:14
    čtvrtek 5. února 2015 19:25
    Vlastník
  • chyby dle logů při volání stránek "500 0 0 1169" a "301 0 0 202" myslel jsem že by mohl být problém v bráně, ale i po té beze změny. Článků jsem o tom načetl dost. Ale bez výsledku neblíží se k řešení problému. Jestli chybý role nebo funkce, nastavení DNS apod. jsem v koncích
    čtvrtek 2. dubna 2015 10:50
  • Tak začni vylučovat problémy jeden po druhém. Nejprve otestuj funkčnost IIS jako takového, bez nějaké aplikace. Takže v tom virtuálním adresáři vytvoř soubor INDEX.HTM, do něj napiš například obligátní "Hello world!" a přistup na adresu HTTP://FQDN-TVEHO-SERVERU/ESHOP/INDEX.HTM. Pokud v prohlížeči uvidíš obsah souboru INDEX.HTM, tak není problém v síti, DNS, firewallu ani IIS jako takovém a musíš hledat někde jinde (asi na straně té aplikace).

    BB

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:14
    čtvrtek 2. dubna 2015 11:10
  • Tady problém nevidím. druhý web(aplikace) naprosto bezproblémový chod. Ale tohle mi nedá už spát. eshop i první web dělala externí firma. Už jsem to s nimi taky konzultoval ale také netuší co by to mohlo být.
    čtvrtek 2. dubna 2015 11:36
  • Ten problém tam skutečně není nebo ho tam Ty nevidíš?

    Zapnul sis v IIS error reporting na úroveň "Detailed errors", abys viděl podrobný chybový výpis v prohlížeči?


    BB

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:14
    čtvrtek 2. dubna 2015 11:41
  • No měl podrobné chyby pro místní požadky atd... tak jsem to přenul jen "detailní". Eshop se na pár sec rozjel. Jsem z toho dost jelen. no na serveru mám nyní přepnuto jen na detailní. jak ASP tak chybových stránkách. Ale ani chrome a IE bez detailnich výstupů.

    • Upravený PolipCZ čtvrtek 2. dubna 2015 13:01
    čtvrtek 2. dubna 2015 12:29
    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:30
    čtvrtek 2. dubna 2015 19:44
    Vlastník
  • eshop se podařil rozjet. bohužel jede pouze na IP. v okamžiku kdy se mi vytvoří předpona www. padne.
    pátek 3. dubna 2015 6:13
  • Co přesně znamená věta "kdy se mi vytvoří předpona www"? Kde se Ti vytvoří?


    BB

    pátek 3. dubna 2015 6:18
  • lokálně zavolám 192.168.1.5/eshop připojím se bez problému. jakmile použiji odkaz na nějaký produkt okamžitě naskočí www.192.168.1.5/....... a padne to
    pátek 3. dubna 2015 6:23
  • To znamená, že WWW tam doplňuje aplikace. Proč?

    Co to udělá, když nepoužiješ IP adresu, ale FQDN? Máš v DNS alias pro WWW?


    BB

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:14
    pátek 3. dubna 2015 7:06
  • FQDN vyhazuje úplně to samé. automaticky naskočí www. První web se nevrací www, je možné že by byla chyba aplikace? Nejsem její tvůrce. Firma ho sama nahrála a nastavila. Žádné aliasy zatím nastaveny nemám
    pátek 3. dubna 2015 8:02
  • Aha, ty v DNS nemáš alias na WWW a čekáš, že ti přeloží adresu WWW.DOMENA.LOCAL?

    BB

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:15
    pátek 3. dubna 2015 8:13
  • Ne právě nechci aby mi to překládalo www. Mám tam http://46.13.158.188  (první web), zatím chci aby to vypadalo stějně i eshop http://46.13.158.188/eshop (externí adresy pro přístup) eshop není připraven na spuštěný na ostrý provoz.
    pátek 3. dubna 2015 8:18
  • Proč proboha vůbec přistupuješ k webu na IP adrese?

    Když už tedy chceš provozovat web na IP adrese (což je samo o sobě nesmysl), seznámil jsi s tímto požadavkem tvůrce webu?


    BB

    • Označen jako odpověď PolipCZ pátek 3. dubna 2015 9:15
    pátek 3. dubna 2015 8:21
  • Já s tím naprosto souhlasím, že je to blbost. ale vedení trvá na svém. Takže z toho důvodu je to takhle blbě. Důvod proč nevím ani já sám.
    pátek 3. dubna 2015 8:28
  • Promiň, ale ty jako administrator si necháš od vedení (předpokládám, že laického) mluvit do technických detailů? To je přece Tvoje práce jim vysvětlit, že jejich požadavek je nesmyslný. Pokud to neuděláš a jen tupě plníš přání a příkazy, pak se nesmíš divit.

    BB

    pátek 3. dubna 2015 8:31
  • No oni všechno umí všechno znají. Jede první web tak prostě pojede stejně tak eshop. V tom je kámen úrazu přesto nejede vlak.
    pátek 3. dubna 2015 8:42
  • zkusím vytvořit alias zda se to rozjede po té nebude jiné řešení pokud budou chtít provozovat eshop
    pátek 3. dubna 2015 8:43
  • Alias je ti k ničemu, dokud tam budeš přistupovat přes IP adresu.

    BB

    pátek 3. dubna 2015 8:47
  • No zkusil jsem první vytvořit na hostingu alias na server... eshop i druhé web je plně funkční

    pátek 3. dubna 2015 9:04
  • Každopádně vám všem děkuji za rady. Pokud vím že eshop je funkční tímhle už se poperu
    pátek 3. dubna 2015 9:11
  • Označ prosím odpovědi, které Ti pomohly problém vyřešit.

    BB

    pátek 3. dubna 2015 9:13