none
Windows server 2008 R2

    Dotaz

  • Dobrý den,

    trápí mě jakýsi podivný problém, na serveru mi nechodí vzdálená plocha. Tvaří jako by vůbec nebyla zapnutá (přičemž je) a ve službách normálně běží, to že to nefunguje z venku bych pochopil že nemám někdy otevřený port, ale nefunguje mi ani z toho servru pokuď zadám do kolonky počítač: 127.0.0.1 nebo localhost. Tak okamžitě vyhodí hlášku 1) Nebyl povolen přístup k serveru

                                             2) Výdálený počítač je vypnutý

                                             3) atd

    Firewall vypnutý.

     

    Nenapadá vás někoho kde může být problém?

     

    Díky, s pozdravem Dominik

    9. srpna 2011 14:18

Odpovědi

  • Na serveru dejte Win + Pause/Break a v Advanced System Settings kliknete na list Remote. V dolni polovine listu mate tri moznosti, prvni je zakaz pouzivani pripojeni pres vzdalenou plochu, druha moznost je pro mene bezpecne spojeni a treti je pro zabezpeceny pristup. Pokud se pripojujete z Windows XP (*), pouzijte druhou moznost, pokud se pripojujete z Windows 7, tak volite treti moznost. Tim spojeni "aktivujete" a nemusite se starat o firewall, protoze si system firewall nakonfiguruje sam pri "aktivaci" sluzby (spravne povoleni = allow).

    Ze stanice pouzivate pri pripojeni skutecnou IP adresu serveru, jmeno administrativniho uctu a heslo. V nastaveni muzete urcit, jak se bude spojeni chovat (sdilene prostredky...)

    Na pokusy s local hostem (127.0.0.1) zapomente, nemaji smysl.

    [(*) Pokud mate Windows XP SP 3 s nainstalovanym RDP klientem posledni verze, bude fungovat i varianta TRI.]


    9. srpna 2011 14:50
    Moderátor

Všechny reakce

  • Zdravím,

    pro vzálenou plochu bych zkusil povolit ve firewalu port 3389. Ale chtělo by to minimálně napsat jakou verzi serveru používáš a co tam máš (AD DC, DHCP, DNS....)

    SL


    9. srpna 2011 14:31
  • Firewall mam momentálně vypnutý, mě nejde vůbec do hlavy proč to nejde ani z toho serveru se připojit sám na sebe. Tam už je asi někde špatně.

     

    Verze 2008 R2 Standart

     

    Na serveru mi běží : AD DC, DHCP, DNS , souborovej server, služba síťové zásady a přístup.

    9. srpna 2011 14:46
  • A v EventLogu nic není? Může být problém v nastavení DNS..
    Jake je nastavení TCP/IP?
    9. srpna 2011 14:50
  • Na serveru dejte Win + Pause/Break a v Advanced System Settings kliknete na list Remote. V dolni polovine listu mate tri moznosti, prvni je zakaz pouzivani pripojeni pres vzdalenou plochu, druha moznost je pro mene bezpecne spojeni a treti je pro zabezpeceny pristup. Pokud se pripojujete z Windows XP (*), pouzijte druhou moznost, pokud se pripojujete z Windows 7, tak volite treti moznost. Tim spojeni "aktivujete" a nemusite se starat o firewall, protoze si system firewall nakonfiguruje sam pri "aktivaci" sluzby (spravne povoleni = allow).

    Ze stanice pouzivate pri pripojeni skutecnou IP adresu serveru, jmeno administrativniho uctu a heslo. V nastaveni muzete urcit, jak se bude spojeni chovat (sdilene prostredky...)

    Na pokusy s local hostem (127.0.0.1) zapomente, nemaji smysl.

    [(*) Pokud mate Windows XP SP 3 s nainstalovanym RDP klientem posledni verze, bude fungovat i varianta TRI.]


    9. srpna 2011 14:50
    Moderátor
  • Co je to za blbost, chtit si otevrit sessionu na svem vlastnim stroji?
    Samozrejme ze to nefunguje a je to tak dobre, k cemu by to bylo dobre???
     
    L.
     
    > Dobrý den,
    >
    > trápí mě jakýsi podivný problém, na serveru mi nechodí vzdálená plocha.
    > Tvaří jako by vůbec nebyla zapnutá (přičemž je) a ve službách normálně
    > běží, to že to nefunguje z venku bych pochopil že nemám někdy otevřený
    > port, ale nefunguje mi ani z toho servru pokuď zadám do kolonky počítač:
    > 127.0.0.1 nebo localhost. Tak okamžitě vyhodí hlášku 1) Nebyl povolen
    > přístup k serveru
    >
    > 2) Výdálený počítač je vypnutý
    >
    > 3) atd
    >
    > Firewall vypnutý.
    >
    > Nenapadá vás někoho kde může být problém?
    >
    > Díky, s pozdravem Dominik
    >
     
     
    9. srpna 2011 16:34
  • Na "podezrelem server" si spustte v CMD NETSTAT -A.

    Mezi TCP porty mate Listener na portu 3389? = posloucha Remote desktop sluzba na svem portu a ceka na spojeni?

    11. srpna 2011 8:22
  • Pokud se povoli pripojeni na RD, pak se automaticky nastavi ve firewallu pristup pres port 3389

    Test, ktery uvadi tazatel je nesmyslny. Nepripojite se na konzoli serveru pres RDP na sebe. Odezva pocitace je: Your computer could not connect to another console session on the remote computer because you already have a console session in progress.

    11. srpna 2011 8:41
    Moderátor
  • Z puvodniho dotazu vyplyva, ze RDP nechodi ani odjinud. cituji: " to že to nefunguje z venku bych pochopil ..." a take uz nekolikrat zaznelo, ze neni zapnuty zadny FW.

    A proto se ptam zda RDP sluzba nasloucha na svem portu. Vsichna zatim doporucena reseni resila problem shora. Ja se snazim o druhy smer. Je RDP port na svem miste?


    11. srpna 2011 10:08
  • Takze shrnuto:

    1. Sluzba udajne bezi (viz provazani portu s PIDem v 2.)

    2. Nemame informaci, zda dava "netstat -ano" spravnou odezvu, tedy indikaci, ze port 3389 je otevreny. Nakonec by takovy test mohl objevit, ze byl port pro RD zmeneny.

    3. Nemame informaci z jakeho klienta se testovalo spojeni. Pokud by bylo nastavene RD na maximalni bezpecnost, pak klient s RDP nizsi verze se "nechyta".

    4. Test na sebe (localhost) nema smysl. A nevime, zda byl test delany je stejnem subnetu.

     

    11. srpna 2011 10:30
    Moderátor