none
RAID 1 - jak nastavit bootovani z obou disku

    Dotaz

  • Ahoj,

    po nejakem casu googleni jsem to vzdal a rovnou se zeptam. Je ve Win 2008 R2 Ent. nejaka moznost jak na stavit RAID 1 tak aby byl stroj schopen nabootovat z jakehokoliv disku? Rozumnej - mam 2 disky s dyn. oddily nastaveny jako mirror. Pokud, ale ten prvni(puvodni) disk vytahnu a zkousim bootovat jen z druheho tak se nedostanu ano do toho menu win boot managera. Jak to vypada? No, stroj se neustale dokola rebootuje. Pritom v device manageru je uvedeno na druhem disku ze ma priznak "boot". V BIOSu by melo byt vse ok. Jeste me napada zda neni treba nejak v systemu nastavit to aby to bootovalo aj z druheho disku.

    Muzete me prosim nasmerovat k reseni - klidne mi staci odkaz kde se doctu jak na to.

    V prilozenem screenu posilam nahled z device managera.

    31. října 2011 13:12

Odpovědi

  • RAID1 byl trosku opruz i na starsich systemech. Napr v NT4 serveru (jeste nemel dyn.disky) se zase musel RUCNE pridavat MBR a nastavit oddil jako bootovaci. Takze se vlastne nic moc nezmenilo :)

    Takze to mam chapat tak, ze po pouziti bootrec mate co jste chtel? tj. system se spousti i z HDD1 po vysunuti HDD0?

    10. listopadu 2011 8:42

Všechny reakce

  • Musíš mít mirrored obě partition, na té 100MB jsou uložené bootovací soubory. Nebo lépe mít HW raid.
    31. října 2011 13:34
  • HW RAID v mem pripade nepripada v uvahu. Z te 100MB partition kde jsou ty boot soubory jsem udelal dynamicky disk a z tech zbylych 100MB na druhem disku taky. Kdyz ale kliknu pravym na tu 100MB part. kde jsou ty boot soubory nenabidne mi to "Add mirror...". Takze jak to mam propojit? Zkousel jsem ten druhy nechat nealokovany. Potom kdyz kliknu na 100MB boot part. mam moznost  dat add mirror....dam "Add mirror", vyberu "disk 1" a po chvili dostanu hlasku "no extents were found for the plex". Dalsi moznosti me nenapadaji.

    Nechce se mi verit ze ve Win 2008 R2 NENI moznost jak vytvorit sw RAID 1 s tim, aby bylo mozne bootovat z obou disku.


    Jeste me napada ... co by se stalo kdybych ten RAID rozbil a nejprve syncnul ten 100MB oddil a pak az ten velky? Mozna by to slo, ale myslim si ze by se syncnul jen ten maly a u velkeho by to pak psalo stejnou hlasku "no extents were found for the plex".
    • Upravený polo939 31. října 2011 15:00
    31. října 2011 14:58
  • Myslim, ze chybka nastala pri tvorbe zrcadla na druhy fyzicky disk. Mel jste k 100MB na primarnim disku pripojit druhy  dynamicky disk a nechat vytvorit 100MB RAID 1 a pak k cecku na prvnim disku pripojit zbytek z druheho disku. (Obcas se vyplati nevytvaret na primarnim disku bootovaci oddil v cele volne kapacite.)
    31. října 2011 16:28
    Moderátor
  • Cau, tak nepomohlo ani to kdyz jsem vytvoril RAID 1 toho 100MB oddilu a nasledne RAID 1 toho zbytku. Kdyz vytahnu prvni disk (ten na ktery jsme instaloval win a ze ktereho stroj umi bootovat), tak to proste nenabootuje. Pro ilustraci prekladam screen z disk management.

     

    1. listopadu 2011 10:20
  • Odpovedel jsem na stejnou otazku v anglickem foru. Problem bude v absenci aktivniho oddilu.

     

    1. listopadu 2011 15:21
    Moderátor
  • Aha:) Diky, jelikoz jsem nevedel, jak to dopadne na tomto foru, zalozil jsme jeste stejny topic na en foru.  Zaroven jsem tam dal odpoved na Vasi radu. Dalsi posty davejte prosim pokud mozne sem, at to vlakno neni duplicitni. Tam to necham byt, budu reagovat jen pripade, ze by nekdo napsal.

    Diky za pochopeni.

    1. listopadu 2011 17:57
  • Primarni disk byl nastaveny spravne jako aktivni a druhy disk "opisoval" zmeny. Pokud pracujete jen s druhym diskem, tak po rozpojeni disku musite tuto funkcionalitu "prisoudit zdravemu disku"(tj. druhemu disku). Moznosti je vice, muzete udelat jednoduse recovery z instalacniho DVD, nebo dat disk do jineho pocitace a nastavit aktivni oddil treba pomoci utilitky  diskpart. (Nevim, jake disky mate, jeste mozna bude treba "rici" BIOSu, ze ma startovat z tohoto disku.)

    PS: Myslim, ze crossposting mezi ruznymi jazykovymi fory nevadi. Formalne je na anglickem foru vic potencialnich lidi, kteri odpovi, ale na ceskem foru necekate dele.


    1. listopadu 2011 19:52
    Moderátor
  • Tak jsem si pro forma udelal RAID1 na W7, coz predpokladam je stejne jako u W2008 R2. A funguje to tak, jak ma.

    Muj postup: 

    • prvni disk obsahuje oddil 100MB s Boot loaderem a druhy oddil se systemem.
    • Prevedu HDD na dynamicky, restart
    • Pridam prazdny disk (HDD1), ktery system nikdy nevidel - nezna jeho GUIDy.
    • pridam zdcadlo k boot loaderu a systemu, pockam na synchronizaci - vysledkem je stejna situace jako 2. obrazek od polo939, restart

    Vysledkem techto operaci je boot nabidka pri startu systemu, ktera obsahuje 2 zaznamy:

    • Windows 7
    • Windows 7 - secondary plex

    Tj. pri mirroru si OS sam aktualizoval BCD data a pridal zaznam pro druhy disk. Pri padu HDD0 (fyzicky jsem odebral) system normalne bootoje a v boot nabidce zvolim secondary plex (druhy disk).

    V podstate stejne o tom mluvi

    http://www.techotopia.com/index.php/Mirroring_Windows_Server_2008_GBT_and_MBR_Boot_and_System_Disks

    Jak se vam chova boot z HDD1?


    2. listopadu 2011 12:26
  • Dobry den,

    diky za info i testy. Vse co jste popsal je stejne i u me. Ay na to ze kdyz vytahnu HDD0 a necham tam jen HDD1, ze ktereho chci bootovat tak pri zapnuti serveru se nikdy nedostanu az k Vami posanemu menu

    • Windows 7
    • Windows 7 - secondary plex

    Server se periodicky rebootuje porad dokola. V BIOSU jsem nenasel nic co by to mohlo zpusobovat. Mozna ze ten druhy disk opravdu nema flag "boot". Fyzicky se k serveru dostnu v pondeli. Myslite, ze bych Windows zkousnuly kdybych ten flag nastavil fdiskem v Linuxu?:)

    P.S. I kdyz ve Vasem odkazu se pise ze pri mirrorovani se:

    It will also create the master boot record (MBR).

    Takzeby vse melo byt OK.

    3. listopadu 2011 20:08
  • A nabidka s secondary diskem je pri bootu z HDD0? Tj. problem je jen neboot z HDD1?

    Pravdepodobne by to spravilo instalacni medium a prikazy utility bootrec. Viz http://support.microsoft.com/kb/927392

    Protoze si tak matne uvedomuji, ze disk HDD1, ktery jsem pouzil byl puvodne s Win2003 a pak jen smazany oddil. Tj. MBR tam urcite byl od minula.

    4. listopadu 2011 7:10
  • Dobry den,

    kdyz v serveru necham jen HDD0 tak pri bootovani se nabidka "secondary plex" objevi. Co mi, ale prijde divne je to, ze na sestaveni bootujiciho RAID 1 jsou nutne takove obstrukce jako pouziti utility bootrec, navic v systemu Win2008R2:)

    9. listopadu 2011 16:03
  • A to jeste muzete byt rad, kdyz se na "zdravy disk nenazrcadli" nejaka podstatna chyba. Pak jste v haji. To co delate je vyjimecna akce, takze trochu nepohodli nejak zvladnete.
    9. listopadu 2011 17:18
    Moderátor
  • RAID1 byl trosku opruz i na starsich systemech. Napr v NT4 serveru (jeste nemel dyn.disky) se zase musel RUCNE pridavat MBR a nastavit oddil jako bootovaci. Takze se vlastne nic moc nezmenilo :)

    Takze to mam chapat tak, ze po pouziti bootrec mate co jste chtel? tj. system se spousti i z HDD1 po vysunuti HDD0?

    10. listopadu 2011 8:42
  • Dobry den,

    k bootrec jsem se jeste nedostal - jak budu fyzicky u serveru tak to vyzkousim, ale v podstate mate pravdu - pokud to funguje jak rikate, tak muzeme tento problem povazovat za vyreseny.

    Dekuji za pomoc.

    10. listopadu 2011 9:03