none
Mapování disku

    Dotaz

  • Dobrý den, mám problém s namapováním disků.
    AD běží na W2008, stanice jsou XP. Pomocí logonscriptu to není problém, mám baťák

    net use n: \\server\složka heslo /USER:nedomenovyuživatel
    SUBST U: "%homepath%"\data 

    Chtěl jsem to provést elegantní řešení pomocí preferencí, ale nejde to. I když u mapování N mám zadáno jméno i heslo.
    Disk N vyžaduje heslo a U se vůbec nevytvoří.
    Server není zařazený v doméně, beží na linuxu (samba) a asi připojení do domény neprojde.
    Připojení složky data jako U potřebuji z důvodu určitého programu, který používají pouze někteří uživatelé a neměla by být pro jiné uživatele, kteří se na PC přihlásí a nemají mít do složky přístup.
    Poradí mi někdo?
    4. března 2009 9:37

Odpovědi

  • Ne, tím to není, zkoušel jsem i PC s windows 7, ani na těch to pomocí preferencí nejde. Zatím používám připojení pomocí logonscriptu, snad na to příjdu časem.
    • Označen jako odpověď marksenior 20. března 2009 10:24
    16. března 2009 6:41

Všechny reakce

  • Zkus pomoci Group policy nastavit mapovani uzivatelum pomoci GPO. Jde to bez skriptu, rychlejsi, prehlednejsi a krasne nastavitelne. V cestine myslim sprava zasad skupiny.
    Budes-li chtit (neproklikas se sam), poznaviguju cestu..
    4. března 2009 9:52
  • Já to vytvářel pomocí GPO, v GPMC jsem v gpo dal nový, vytvořil filtr na skupinu kde chci aby bylo mapování a původní filtr jsem odstranil. Nový objekt jsem přejmenoval na mapovani a editoval. V User Configuration jsem v Preferences a Windows Setting dal Drive Maps dal new mapped drive.
    Action: Create, zkoušel jsem i Update
    Location: %homepath%\data
    Drive Letter: U
    To se při přihlášení uživatele do domény vůbec neprojevilo, nevím, jestli  je správně %homepath%\data.

    Pro připojení složky z linuxového serveru jsem  použil cestu\\server1\slozka1, zaškrtl jsem reconect, label test,use letter N, v optional jsem zadal jméno a heslo, pod kterám se přihlášuju na složku.

    Po přihlášení je sice vidět namapovaný disk,  ale není připojený, musím zadat heslo ručně abych se do složky (disku N).  Jestli to beru špatným směrem, tak bych poprosil o navigaci.
    Děkuji



    4. března 2009 11:34
  • To asi nemám, zkusím v pátek a napíšu. Zatím díky.
    4. března 2009 16:37
  • Ne, tím to není, zkoušel jsem i PC s windows 7, ani na těch to pomocí preferencí nejde. Zatím používám připojení pomocí logonscriptu, snad na to příjdu časem.
    • Označen jako odpověď marksenior 20. března 2009 10:24
    16. března 2009 6:41
  • nepokousis se mapovat disk na pouzite pismeno? Zkontroluj pred restartem pomoci

    net use
    net use * /delete
    net use /persistent:no
    ...


    MP
    20. března 2009 12:29
    Moderátor
  • ne, nikoliv, přes script to jde, mám pocit, že  %homepath%\data nenajde správnou cestu a u toho připojení na linuxový server to nevezme jméno a heslo. Když jsem použil připojení na jiný server, kde se nemusím připojovat pod jménem a heslem, tak se disk připojí.
    26. března 2009 10:15