none
New VHDX in HyperV VM not recognized

    Dotaz

  • We created a new VHDX in HyperV Manager and mounted it in one of our virtual machines via a SCSI controller. HyperV Manager says it's connected without any errors.

    After connecting the VHDX to the VM, we checked whether the disk was recognized by the VM in diskpart but it didn't show up there. We then tried creating two test VHDX disks with just 1 GB size each (1 fixed and 1 dynamic). Both got recognized once, but not the other times we tried mounting them. The chance of being actually seen by the VM seems to be pretty random.

    The HyperV host and guest machines are both on Windows Server 2012 R2 with no GUI installed. We couldn't check a more detailed hardware information of the hard drive (VHDX) via device manager because it is not installed in the VM's Windows version. The HyperV Integration Services (mounted vmguest.iso via HyperV) are also on the latest version, the installer says.

    Has anyone experienced this issue before or has some tips or ideas on how to fix this? Any help is appreciated very much.

    Thank you!

    8. května 2018 12:34

Všechny reakce

  • Hi,
    Based on the complexity and the specific situation, we need do more researches. If we have any updates or any thoughts about this issue, we will keep you posted as soon as possible. Your kind understanding is appreciated. If you have further information during this period, you could post it on the forum, which help us understand and analyze this issue comprehensively.
    Sorry for the inconvenience and thank you for your understanding and patience.
    Best Regards,

    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    9. května 2018 9:45
  • Hi ,

    From your problem description, it seems that only the one VHDX cannot be recognized by VM, right?

    I noticed that we had tried to create another two VHDX with 1 GB to test. May I know we create the three vhdx with the same way?

    Would you please provide the screenshot of how add the VHDX to the VM?

    Best Regards,

    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    10. května 2018 10:06
  • Hi,

    thanks for your answer!

    Yes, we have multiple other VHDX disks attached to that exact VM which work without problems. Just the latest one isn't recognized properly.

    We created the VHDX and the test disks with the same method in HyperV Manager: Right-click VM > Properties > SCSI Controller > Hard drive > Add > New

    Here is a screenshot of how we attach the disk: i.imgur.com/3RFqGbW.png

    Regards

    11. května 2018 9:54
  • Hi,

    Would you please add the VHDX with IDE controller instead of SCSI controller?

    Best Regards,

    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    14. května 2018 9:51
  • Hi,
    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    16. května 2018 9:23
  • Hi,

    thanks for your answer.

    We can try attaching the disk via a new IDE controller. For that to work, we have to schedule a downtime first as there is no IDE controller currently. This could take a few days, we will report back the result once we've done that.

    Best regards

    17. května 2018 8:49